Koozali.org formerly Contribs.org

Cannot Access Server Manager or Web from external

Cannot Access Server Manager or Web from external
« on: April 24, 2007, 05:07:56 PM »
Hi

I am trying to solve the following problem

Trying to connect to either the server manager or the default website from an external address I get no joy!!

However everything is accessible from the internal IP address.

Server is set up as server/gateway - no ISP firewalls - nothing

I have tried everything I could think of, to no avail.
I have searched the forums till I was blue in the face - could not find it.

The funny thing I have noticed though is the following
Running iptables --list
Chain InboundTCP_8012 (1 references)
target     prot opt source               destination
denylog    all  --  anywhere            !196.xx.xx.xx
ACCEPT     tcp  --  anywhere             anywhere           tcp dpt:auth
denylog    tcp  --  anywhere             anywhere           tcp dpt:ftp
denylog    tcp  --  anywhere             anywhere           tcp dpt:www
denylog    tcp  --  anywhere             anywhere           tcp dpt:https

denylog    tcp  --  anywhere             anywhere           tcp dpt:imap2
denylog    tcp  --  anywhere             anywhere           tcp dpt:ldap
denylog    tcp  --  anywhere             anywhere           tcp dpt:pop3
denylog    tcp  --  anywhere             anywhere           tcp dpt:1723
ACCEPT     tcp  --  anywhere             anywhere           tcp dpt:smtp
ACCEPT     tcp  --  anywhere             anywhere           tcp dpt:ssh
denylog    tcp  --  anywhere             anywhere           tcp dpt:telnet

Also I have noticed this in the httpd.conf file

Listen 10.179.219.253:80
Listen 127.0.0.1:80

and

<IfModule mod_ssl.c>
Listen 10.179.219.253:443
Listen 127.0.0.1:443

Whereas another box has the following

Listen 0.0.0.0:80

and

Listen 0.0.0.0:443


In all fairness - I have tried deleting the offending iptables rules and replaced them with Accept rules.

No Luck

Maybe I am missing a small thing that is causing this problems

Any ideas very welcome!!

Thanks in advance

Problem Solved
« Reply #1 on: April 24, 2007, 08:56:46 PM »
Seemed to have sorted it out - will see after next reboot

Here is wat I did

/sbin/e-smith/config getprop httpd-e-smith access

Mine was set to private for an unknown reason
So I.....

/sbin/e-smith/config setprop httpd-e-smith access public
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
/sbin/e-smith/expand-template /etc/httpd/admin-conf/httpd.conf
/sbin/e-smith/expand-template /etc/rc.d/init.d/masq
service masq restart
/etc/rc.d/init.d/httpd-e-smith graceful


After all of that it seems to be working

Hope this post can help someone else!

mine is set to Public
« Reply #2 on: June 24, 2007, 09:05:26 PM »
So i think its something else.

My webmail is working though. So i dont know what the problem is. Please help
...