Koozali.org formerly Contribs.org

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE

Offline Knuddi

  • *
  • 531
    • http://www.smeoptimizer.com
[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« on: April 13, 2007, 12:58:51 PM »
All,

I have finally found the problem that has prevented an upgrade to later version of ClamAV.  Since the upgrade requires a patch to be applied and if not done correctly will kill Clam and close your mail I have decied not to start an automatic update this time.

This means you HAVE to download and run the install/upgrade script which is available from my site:

# wget -N http://sme.swerts-knudsen.dk/downloads/AntiVirus/antivirus_install.sh
# sh antivirus_install.sh

Enjoy,
Jesper

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #1 on: April 13, 2007, 02:10:42 PM »
Maybe good to mention that this is NOT intended for SME7

Offline Knuddi

  • *
  • 531
    • http://www.smeoptimizer.com
[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #2 on: April 13, 2007, 02:31:45 PM »
Absolutely - that's why its in the SME 6.x contribs area :-)

Anyways, the script will bail out and not run under SME 7x

Better safe than sorry...

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #3 on: April 13, 2007, 03:44:54 PM »
Jesper,

What happened in these updates. I still have 3 servers doing 601 and they vary in structure & apps. But no matter what server I check they all become seriously faster (when I have to make an estimate, 20%)

Wish this had come earlier... I'm in the process of upgrading to 7

Offline Knuddi

  • *
  • 531
    • http://www.smeoptimizer.com
[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #4 on: April 13, 2007, 07:15:03 PM »
Clamd's RAWSCAN command which is used by amavis simply hangs so I had to change amavis-ng to use another (SCAN) command.

What do you mean about faster? Sure SME6 is based on an ancient kernel and all others are newer and faster. I have 4 servers with SME6 and 1 with SME7. My main company mailserver is still SME6 (this is why I needed this thing to work...)

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #5 on: April 13, 2007, 07:32:56 PM »
I meant that the SME6 servers became faster after installing the new scanner you just handed out.

Harro

cc_skavenger

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #6 on: April 14, 2007, 06:18:12 AM »
thanks again for all your hard work!!

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #7 on: April 14, 2007, 06:30:19 PM »
Thank Knuddi for your efforts.

stefan_gk

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #8 on: April 17, 2007, 09:01:29 AM »
I successfuly installed 0.90.2 version of clamav with antivirus_install.sh, but today I got the following message in admin mailbox:

Code: [Select]

...
Subject: Clam Antivirus was updated

The following updates were downloaded and installed:
  - clamav-es-0.88.7-es01.i386.rpm
  - clamav-es-libs-0.88.7-es01.i386.rpm
  - sme-antivirus-1.4.6-1.noarch.rpm

regards,
The Automatic Clam Antivirus updater


Maybe UCA script is doing something wrong?

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #9 on: April 18, 2007, 09:44:16 PM »
Hi Knuddi,

great job, but there is an error in the /etc/freshclam.conf.

The content of the template fragment

/etc/e-smith/templates/etc/freshclam.conf/55NotifiyClamd

should be

NotifiyClamd /etc/clamd.conf

otherwise clamd is NOT reloaded after an db update.

CU Hartmut

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #10 on: April 19, 2007, 12:04:44 AM »
Wondering how you came to that conclusion...

Code: [Select]

# Send the RELOAD command to clamd.
NotifyClamd yes

# Run command after database update.
OnUpdateExecute /bin/date -R > /usr/share/clamav/last_update


The Update Reload command is below it. NotifyClamd is no more then a true or false parameter and not a reference.

Harro

Offline Knuddi

  • *
  • 531
    • http://www.smeoptimizer.com
[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #11 on: April 19, 2007, 04:31:49 PM »
I am aware of three bugs/problems in this release.

1) freshclam.conf: NotifyClamd should be /etc/clamd.conf rather than just Yes. Clam updates the database on a regular basis (every 1 hour) as far as I know so its not critical.

2) The clamscan command (scan if ibays, etc.) has an incorrect archive command (--unace) which has been obsoleted.

3) The UCA script is a little confused since the current installed version (0.90.2) is newer than what it sees when checking for updates. This is an unfortunate issue that is a consequence of the way this update is applied. I think that you should only see this once.

I will around and send and update out one of the next days - none of the above problems are critical.

Maybe I will release as normal release and you will all be normally and automatically updated.

Sorry all of you (that has not read this thread) and who will get a sick server - I hope you find this quickly....

Rgds,
Jesper

Offline Knuddi

  • *
  • 531
    • http://www.smeoptimizer.com
[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #12 on: April 20, 2007, 09:06:18 AM »
I have now compiled a new release of the sme-antivirus package that should solve the above mentioned problems.

Can be installed directly via:

# rpm -Uvh http://mirror.contribs.org/smeserver/contribs/swerts-knudsen/AntiVirus/clam_090/sme-antivirus-1.4.8-1.noarch.rpm

and I will make it auto update as well. Users with <0.90 will be notified that there is a new release and a failing admin mail but do dead mail system.

Rgds,
Jesper

Offline Knuddi

  • *
  • 531
    • http://www.smeoptimizer.com
[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #13 on: April 22, 2007, 09:05:25 PM »
And now yet another version that does the patch has been released. Together with this is have released Clam 0.90.2 for auto update.

Hope that this will be successful for the ~1300 user/servers that I expect to get updated over the next 24 hours......

BTW: I had a strange problem today that I have not been able to figure out where originated from. Suddenly my server-manager panels didn't work anymore and I got permanent qmail-queue errors. It turned out that my /tmp directory had wrong right setting (yey it took a while to figure that out).

If you /tmp has the following rights (see with ls -la /):

drwxr-xr-t    8 root     root ...

then change with

# chmod uga=+rxwt /tmp

and restart server.

Offline allun

[Announce]: ClamAV updated to 0.90.2 - IMPORTANT UPDATE
« Reply #14 on: April 22, 2007, 11:10:35 PM »
Heya - just wanted to let ya know we had the same problem this morning with our server's AV stopping and mail being put into problems directory -  the /tmp permissions error was also present.
 After reading this thread up to this point and updating as instructed it is all working again.  

Thanks for your efforts Knuddi :-)
...