Koozali.org formerly Contribs.org

[ANNOUNCE] smeserver-trac contrib

Updated version of smeserver-trac available
« Reply #30 on: April 27, 2007, 09:29:22 AM »
Hi All,

Just to let you know that an updated version of 'smeserver-trac' is now available.

Main updated feature is that for SME boxes that have multiple domains
each trac project can be configured for which domain it should appear.

Other updates are tighter integration with the SME environment so that
changes/deletions in users/groups/domains/repositories do not leave
the trac project in an improper state.

Enjoy!

Marco
Adelaide - Australia

[ANNOUNCE] smeserver-trac contrib
« Reply #31 on: April 27, 2007, 12:06:47 PM »
Is there a solution for this ??


[root@server]# yum --enablerepo=smedev --enablerepo=through-ip install smeserver-trac
==============================================================
WARNING: Additional commands may be required after running yum
==============================================================
Loading "fastestmirror" plugin
Loading "smeserver" plugin


Error getting repository data for through-ip, repository not found
================================================================
No new rpms were installed. No additional commands are required.
================================================================
...

[ANNOUNCE] smeserver-trac contrib
« Reply #32 on: April 27, 2007, 03:29:07 PM »
Quote from: "p-jones"
Error getting repository data for through-ip, repository not found


Have you followed the instructions from http://wiki.contribs.org/Trac and added the through-ip repository to yum?

Marco
Adelaide - Australia

[ANNOUNCE] smeserver-trac contrib
« Reply #33 on: April 27, 2007, 06:19:59 PM »
thf,

Great contrib.  Note my error:
Code: [Select]

[root@sme7test VirtualHosts]# expand-template etc/httpd/conf/httpd.conf
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/VirtualHosts/28SubversionContent: Use of uninitialized value in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/VirtualHosts/28SubversionContent line 247.
WARNING in /etc/e-smith/templates/etc/httpd/conf/httpd.conf/80VirtualHosts: WARNING: Template processing succeeded for //etc/httpd/conf/httpd.conf/VirtualHosts: 1 fragment generated warnings
 at /etc/e-smith/templates/etc/httpd/conf/httpd.conf/80VirtualHosts line 38
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/VirtualHosts/28SubversionContent: Use of uninitialized value in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/VirtualHosts/28SubversionContent line 247.
WARNING in /etc/e-smith/templates/etc/httpd/conf/httpd.conf/80VirtualHosts: WARNING: Template processing succeeded for //etc/httpd/conf/httpd.conf/VirtualHosts: 1 fragment generated warnings
 at /etc/e-smith/templates/etc/httpd/conf/httpd.conf/80VirtualHosts line 38
WARNING: Template processing succeeded for /etc/httpd/conf/httpd.conf: 2 fragments generated warnings
 at /sbin/e-smith/expand-template line 45

I installed as per yum instructions on SME Server 7.1.3 test server.  Install proceeded w/out error.  SM accessed thereafter, created a subversion repo  and then added a trac project.  I recieved an error when adding yet it did create it (named 'mybook')  Trying to access the repo from the new link in Trac project Environments panel gave me "Internal Server Error" so I looked at the logs and noted httpd.conf was not expanding.  That is when I attempted manual expansion of /etc/httpd/httpd.conf and received the error above.

BTW, do you have a bug entry for this contrib?

Thanks again for the contrib.

Craig

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
[ANNOUNCE] smeserver-trac contrib
« Reply #34 on: April 27, 2007, 11:23:34 PM »
The errors above are not from the trac contrib, but they seem to originate from the/my smeserver-subversion contrib. Would you be so kind to file it as a bug, for me to follow-up there?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

[ANNOUNCE] smeserver-trac contrib
« Reply #35 on: April 28, 2007, 01:16:37 AM »
Done.  bug #2943

Craig

Trac subdomain
« Reply #36 on: May 07, 2007, 05:35:51 AM »
Hi thf,

I have successfully written a custom template which creates a subdomain for my TRAC projects.

I had to use your virtual host template 29TracProjects as a reference because the httpd entry changes whenever a group or user is added/removed.

Anyway, my template looks for a special prefix string "trac_sd_" in the trac project name to determine whether it should have a subdomain created or not.
The template creates a subdomain of the type:
trac.project.domain
Note: The prefix can be changed, it is set on line 11, $trac_subdomain_identifier = "trac_sd_".

So, for a project named: trac_sd_project1
which is visible on the domain: mydomain.com
the following subdomain will be created: trac.project1.mydomain.com

I developed this template in the hopes that you might consider integrating something similar in a future realease of the trac contrib.
I think you will only need two new settings:
 - a tickbox Create subdomain [ ] (y/n).
 - a string project name [ ] (eg. project1 for trac.project1.domain).

I'm still very uncertain about the subdomains on this server though so I don't know if what I'm proposing will cause problems.
Should the project1 subdomain (and the trac.project1 subdomain) be added to the subdomains list or not?
Perhaps the project name could/should be a pull down list of configured  subdomains.
I've checked the forum & manual for subdomain setup information but it doesn't say much on how to point the subdomain to somewhere else on the server without suggesting a custom template.

I also don't know much about apache, so the security & redirect commands may need to be changed. Currently I redirect all port 80 traffic to 443 & require SSL.

Anyway, if your interested in my template you can download it from here, it needs to be placed in the /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf directory.

I've also developed a custom template that generates both a trac & svn subdomain.
Because the svn contrib doesn't include the domains option this template uses the trac domains for both.
It can be downloaded here.

Sorry about the marathon post.
I am happy using my custom template but I feel that the trac contrib (and the svn contrib) would be even better with the subdomain options.

Thanks
Blacknz

PS: Should this be put into bugzilla as a feature request (for both the trac & svn contribs) or is the forum a more appropriate place for this?

Re: Trac subdomain
« Reply #37 on: May 07, 2007, 06:03:20 AM »
Quote from: "blacknz"
I have successfully written a custom template which creates a subdomain for my TRAC projects.

Hi Black,

Thanks for your contribution. That looks great. I'll have a look on how that can be integrated when I get a chance to do some more work on smeserver-trac.

In terms of naming the subdomain, would project.trac.domain be more logical? Also, in that way, the trac.domain could be pointed to a summary page that shows all the configured trac projects.

Thanks for your efforts.

Regards,  Marco

Quote from: "blacknz"
PS: Should this be put into bugzilla as a feature request (for both the trac & svn contribs) or is the forum a more appropriate place for this?

Technically, it would be best in bugzilla, however, at the moment I don't think there is a category for smeserver-trac, but there is one for smeserver-subversion.
Adelaide - Australia

Re: Trac subdomain
« Reply #38 on: May 07, 2007, 07:06:30 AM »
Hiya,
Quote from: "thf"
In terms of naming the subdomain, would project.trac.domain be more logical?

I prefer a project oriented subdomain (trac.project.domain) as compared to a trac oriented subdomain (project.trac.domain).

It allows for other project oriented subdomains (trac.project.domain, svn.project.domain, wiki.project.domain) and the project.domain could be a project overview page.

Quote from: "thf"
Also, in that way, the trac.domain could be pointed to a summary page that shows all the configured trac projects.

I think this is still a good idea even with a project oriented approach.

Quote from: "thf"
Technically, it would be best in bugzilla, however, at the moment I don't think there is a category for smeserver-trac, but there is one for smeserver-subversion.

sme-subversion enhancement request #2967 created.

Blacknz

[ANNOUNCE] smeserver-trac contrib
« Reply #39 on: May 16, 2007, 07:11:19 PM »
Hi, I've tried to install contrib on a test environment and:

Error: Missing Dependency: smeserver-mod_python is needed by package smeserver-trac

I don't find smeserver-mod_python. I've tried yum --enablerepo base --enablerepo addons --enablerepo centosplus --enablerepo contrib --enablerepo extras --enablerepo smedev provides smeserver-mod_python with no success.

[ANNOUNCE] smeserver-trac contrib
« Reply #40 on: May 16, 2007, 10:42:34 PM »
Quote from: "hedererjs"
Hi, I've tried to install contrib on a test environment and:

Error: Missing Dependency: smeserver-mod_python is needed by package smeserver-trac

I don't find smeserver-mod_python. I've tried yum --enablerepo base --enablerepo addons --enablerepo centosplus --enablerepo contrib --enablerepo extras --enablerepo smedev provides smeserver-mod_python with no success.


I've done the test on a virtual machine with my production server and I've had a non resolved dependency too.

I've made a new test with a virtual machine with a pretty clean install and dependencies are solved but I've got these messages:

Quote
http://mirror.contribs.org/smeserver/releases/7/smedev/i386/RPMS/smeserver-mod_python-0.1-0.el4.sme.noarch.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.contribs.org/smeserver/releases/7/smedev/i386/RPMS/smeserver-mod_python-0.1-0.el4.sme.noarch.rpm: [Errno 4] IOError: [Errno ftp error] 450 smeserver-mod_python-0.1-0.el4.sme.noarch.rpm: No such file or directory
Trying other mirror.
http://mirror.contribs.org/smeserver/releases/7/smedev/i386/RPMS/smeserver-mod_python-0.1-0.el4.sme.noarch.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.contribs.org/smeserver/releases/7/smedev/i386/RPMS/smeserver-mod_python-0.1-0.el4.sme.noarch.rpm: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
(2/17): perl-Config-IniFi 100% |=========================|  46 kB    00:01
(3/17): python-setuptools 100% |=========================| 447 kB    00:05
(4/17): python-clearsilve 100% |=========================| 181 kB    00:02
(5/17): python-docutils-0 100% |=========================| 1.3 MB    00:37
(6/17): python-silvercity 100% |=========================|  13 kB    00:00
(7/17): mod_python-3.1.3- 100% |=========================| 568 kB    00:07
(8/17): tcl-8.4.7-2.i386. 100% |=========================| 897 kB    00:10
(9/17): xorg-x11-Mesa-lib 100% |=========================| 379 kB    00:05
(10/17): tk-8.4.7-2.i386. 100% |=========================| 838 kB    00:09
(11/17): python-imaging-1 100% |=========================| 358 kB    00:05
(12/17): fontconfig-2.2.3 100% |=========================| 117 kB    00:01
(13/17): xorg-x11-libs-6. 100% |=========================| 2.7 MB    00:40
(14/17): trac-0.10.3.1-2. 100% |=========================| 665 kB    00:09
(15/17): python23-silverc 100% |=========================| 175 kB    00:02
(16/17): clearsilver-0.10 100% |=========================| 192 kB    00:03
(17/17): smeserver-trac-0 100% |=========================| 103 kB    00:02


Error Downloading Packages:
  smeserver-mod_python - 0.1-0.el4.sme.noarch: failure: RPMS/smeserver-mod_python-0.1-0.el4.sme.noarch.rpm from smedev: [Errno 256] No more mirrors to try.
================================================================
No new rpms were installed. No additional commands are required.
================================================================


Help! I need somebody help...

where is this RPM?

[ANNOUNCE] smeserver-trac contrib
« Reply #41 on: May 17, 2007, 12:20:22 AM »
Investigating, it looks like smecontribs cvs doesn't fullfill a repository. or which one?

[ANNOUNCE] smeserver-trac contrib
« Reply #42 on: May 17, 2007, 12:34:27 AM »
after having downloaded it from CVS, and tried to extract (on Windows XP), 7-zip says smeserver-mod_python-0.1.tgz is invalid.

[ANNOUNCE] smeserver-trac contrib
« Reply #43 on: May 17, 2007, 04:01:22 AM »
Quote from: "hedererjs"
Error: Missing Dependency: smeserver-mod_python is needed by package smeserver-trac


It should be available from the smedev repository, but somehow it seems to have disappeared from there.

For the time being I have put a copy of the rpm in my through-ip repository (as detailed in http://wiki.contribs.org/Trac) so you can continue your install with

Code: [Select]
yum --enablerepo=smedev --enablerepo=through-ip install smeserver-trac

Regards,

Marco
Adelaide - Australia

[ANNOUNCE] smeserver-trac contrib
« Reply #44 on: May 17, 2007, 04:18:26 PM »
thanks, it works.

is the subversion repository created when creating an smeserver-trac project?

should there appear a smesubversion repository?