Koozali.org formerly Contribs.org

Update failed - dependency issue

AJB

Update failed - dependency issue
« on: March 01, 2007, 03:53:23 PM »
Hi all,

I'm new to this forum, and therefore not entirely sure whether I'm posting this in the right section. If not, please let me know.

I'm also somewhat new to SME Server, so please bear with me on this one :wink: .

I have been trying to run a yum update, but there seems to be a dependency problem. This is the output generated:
Code: [Select]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package rssh.i386 0:2.3.2-1.2.0.el4.sme set to be updated
---> Package e-smith-openssh.noarch 0:1.12.0-6.el4.sme set to be updated
---> Package openssh.i386 0:3.9p1-8.RHEL4.17.1 set to be updated
---> Package perl-Crypt-OpenSSL-Bignum.i386 0:0.03-3.el4.at set to be updated
--> Running transaction check
--> Processing Dependency: openssh = 3.9p1-8.RHEL4.12 for package: openssh-clients
--> Processing Dependency: openssh = 3.9p1-8.RHEL4.12 for package: openssh-server
--> Finished Dependency Resolution
Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.12 is needed by package openssh-clients
Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.12 is needed by package openssh-server

I take this to mean that I would need to have the package 3.9p1-8.RHEL4.12 installed first, but a quick peek in the server manager tells me that this is already the case.

Is this indeed a bit weird, or am I interpreting the yum update output the wrong way?

Thanks for the responses.

Update failed - dependency issue
« Reply #1 on: March 01, 2007, 05:45:25 PM »
This won't be any help, but I have seen the same thing for a few weeks now. I haven't really paid much attention to it because I am trying to migrate to a new server for that particular installation. I can't recall if it showed up after I installed a particular contrib or not.
Ryan