Koozali.org formerly Contribs.org

SME Server 7.1 Update 1

Offline wellsi

  • *
  • 475
    • http://www.wellsi.com
SME Server 7.1 Update 1
« on: February 27, 2007, 09:58:07 PM »
Announcement for 7.1
http://forums.contribs.org/index.php?topic=35019.0

Announcement for 7.1.1
The SME Server maintenance team is pleased to announce the release of SME Server 7.1 Update 1 (SME 7.1.1) This release has many fixes for previously reported issues.

All SME Server users should upgrade to this release.

Bug reports and reports of potential bugs should be raised
in the bug tracker (and only there, please);
http://bugs.contribs.org/

Major changes from SME Server 7.1

- Mainly bug fixes and upstream updates
- Added USB backup option added in console menu
- Added Swedish Translation
- Improved Samba Roaming profiles handling
- Added cookie based authentication to server-manager
- Added logout feature to server-manager
- Added ability to have shared address books in webmail

- Major changes that are not user-visible
. Added ability to open tcp and udp port ranges
. Added ability to set global chroot directory for users
. Added ability to purge old logs by days
. Added ability to specify which drive letter to user for user's home directory

- A list of other work included in this release can be found here:
http://bugs.contribs.org/showdependencytree.cgi?id=2342

Please visit http://www.smeserver.org/donate/ to donate.

Other notable items:

We realize that we had issues with some of the mirrors not being in sync at the time of the announcement. We are working with the dev team to come up with a strategy to correct this in the near future.

We were caught by an upstream kernel release so some systems may have the -10 kernel installed. If so, you will notice that PPTP will be broke. We are working on getting 7.1.2 out the door so the associated -10 kmods will be installed and fix PPTP again. There is an update in 7.1.1 that fixes a bug where the excludes section in yum.conf was not being populated properly. Going forward, this should aid in new kernels only showing up as an update in smeupdates.

If smeserver-userpanel is installed please refer to this post
http://forums.contribs.org/index.php?topic=35924.0

Lastly, we would like to extend the call again for others to help in validating bug reports and helping the maintenance team get updates verified so they can be pushed out. The more help we can get, the better quality we can provide.

Thanks,

John Bennett
on behalf of the maintenance team

[edit to refer to 7.1 announcement]
............

Offline bpivk

  • *
  • 908
    • http://www.bezigrad.com
SME Server 7.1 Update 1
« Reply #1 on: February 27, 2007, 10:36:05 PM »
You're a little fast with your post.  It's 22:30 and still no option or notice from SME to update new software. :D
"It should just work" if it doesn't report it. Thanks!

SME Server 7.1 Update 1
« Reply #2 on: February 28, 2007, 09:15:42 AM »
Tonight I received a mail about available updates.

This morning I launched "yum update", and this is its output:
Code: [Select]
==============================================================
WARNING: Additional commands may be required after running yum
==============================================================
Loading "fastestmirror" plugin
Loading "smeserver" plugin
Setting up Update Process
Setting up repositories
smeaddons                 100% |=========================|  951 B    00:00
smeos                     100% |=========================|  951 B    00:00
smeupdates                100% |=========================|  951 B    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 3.1 kB    00:00
smeupdates: ################################################## 2/2
Added 1 new packages, deleted 88 old in 0.05 seconds
No Packages marked for Update/Obsoletion
================================================================
No new rpms were installed. No additional commands are required.
================================================================

Has the update been retired, or are the repository servers not fully available?
Pierluigi Miranda
Responsabile Sistemi e Reti
Servizio Sistemi Informativi
Agecontrol S.p.A.

Offline okepc

  • ***
  • 118
    • http://www.okepc.nl
SME Server 7.1 Update 1
« Reply #3 on: February 28, 2007, 10:28:24 AM »
I had a whole bunch of updates in the mail for 7.1.1
What i didn't find in the list is the clamav update to 0.90
smeserver-clamav.noarch was there but not the clamav rpm's

Dirk

Offline okepc

  • ***
  • 118
    • http://www.okepc.nl
SME Server 7.1 Update 1
« Reply #4 on: February 28, 2007, 01:18:08 PM »
Same issue as pmiranda

No updates available although i had a bunch in the mail.

Checked they were available at ibiblio.
Disabled the fastestmirror plugin.
Only enabled ibiblio repo.
Point ibiblio to the 7.0 and 7.1 repo

NO updates :-(

Dirk

SME Server 7.1 Update 1
« Reply #5 on: February 28, 2007, 02:35:30 PM »
I have a whole lot of updates:-)

Hans-Cees
nl.linkedin.com/in/hanscees/

Offline bpivk

  • *
  • 908
    • http://www.bezigrad.com
SME Server 7.1 Update 1
« Reply #6 on: February 28, 2007, 02:39:47 PM »
Quote from: "hanscees"
I have a whole lot of updates:-)

Hans-Cees


I had them too. But it only updated the two kernels. Now i don't have any updates so i posted this problem to the bugtracker.
"It should just work" if it doesn't report it. Thanks!

SME Server 7.1 Update 1
« Reply #7 on: February 28, 2007, 04:20:45 PM »
Quote from: "hanscees"
I have a whole lot of updates:-)

Hans-Cees

I see 12 of them, but only CentOS related. No SMEServer 7.1.1 update.
Pierluigi Miranda
Responsabile Sistemi e Reti
Servizio Sistemi Informativi
Agecontrol S.p.A.

Offline _YO_

SME Server 7.1 Update 1
« Reply #8 on: February 28, 2007, 07:03:54 PM »
As some of you, i had only 2 updates for kernel
I perform a yum clean all
Then yum list updates give the whole.

           .YO.
.YO.

SME Server 7.1 Update 1
« Reply #9 on: March 01, 2007, 08:51:43 AM »
Today, this is the yum transaction summary:
Code: [Select]
Transaction Summary
=============================================================================
Install     12 Package(s)
Update      73 Package(s)
Remove       0 Package(s)
Total download size: 81 M


No need to clean the yum cache, the problem was elsewhere, and seems solved.
Pierluigi Miranda
Responsabile Sistemi e Reti
Servizio Sistemi Informativi
Agecontrol S.p.A.

SME Server 7.1 Update 1
« Reply #10 on: March 01, 2007, 10:35:35 AM »
WARNING

There are some troubles with this update. Kernel could be updated to a wrong version, mostly for people using 7.1 fresh and not 7.0 upgraded to 7.1.

Do not install kernel.2.6.9_42.10.EL. Right kernel should be : kernel.2.6.9_42.8.EL.

Offline okepc

  • ***
  • 118
    • http://www.okepc.nl
SME Server 7.1 Update 1
« Reply #11 on: March 01, 2007, 11:07:01 AM »
Problem solved itself can confirm all updates are now available through yum and i upgraded without trouble.
Use --disablerepo=updates for exluding the kernels

Dirk

Backwards
« Reply #12 on: March 01, 2007, 04:59:52 PM »
OK OK this probably should be in the "Bug Tracker" forum but it might help others out who are updating.

When I ran yum from the admin panel today my internal Nic card and external Nic card got reversed.
What are the three dots for at the end of my signature file and why can't I get rid of them?These three dots right here >...

Offline bpivk

  • *
  • 908
    • http://www.bezigrad.com
Re: Backwards
« Reply #13 on: March 01, 2007, 07:30:07 PM »
Quote from: "stancol"
OK OK this probably should be in the "Bug Tracker" forum but it might help others out who are updating.

When I ran yum from the admin panel today my internal Nic card and external Nic card got reversed.


Yes you should post this to the bugtracker.
"It should just work" if it doesn't report it. Thanks!

Would if I Could
« Reply #14 on: March 02, 2007, 09:35:48 AM »
Well I'd post it to the bugtracker but it wouldn't let me in. The other reason I posted it here was just in case somebody was trying to update remotely over the internet they would lose control of the machine.
What are the three dots for at the end of my signature file and why can't I get rid of them?These three dots right here >...

Offline bpivk

  • *
  • 908
    • http://www.bezigrad.com
Re: Would if I Could
« Reply #15 on: March 02, 2007, 02:24:10 PM »
Quote from: "stancol"
Well I'd post it to the bugtracker but it wouldn't let me in. The other reason I posted it here was just in case somebody was trying to update remotely over the internet they would lose control of the machine.


You should make a username and a password and report this kind of bugs.

Let me ask you.... Would you rather help and fix this problem for other users by telloing devs about it ro would you have them searching the forum when something is broke.

So i'll repeat my sentence... Please post this to the bugtracker.
"It should just work" if it doesn't report it. Thanks!

SME Server 7.1 Update 1
« Reply #16 on: March 02, 2007, 07:10:20 PM »
I HAD a lot of updates. Now they are gone, and I have not updated??

strange..
nl.linkedin.com/in/hanscees/

Offline bpivk

  • *
  • 908
    • http://www.bezigrad.com
SME Server 7.1 Update 1
« Reply #17 on: March 02, 2007, 07:16:50 PM »
hanscees the answer is here on the forums and in the bugtracker. Search a little. Look at posts in SME Server 7.x section.
"It should just work" if it doesn't report it. Thanks!

SME Server 7.1 Update 1
« Reply #18 on: March 02, 2007, 09:16:34 PM »
After updating to 7.1.1 I can't get in contact with my server-manager. Get this reply:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Any suggestions? (I don't know how to see the log files.)

Offline byte

  • *
  • 2,182
SME Server 7.1 Update 1
« Reply #19 on: March 02, 2007, 10:55:32 PM »
Quote from: "presk"
After updating to 7.1.1 I can't get in contact with my server-manager. Get this reply:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Any suggestions? (I don't know how to see the log files.)


Please report bugs and potential bugs to bug tracker as we already have a few case's of this. Thanks!
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline del

  • *
  • 765
SME Server 7.1 Update 1
« Reply #20 on: March 04, 2007, 05:37:29 AM »
Hi All,

I did the updates tonight and also have a problem with the NIC's getting reversed :shock:
Quote
OK OK this probably should be in the "Bug Tracker" forum but it might help others out who are updating.

When I ran yum from the admin panel today my internal Nic card and external Nic card got reversed
I  have no internet now and each time I reconfigure the NIC's are reversed and I don't get the option to choose which one, it tells me that there are 2 NIC's but only offers 1 and I have continually failed to get the right one and therefore have no internet access. I have had to set up a router as a temp. measure :shock:  Any help is appreciated.

Regards,
Del
If at first you don't succeed, then sky-diving is not for you!
"Life is like a coin. You can spend it anyway you wish, but you can only spend it once." --Author Unknown

Offline bpivk

  • *
  • 908
    • http://www.bezigrad.com
SME Server 7.1 Update 1
« Reply #21 on: March 04, 2007, 01:10:51 PM »
Please report bugs and potential bugs to bug tracker as we already have a few case's of this. Thanks!

And you said that someone has the same problem. Well search the bugtracker for it. This is why it's important to submit bugs and not solve them on the forum.

So search for this bug or open a new bug.
"It should just work" if it doesn't report it. Thanks!

WWW24

solution
« Reply #22 on: June 01, 2007, 08:04:19 PM »
Quote from: "presk"
After updating to 7.1.1 I can't get in contact with my server-manager. Get this reply:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Any suggestions? (I don't know how to see the log files.)


Yes, log on localy to the console as admin, go to step 4 / reconfiguration, make rekonfiguration, it needs a little time, then wait for restart, after this procedure, i have had normal access to the server manager. hope this helps

regards

Gerhard