Koozali.org formerly Contribs.org

[HOW TO] Install eGroupWare on SME 7.x

Offline Franco

  • *
  • 1,171
    • http://contribs.org
[HOW TO] Install eGroupWare on SME 7.x
« Reply #15 on: January 16, 2007, 08:13:05 PM »
:D
Very good!
I still get this error:
Code: [Select]
httpd: PHP Warning:  imap_open(): Couldn't open stream {localhost:143}INBOX in /opt/egroupware/html/email/inc/class.mail_dcom_imap.inc.php on line 214 Should I worry?

Thanks,

[HOW TO] Install eGroupWare on SME 7.x
« Reply #16 on: January 16, 2007, 09:59:31 PM »
There is nothing to worry about, but obviously something is going wrong !
If you can not retrieve mails via IMAP, have you tried via POP ? (both protocols are supported)
If this work with POP, maybe you forgot to fill IMAP server name in the setup process ? Go to https://yourserver/egroupware/setup to check it. I don't ask you if IMAP is enabled on your server, I bet it is !!!

Offline Franco

  • *
  • 1,171
    • http://contribs.org
[HOW TO] Install eGroupWare on SME 7.x
« Reply #17 on: January 16, 2007, 10:12:41 PM »
Oh no! Everything works!!!  :)
I just see this message coming through the logs everytime I log in.

Thanks,

downloadable script?
« Reply #18 on: January 16, 2007, 11:01:25 PM »
hiya cool34000...

is it possible for you to create the complete script for easy downloading instead of people struggling with typing errors?

also, a general question about groupware, their homepage says you have access from various clients (outlook included), but would outlook have the full feature range of the webclient?


thanks for all your hard work!

[HOW TO] Install eGroupWare on SME 7.x
« Reply #19 on: January 16, 2007, 11:54:36 PM »
@stuntshell : I don't have any errors in my logs... Are you sure EGW users and passwords are the same that SME's ? I ask that because man can add mailboxes to a user but by default, EGW will open EGWuserlogin@localhost to retrieve mails... That's why EGWuserlogin must equal SMEuserlogin (and of course password). If not, I don't have anymore ideas :oops: Sorry... See EGW forums, maybe this will help you ?

@rkscscc : I do not have the necessary bandwidth to do that at home at the moment : I'm lost in the asshole of the world where xDSL means 512/128kbps :cry: I'm also an onlinegamer and ping is life !!! :twisted:
Anyway, this script and the templates are for everyone so I have no problem on putting these 3 little files on any FTP a generous soul would provide...

[HOW TO] Install eGroupWare on SME 7.x
« Reply #20 on: January 17, 2007, 03:05:52 AM »
About what can do (or what cannot do) eGroupWare and Outlook, I invite you to test eGWOSync.
I've just discovered it while trying to answer your post...
Using this tool is really not hard but there is one thing you must know before starting...
To use eGWOSync with HTTPS, YOU MUST HAVE A VALID CERTIFICATE
If not there are howtos on contribs.org to do this...
I highly recommend to use HTTPS with eGroupWare !!!

Here is another solution, which does not use HTTPS and THAT IS NOT SECURED.
So I recommend to limit access to eGroupWare from LAN only...

I highly insist in the fact that http and xmlrpc shouldn't be used together, password are written in plain text !!! You are warned !


Here's the howto :
delete the file created by the script : 60redir-egroupware
Code: [Select]
rm /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf/VirtualHosts/60redir-egroupwareReplace the content of the file /etc/e-smith/templates/etc/httpd/conf/httpd.conf/98egroupware by this :
Code: [Select]

# eGroupWare
Alias /egroupware /opt/egroupware/html
<Directory /opt/egroupware/html>
AddType application/x-httpd-php .php .php3 .phtml
Options Indexes +Includes FollowSymLinks
AllowOverride all
order deny,allow
deny from all
allow from { "$localAccess"; }
php_flag magic_quotes_gpc on
php_flag track_vars on
php_flag register_globals off
php_admin_value phpa on
php_admin_value eaccelerator.enable 1
php_admin_value display_errors 0
php_admin_value mbstring.func_overload 7
</Directory>

Be careful on the blank line on top&end :wink:
Then expand the template and restart apache :
Code: [Select]
expand-template /etc/httpd/conf/httpd.conf
service httpd-e-smith restart


At this stage, things should be the same if you use https or http :
If it's not already done, activate xmlrpc services in Admin panel / site configuration. Then click on xmlrpc item and click on introspection.
This should give you something like this :
Quote from: "xmlrpc introspection"
methods available at http://yourservername:80/egroupware/xmlrpc.php
system.listMethods
Documentation
This method lists all the methods that the XML-RPC server knows how to dispatch

Signature
array system.listMethods(string)
array system.listMethods()


system.methodHelp
Documentation
Returns help text if defined for the method passed, otherwise returns an empty string

Signature
string system.methodHelp(string)


system.methodSignature
Documentation
Returns an array of known signatures (an array of arrays) for the method name passed. If no signatures are known, returns a none-array (test for type != array to detect missing signature)

Signature
array system.methodSignature(string)


system.login
Documentation
eGroupWare client or server login via XML-RPC

Signature
struct system.login(struct)


system.logout
Documentation
eGroupWare client or server logout via XML-RPC

Signature
struct system.logout(struct)


system.phpgw_api_version
Documentation
Returns the eGroupWare API version

Signature
string system.phpgw_api_version()


system.time
Documentation
returns system-time and -timezone and if loged in user-time and timezone

Signature
struct system.time()

If you passed the test, install eGWOSync (you need .net framework 1.1). Launch the program and provide the needed information during the 'first time run' :
Put just your server name in field Http://
Port should be 80 if using http or select Use SSL/Secure to use https (if you must have a valid certificate)
URI should be left by default (/egroupware/xmlrpc.php)
On next page, insert username and password and enter yourdomain.com
Then test your login. If you get 2 success, you can now sync calendar, addressbook, notes, todo's :P

Enjoy !

[HOW TO] Install eGroupWare on SME 7.x
« Reply #21 on: January 17, 2007, 08:31:13 AM »
cool34000,

send me an email with the files to admin @ rkscomputersolutions dot com

if you stick all the files in one zip then i'll get it hosted, no probs...

Will have it up within a short time....

[HOW TO] Install eGroupWare on SME 7.x
« Reply #22 on: January 17, 2007, 11:49:03 PM »
Done, 3Kb! :D

[HOW TO] Install eGroupWare on SME 7.x
« Reply #23 on: January 19, 2007, 10:52:05 AM »

Offline Franco

  • *
  • 1,171
    • http://contribs.org
[HOW TO] Install eGroupWare on SME 7.x
« Reply #24 on: January 19, 2007, 01:23:58 PM »
Quote from: "cool34000"
Are you sure EGW users and passwords are the same that SME's ? I ask that because man can add mailboxes to a user but by default, EGW will open EGWuserlogin@localhost to retrieve mails... That's why EGWuserlogin must equal SMEuserlogin (and of course password).

EGW and SME does not need to have the same passwords, the only piece that needs access to e-smith is the mail part, and you can have different passwords set, there's an option so you can customize the imap settings. Checkmark and enter the propper information.

About the error log I was receiving, it was due to the fact I had used a localhost name instead of the fully qualified domain in setup. After fixing that, all good to go.

Thanks,

Offline fpausp

  • *
  • 728
[HOW TO] Install eGroupWare on SME 7.x
« Reply #25 on: January 19, 2007, 09:36:04 PM »
Hi,

I have installed egroupware on sme 7.1, when i send a mail anglemail hide my adress.

Where can i change this ?

fpausp
Viribus unitis

steveyb

Help Empty Blank Page
« Reply #26 on: January 29, 2007, 09:27:45 PM »
Hello,

I have installed egroupware using the script above with no errors however I get an empty page after i write the config at the setup page. https://www.myserver.com/egroupware/setup/index.php any help will be greatly appreciated.

Thanks

Steve

[HOW TO] Install eGroupWare on SME 7.x
« Reply #27 on: January 30, 2007, 08:46:14 PM »
Have you downloaded the .zip file ?
Have you followed the howto (setup process) ?

davdo

egroupware setup fail
« Reply #28 on: January 31, 2007, 10:43:29 PM »
I have installed egroupware using the script above with no errors however I get an empty page after i write the config at the setup page.  :shock:

davdo

egroupware setup fail
« Reply #29 on: January 31, 2007, 10:44:14 PM »
I have installed egroupware using the script above with no errors however I get an empty page after i write the config at the setup page. Help.. :shock: