Koozali.org formerly Contribs.org

[Announce] Horde 3.1.x RPM's

[Announce] Horde 3.1.x RPM's
« Reply #15 on: November 20, 2006, 03:41:12 PM »
Hi everyone,

Has anyone had any luck getting an Outlook Client to Sync up with Horde 3.1 yet?

Cheers,
...
Nick

"No good deed goes unpunished." :-x...

Offline mrjhb3

  • *
  • 1,187
    • John Bennett Services
[Announce] Horde 3.1.x RPM's
« Reply #16 on: November 20, 2006, 04:43:45 PM »
Quote from: "NickCritten"
Hi everyone,

Has anyone had any luck getting an Outlook Client to Sync up with Horde 3.1 yet?

Cheers,


There is some vague information about syncing with horde 3.1 in their wiki, but if you get it to work, you won't get much to sync unless you are using the CVS versions.  The horde developers are spending a lot of time on synching capabilities, if your interested join the horde sync list.  From what I can gather, full syncing support won't be supported until horde 3.2.

People have reported some various successes with syncing using egroupware, but the sync code they are using comes from horde as well.

John
......

[Announce] Horde 3.1.x RPM's
« Reply #17 on: November 20, 2006, 04:50:09 PM »
Ah.. I was under the impression that 3.1 was the holy grail of Outlook syncing with a Linux server (Open-source Server software & Open source Connector)

Ho Hum.
...
Nick

"No good deed goes unpunished." :-x...

maedli

[Announce] Horde 3.1.x RPM's
« Reply #18 on: November 25, 2006, 11:30:44 PM »
Quote from: "NickCritten"
Hi everyone,

Has anyone had any luck getting an Outlook Client to Sync up with Horde 3.1 yet?

Cheers,


I have had some luck in getting Outlook to sync with Horde 3.1. Currently I'm using Nexthaus SyncJE and it is working flawlessly.

The problem I have left, is that the synced items have the username 'username' and the items created in the webclient have the username 'user@domain.tld'. Because of this I cannot see the synced items in the webclient.  I can see the synced items via phpmyadmin and if I change the username I can see them in the webclient.
Items created in the webclient doesn't get synced into Outlook either.

Anybody with a solution to this problem?

[Announce] Horde 3.1.x RPM's
« Reply #19 on: December 05, 2006, 09:00:52 AM »
Quote from: "mrjhb3"
Quote from: "arnie25"
After an upgrade to Horde 3.1.x admin user left side panel has gone and isn't possible to view word or exel documents as attachments in mail.


I can't duplicate the admin sidepanel issue?  Are you using IE?  
I also have not messed with any of the viewer configurations.  But, the viewers seem to be installed on SME 7.  Edit the horde/mime_drivers.php and change the //260 to /usr/bin/xhtml, the //270 to /usr/bin/ppthtml and let me know if that corrects it for the viewers.

John

[edit]

There is more that needs to be done.  You also need to edit 100mimedrivers and make sure you register msexcel and/or mspowerpoint, and in the 260 and/or 270 sections change inline to true.

Going forward, you will need to make a custom template of these options as I don't plan on setting them by default.


Hi John,

I uninstalled all horde rpm's and reinstalled all the new ones.
After that I edited that you had mentioned and everything is working in horde right now.
Thanks for everything!

Arnie
...

jodahall

[Announce] Horde 3.1.x RPM's
« Reply #20 on: December 08, 2006, 01:52:58 AM »
sorry to be a real newbie dunce here, but what is what there are multiple versions of applications there.  which ones do is use ?? some say smeserver, some say e-smith, some don't have anything at all.  i'm not very comfortable with yum or rpm so i don't want to accidently install the wrong thing.

also what configuration do i have to do to get these working as a groupware app.  i've looked around for a how-to but couldn't find anything.

Offline mrjhb3

  • *
  • 1,187
    • John Bennett Services
[Announce] Horde 3.1.x RPM's
« Reply #21 on: December 08, 2006, 02:02:38 AM »
Quote from: "jodahall"
sorry to be a real newbie dunce here, but what is what there are multiple versions of applications there.  which ones do is use ?? some say smeserver, some say e-smith, some don't have anything at all.  i'm not very comfortable with yum or rpm so i don't want to accidently install the wrong thing.

also what configuration do i have to do to get these working as a groupware app.  i've looked around for a how-to but couldn't find anything.


There is a horde 3.0 versions and there a horde 3.1 version.  Parts of horde 3.0 are installed on a stock SME server.  I have created RPMS for kronolith - calendar, mnemo - notes, nag - tasks, gollem - file manager, trean - bookmark manager, mimp - mobile imp.  None of those are part of a stock server.  The files named e-smith are named as such because that is what they are called in the base.  The smeserver- designates a contrib.  For horde 3.1 all of these RPMS are currently contribs because horde 3.0 is the standard install.  So, you can install whatever packages you want.  You will need to install 2 RPMS for every package.  The actual product install, and the appropriate e-smith- or smeserver- rpm.  Then signal-event post-upgrade ; signal-event reboot so the proper tables are created.

HTH,

John
......

jodahall

[Announce] Horde 3.1.x RPM's
« Reply #22 on: December 08, 2006, 10:37:53 PM »
so just to be sure, hate being such a dunce, but i don't want to mess up my system, i'm planning on downloading and rpm'ing the following, but first here is what i'm using.  stock sme7 system, haven't installed any extra contribs or anything.

I will do a wget on the following files

horde-3.1.3-00sme01.noarch.rpm     --> to update my horde to 3.1 (don't know if i have to)
smeserver-kronolith-1.1-5.noarch.rpm  --> add contrib for calendar (don't know what a contrib is)
kronolith-h3-2.1.4-00sme01.noarch.rpm  --> actual calendar application (guess it's different than the contrib

then run a rpm -Uvh *rpm
then signal-event post-upgrade ; signal-event reboot

when it starts back up.....do i just navigate to http://<mydomain>/webmail and login and will the calendar be there ??

sorry about being stupid, I just don't want to mess up a system that is running fine.

Offline mrjhb3

  • *
  • 1,187
    • John Bennett Services
[Announce] Horde 3.1.x RPM's
« Reply #23 on: December 09, 2006, 01:31:04 AM »
Quote from: "jodahall"
so just to be sure, hate being such a dunce, but i don't want to mess up my system, i'm planning on downloading and rpm'ing the following, but first here is what i'm using.  stock sme7 system, haven't installed any extra contribs or anything.

I will do a wget on the following files

horde-3.1.3-00sme01.noarch.rpm     --> to update my horde to 3.1 (don't know if i have to)
smeserver-kronolith-1.1-5.noarch.rpm  --> add contrib for calendar (don't know what a contrib is)
kronolith-h3-2.1.4-00sme01.noarch.rpm  --> actual calendar application (guess it's different than the contrib

then run a rpm -Uvh *rpm
then signal-event post-upgrade ; signal-event reboot

when it starts back up.....do i just navigate to http://<mydomain>/webmail and login and will the calendar be there ??

sorry about being stupid, I just don't want to mess up a system that is running fine.


Here is what I would do, upgrade horde, imp, turba, ingo and kronolith.  I have not done much testing with running mixed versions of 3.0 and 3.1 although they are supposed to work together according to the horde devs.  Then yes, just browse to yourdomand.com/webmail and the calendar will be there.

John
......

jodahall

[Announce] Horde 3.1.x RPM's
« Reply #24 on: December 09, 2006, 02:58:58 AM »
well i went and did it.....BOOOM.....it seemed to upgrade properly, no errors or anything, but now i've lost my user id's ??  all my user accounts got locked, i had to go in and reset their passwords (unlock accounts) fortunately i didn't have a lot of users.

here is what i did.....

i did a wget on all the rpms of interest.  smeserver ones and the application ones. including horde, imp...etc then did a rpm -Uvh *rpm after that completed correctly i ran a signal-event post-upgrade and after that finished ran a signal-event reboot.

also when i try to add a calendar event it says <user>@<my domain>.com not found and it won't let me add the entry.  even though when i "edit attendees" and go to LDAP it finds the users when i do a search.

is there configuration, permissions that i have to set up ??  i don't know whey it locked all my existing accounts.

i also get errors when trying to add users to my addressbook or local ldap, i expect the local ldap but my addressbook gives me a error saying.

A fatal error has occurred
You must configure a VFS backend.
Details have been logged for the administrator.

Offline mrjhb3

  • *
  • 1,187
    • John Bennett Services
[Announce] Horde 3.1.x RPM's
« Reply #25 on: December 09, 2006, 03:12:39 AM »
Quote from: "jodahall"
well i went and did it.....BOOOM.....it seemed to upgrade properly, no errors or anything, but now i've lost my user id's ??  all my user accounts got locked, i had to go in and reset their passwords (unlock accounts) fortunately i didn't have a lot of users.


That is very odd and the first time someone has said this.  I have never had that happen on any of my tests.  I'll will load my test server again, add users, do a yum update, reboot, upgrade just the horde components you did, then reboot again.  Do you have anything odd in your /var/log/messages.  If you don't mind, I'd like to see it, send it to me a bennettj at johnbennettservices.com

Quote from: "jodahall"
also when i try to add a calendar event it says <user>@<my domain>.com not found and it won't let me add the entry.  even though when i "edit attendees" and go to LDAP it finds the users when i do a search..


Everyone *must* create a default identity in either options/horde/personal information, or options/imp/personal information.  Then check options/calendar and make sure the default calendar is set correctly, it should be.  As a user, you can not add entries to to the local ldap address book, only to your personal address book.  The only entries that show up in the ldap address book are users that you entered via server-manager.  Also user preference settings override any system default settings.  Login as admin, then choose administration in the sidebar, then setup, make sure all the applications say ready and the versions match with what you should have.

John
......

Offline mrjhb3

  • *
  • 1,187
    • John Bennett Services
[Announce] Horde 3.1.x RPM's
« Reply #26 on: December 09, 2006, 05:36:44 PM »
I did this today.  I installed sme7, added 10 users, sent email from each of the 10 users to at least 3 other users, yum update, post-upgrade; reboot, checked server-manager, users fine.  Then I logged in to webmail again as each user, no issues.  Downloaded the RPMS from my contribs site, checked the md5sums and they matched.  Installed the 10 RPMS you should have:
e-smith-horde-1.13.0-15.noarch.rpm
imp-h3-4.1.3-00sme01.noarch.rpm
e-smith-imp-1.13.0-07.noarch.rpm
ingo-h3-1.1.2-00sme01.noarch.rpm
smeserver-kronolith-1.1-5.noarch.rpm
e-smith-ingo-1.1-5.noarch.rpm
kronolith-h3-2.1.4-00sme01.noarch.rpm    
turba-h3-2.1.3-00sme01.noarch.rpm
e-smith-turba-1.7.0-08.noarch.rpm  
horde-3.1.3-00sme01.noarch.rpm

post-upgrade and reboot.  Checked server-manager, no issues with users, added users free/busy information via server-manager (this must be done in order to be able to query a users calendar), logged in as users, created default identities.  Opened Kronolith and added events and invited users.

You error about a horde VFS tells me that either you had an error when doing the post-upgrade, or there may be a templates-custom fragment.

Your /var/log/messages should show any of these errors.  If you don't have it, do a signal-event post-upgrade again and then browse your log before you do the reboot.

John
......

Offline slords

  • ****
  • 235
[Announce] Horde 3.1.x RPM's
« Reply #27 on: December 09, 2006, 11:41:17 PM »
Are these close to being ready to include into the base distribution?  I've been wondering why we aren't including the updated versions of the packages we already have.   Are there things lacking, missing or that different from what we currently have?
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs,
and the Universe trying to produce bigger and better idiots. So far, the Universe is winning." -- Rich Cook

Offline mrjhb3

  • *
  • 1,187
    • John Bennett Services
[Announce] Horde 3.1.x RPM's
« Reply #28 on: December 10, 2006, 12:05:45 AM »
Quote from: "slords"
Are these close to being ready to include into the base distribution?  I've been wondering why we aren't including the updated versions of the packages we already have.   Are there things lacking, missing or that different from what we currently have?


IMO, yes they are ready (horde, imp, ingo, turba) which match what is included in the base.  There are some things that have been added by me such as the MenuArray settings so that one can choose whether or not to display all of the menu icons or indivudual ones within webmail, an additional template fragment so that if mimp is enabled the horde/conf.php is created with the composite driver, template fragment to add admin@yourdomain.com as an admin for horde, which is needed to administrate the horde permission system for 3.1.x, modified 50localldap template in turba so that the saving of freebusy info can be enabled, etc.  I have documented every change I have made in the various changelogs.

What is not ready is kronolith, which I don't know if you were referring to that as well.  Why it is not is because within kronolith I add a server-manager panel that is just a modified create-user that adds a field so that the users freebusy info can be inputted and saved to the ldap database.

John
......

Offline slords

  • ****
  • 235
[Announce] Horde 3.1.x RPM's
« Reply #29 on: December 10, 2006, 01:56:41 AM »
http://bugs.contribs.org/show_bug.cgi?id=1065

Looks like we might just need to make a little more noise.
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs,
and the Universe trying to produce bigger and better idiots. So far, the Universe is winning." -- Rich Cook