Koozali.org formerly Contribs.org

Not receiving email - Help Please!

Trevor Wendt

Not receiving email - Help Please!
« on: February 05, 2002, 08:21:36 AM »
I just upgraded my PHP to 4.0.6.  It is installed correctly and running.  Ever since I upgrade my PHP I have not been able to receive email through my server.

When I turn error tracking on in my php.ini file all I get is a blank white screen instead of my IMP login page through webmail.  I thinking there is a bug between PHP 4.0.6 and IMP 2.2.7 that SME V5 runs.  

I can send email out, but when I send an email from outside my network to my email address I get a unknown user error.  The user exists and is active.  I have checked all my IP address with my DNS host and they all match up.  My domain resolves correctly for my website but not for the email.  I am at a loss for a fix and my email.  Any ideas would be welcome.  

I am still new to all things linux so if you want me to try something, please tell me how to do it or send me a link so I can read how to do it. Thanks.  - Trevor

Jon Blakely

Re: Not receiving email - Help Please!
« Reply #1 on: February 05, 2002, 10:56:46 AM »
Trevor

Have you read this thread. It may help

http://forums.contribs.org/index.php?topic=3138.msg10597#msg10597

Jon

Trevor Wendt

Re: Not receiving email - Help Please!
« Reply #2 on: February 05, 2002, 08:00:01 PM »
Jon, thanks for the input. I read the thread you suggested.  Just for kicks I processed the "rpm -qa | greg ^php" command and it returned these modules:
  php-ldap-4.0.6-10.arvin.rh7.1
  php-4.0.6-10.arvin.rh7.1
  php-imap-4.0.6-10.arvin.rh7.1
  php-mysql-4.0.6-10.arvin.rh7.1

I also ran the phpinfo() function and imap, sql, and ldap are all supported.

The PHP upgrade went very smoothly thanks to Dan's HowTo (http://www.familybrown.org/howtos/php-upgrade-howto-2.html).  

However, the problem still remains. I'm not able to receive incoming emails. I was looking into upgrading IMP to version 3.0 in hopes that it would solve the problem but I have not found any information on how to do this. Either way, I need to get this resolved... my only other option is to rebuild my server which is not something I want or can do easily.  Any and all help is greatly accepted. Thanks.  - Trevor