Koozali.org formerly Contribs.org

challanges with ssl-explorer 0.2.7 on SME 7.0

zouhbi

challanges with ssl-explorer 0.2.7 on SME 7.0
« on: September 06, 2006, 06:09:25 AM »
Hello

I am really new to Linux and SME and have some challanges to get the ssl-explorer service running under SME 7.0

So far I was able to install the latest JRE, and Apache ANT. Then I ran the installation and was able to get to the setup webfront, to complete the setup of the parameters.

I just cant get the actual service to run. Neiter "ant start" or "service sslexplorer start" seem to work.

Any help and/or suggestion are truly appreciated

Below are my notes what I did so far, they may be a little to detailed, though the only way for me to remeber what I did in 6 months from now. I changed the port for the service other than 443 on the webfront. My question if there is any mistake in my install and/or what else I am missing in order to get the service up and running.

SSL Explorer on SME 7.0

download Linux rpm from

www.java.com/en/download/manual.jsp

use WinSCP to

copy jre-1_5_0_06-linux-185-prm.bin to /root/apps/java

Make file executable at console

# cd /root/apps/java
# chmod a+x jre-1_5_0_06-linux-185-prm.bin

start installtion

# ./jre-1_5_0_06-linux-185-prm.bin

type yes to agree to license terms

JAVA JRE is installed in usr/java/jre1.5.0_06


download Apache ANT from ant.apache.org

extract apache-ant-1.6.5.zip

use WinSCP and copy dicretory /bin and /lib to /usr/java/ant

make ant file executable

# cd /usr/java/ant/bin
# chmod a+x ant

download sslexplorer-0.2.7_02-scr.zip from http://sourceforge.net/projects/sslexplorer and extract
use WinSCP and move to

/root/apps/sslexplorer


use midnight commander to move lib files

#mc

move all files from
/root/apps/sslexplorer/sslexplorer/lib
to
/usr/java/jre1.5.0_06/lib

exit mc with F10


to set HOME variables

# export ANT_HOME=/usr/java/ant
# export JAVA_HOME=/usr/java/jre1.5_0_06
# export PATH=${PATH}:{JAVA_HOME}/bin
# export PATH=${PATH}:{ANT_HOME}/bin

to check if parameters have been set use

echo $PATH

change back to sslexplorer directory

# cd /root/apps/sslexplorer

run ant

# ant install-service

continue installation from web console

http://mysmeserver:28080

zouhbi

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #1 on: September 06, 2006, 06:15:15 AM »
i just noticed that this question should have been posted in SME 7.x Contribs

my sincere apologies for this faux pas

zouhbi

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #2 on: October 11, 2006, 05:39:44 AM »
I have been playing around with no positive results.

Rephrasing my question: Has anybody ssl-explorer 0.2.7 running successfully on SME 7.0?

Thank you all in advance for your help

Offline dmay

  • *
  • 450
    • http://myezserver.com
challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #3 on: October 11, 2006, 06:34:48 AM »
Quote from: "zouhbi"
Has anybody ssl-explorer 0.2.7 running successfully on SME 7.0?

Yes.

First remove your old releases and update to release 0.2.8 which is now available in rpm format and the latest java build.

Next you need to set up sme to support usage on the ports sslexplorer will use. During initial config this is port 28080. During configuration you need to assign a service port. I suggest 28081. Here are the basic steps:

Code: [Select]
rpm -Uvh jdk-1_5_0_09-linux-i586.rpm sslexplorer_linux_0_2_8_01.rpm

config set sslexplorer service status enabled TCPPort 28080
signal-event remoteaccess-update

/opt/sslexplorer/install-sslexplorer

http://smeserverip:28080

config set sslexplorer service status enabled TCPPort 28081
signal-event remoteaccess-update

/opt/sslexplorer/install/platforms/linux/install-service -j /usr/java/jdk1.5.0_09

cd /etc/rc.d/rc7.d
ln -s /etc/rc.d/init.d/e-smith-service S99sslexplorer

/etc/rc.d/init.d/sslexplorer start

http://smeserverip:28081


Darrell

Offline dmay

  • *
  • 450
    • http://myezserver.com
challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #4 on: October 11, 2006, 07:14:52 AM »
Typo, the final connection after config requires SSL (https). Here it is again:

Code: [Select]
rpm -Uvh jdk-1_5_0_09-linux-i586.rpm sslexplorer_linux_0_2_8_01.rpm

config set sslexplorer service status enabled TCPPort 28080
signal-event remoteaccess-update

/opt/sslexplorer/install-sslexplorer

http://smeserverip:28080

config set sslexplorer service status enabled TCPPort 28081
signal-event remoteaccess-update

/opt/sslexplorer/install/platforms/linux/install-service -j /usr/java/jdk1.5.0_09

cd /etc/rc.d/rc7.d
ln -s /etc/rc.d/init.d/e-smith-service S99sslexplorer

/etc/rc.d/init.d/sslexplorer start

https://smeserverip:28081

Darrell

zouhbi

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #5 on: October 16, 2006, 05:34:44 AM »
Thank you Darrell for you help

it is working now; I didn't even notice that updates in rpm were available

murray

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #6 on: October 26, 2006, 10:36:39 PM »
I am new to Linux and SME Server and need some help with this.
I have been following along with this post and also the SSL-Explorer "How-to" and every thing was going fine.
I did the the web configuration of SSL-Explorer but when I tried this command :

 # /opt/sslexplorer/install/platforms/linux/install-service -j /usr/java/jdk1.5.0_09

This is what I get :

Detecting Java
   JAVA_HOME points to a missing or invalid Java runtime,
   please set JAVA_HOME environment variable or provide
   -j <java-home> argument.


I think this might be a problem with the PATH for java_home.

This is my PATH :
# echo $PATH
/sbin/e-smith:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:
/usr/X11R6/bin:/root/bin:{JAVA_HOME}/bin:{JAVA_HOME}/bin:{JAVA_HOME}/bin:{ANT_HOME}/bin


I can see that I have got " :{JAVA_HOME}/bin " in there to many times but I don't know how to get it out.
How do I clean entries from the PATH?

I guess my questions are:

What do you make of the error?

How do I clean up my PATH?

Do I need to follow along with zouhbi's post but with release 0.2.8.
Then add in DMAY's additions?

Is there a better guide?

Should I reinstall SME-SERVER 7.0 and start over?

Offline byte

  • *
  • 2,183
challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #7 on: October 26, 2006, 10:46:26 PM »
Quote from: "zouhbi"
i just noticed that this question should have been posted in SME 7.x Contribs


Moving this topic to the SME Server 7.x Contribs, it is more appropriate there. Thanks!
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline dmay

  • *
  • 450
    • http://myezserver.com
challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #8 on: October 26, 2006, 11:30:15 PM »
Quote from: "murray"
This is my PATH :
# echo $PATH
/sbin/e-smith:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:
/usr/X11R6/bin:/root/bin:{JAVA_HOME}/bin:{JAVA_HOME}/bin:{JAVA_HOME}/bin:{ANT_HOME}/bin


I can see that I have got " :{JAVA_HOME}/bin " in there to many times but I don't know how to get it out.
How do I clean entries from the PATH?

You already know how  :wink:

# export PATH=blah

To return to defaults:

# export PATH=/sbin/e-smith:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin

Darrell

murray

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #9 on: October 27, 2006, 02:45:42 AM »
Thanks Darrell.

Sometimes the obvious is hardest to see.



Murray

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #10 on: November 01, 2006, 08:22:06 PM »
Problem after installing ssl-explorer... As far as I can tell install goes well, following dmay's guide. I did use java jre and not jdk, so I used this line instead:

/opt/sslexplorer/install/platforms/linux/install-service -j usr/java/jre1.5.0_09

First configuration of ssl-explorer works, from http://ip:28080. I configured the built in database, listen on all interfaces, no proxy configured and no extra software to be installed.

Then the rest of dmay's guide, but if I try to access ssl-explorer from https://ip:28081 I get an error message:

"While trying to retrieve the URL ip:28081 the following error was encountered: Access denied - access control configuration prevents your request from bei" (sic)

Who can help?

Thanks,

Oz

challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #11 on: November 03, 2006, 06:15:39 PM »
Still need some help , please!

I've manged to get SSL-explorer working for PC's behind my SME server. I added 28081 to file 20ACL15SSL_ports in /etc/e-smith/templates/etc/squid/squid.conf. It did the trick, though I don't quite know why....

Sadly external machines trying to access port 28081 get a time-out. Router is configured to forward port 28081 to the SME-server.

Any help very much appreciated,

Oz

Offline fpausp

  • *
  • 728
challanges with ssl-explorer 0.2.7 on SME 7.0
« Reply #12 on: December 18, 2006, 05:58:41 PM »
Hi All,

I have installed ssl-explorer and can reach it inside my lan like:

https://serverip_external_interface:28081

but when i try to reach it from the internet i get no response.

I use a dyndns-adress, the server is in a dmz.


please help !
Viribus unitis