Koozali.org formerly Contribs.org

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm

katray

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #45 on: November 21, 2006, 02:32:14 AM »
You don't have permission to access /downloads/smeserver-openvpn/patch/panel_patch_1 on this server.

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #46 on: November 21, 2006, 05:58:53 PM »
Sorry, permissions are corrected now
C'est la fin du monde !!! :lol:

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #47 on: November 25, 2006, 09:20:27 PM »
Attempted an install of beta 5. When creating the ca, it is erroring out.

These are the last few lines in the message file

Nov 25 15:15:42 server1 e-smith-bg: Generating DH parameters, 1024 bit long safe prime, generator 2
Nov 25 15:15:42 server1 e-smith-bg: This is going to take a long time
Nov 25 15:16:00 server1 e-smith-bg: ...........+.........+...........+....+...........+....................+
................................+........................+...................
.................................................................................
................................................+....................+..........
..................................................................................
+.+...............................+....................................+
...............+.......+...........+........................................
..............................+..................+...........................+
..................+..........................................+............+....
.....................................................................+.........
.........+.....................................................................
..................................................................+............
......................................................
Nov 25 15:16:18 server1 e-smith-bg: ........................................................+....................+
....................+............................................................
...................................................................................
..............................................................+....................

.............................................+....................................
..........................................................+......+............+.
....................+.............................................................
......................+..........................................................
...+........+........................+..............................+........
..............................................................................+.
....................................+............................................
............+........................................+..........+.............
.......................
Nov 25 15:16:26 server1 e-smith-bg:
..................................................................................
...................+.......................+...................................
...................................+.....+.....................................
..............+...........................+.+....+...........................
...................+...+.......................................................
...............................................................................+
.
........................................++*++*++*
Nov 25 15:16:26 server1 e-smith-bg: unable to write 'random state'
Nov 25 15:16:26 server1 e-smith-bg: /etc/openvpn/easy-rsa/keys/bridge/dh.pem: No such file or directory

I am going to try to find the beta4, then do the update to see what happens.

Bob
If you think you know whats going on, you obviously have no idea whats going on!

katray

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #48 on: November 25, 2006, 09:29:39 PM »
To get it to work I had to create the directory

etc/openvpn/easy-rsa/keys/bridge/

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #49 on: November 26, 2006, 01:24:59 AM »
I was sure I had uploaded the archive which correct this, but it seems I forgot to do it. You're right katray, if you manually create the directory /etc/openvpn/easy-rsa/keys/bridge, it works. The archive is now updated.
C'est la fin du monde !!! :lol:

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #50 on: November 26, 2006, 05:02:27 AM »
VIP-ire

Just tried it again, on another server, and it is not making the '/etc/openvpn/easy-rsa/keys/bridge' directory. I just downloaded it from your site.

Other than that, it works great!!!!!

Bob
If you think you know whats going on, you obviously have no idea whats going on!

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #51 on: November 26, 2006, 02:54:05 PM »
Ok, I understand the problem now. I had updated the archive the last time but my archiver (file-roller) doesn't keep empty directorys during the archiving, so the directorys keys/brdige wasn't created. As during my tests, I don't use the archive but the uncompressed files, it worked for me. I've modified the install script to create it now and it should be ok.
C'est la fin du monde !!! :lol:

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #52 on: November 27, 2006, 02:02:56 AM »
Just installed on my server. Everything works as expected.

Thanks VIP-ire, and your team.You have made openvpn very easy to install and configure.

Bob
If you think you know whats going on, you obviously have no idea whats going on!

hestad

Motion for SME Server 7
« Reply #53 on: November 27, 2006, 10:25:17 AM »
Quote from: "VIP-ire"
Yes, it's still beta. I've started the new release but it's more work than I thought. I'm also working on a small contrib for motion (video supervision), and I've just finish corecting my first contrib backuppc, so the development of openvpn's one has been slow down. But I use this beta on 3 prod servers and I haven't any problem for more than two months. If you use the server&gateway mode, I think you can use this.
There's one thing you must take care (but this were present in the base of the contrib): you must not restart dhcpd service while openvpn is running. If you do, dhcpd wont start corectly, and it will fill the messages log very quickly (more than 700 Mo per day) and this can slow down the server. I'll try to correct this.

dani


How far did you get with the contrib for motion? I would like to help, if I can. I had motion running on 6.x.

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: Motion for SME Server 7
« Reply #54 on: November 27, 2006, 01:02:39 PM »
Quote from: "hestad"
How far did you get with the contrib for motion? I would like to help, if I can. I had motion running on 6.x.


I'll start a new thread when it will be ready for testing. For now, I wrote a panel to controle it, you can monitor as many cams as you wan't, you can set the time motion will be enabled, you can lunch an action each time a motion is detected (I just wrote a simple script to send a mail with the snapshot attached, but it's possible to make everything you want), there's a small php gallery to see the last snapshot and some other things... I don't know when it'll be ready because I havn't an IP cam anymore, but as soon as I get one, I'll continue the developpement and release a beta.
C'est la fin du monde !!! :lol:

Offline jonic

  • *
  • 103
[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #55 on: November 28, 2006, 11:47:12 AM »
I installed the new beta5 on a new server, and I chose authentication method 3 and I just couldn't get my client to connect. I rechecked the settings, created the certificates again, but to no avail. I was getting a "TLS handshake error" right after I introduced my user name and password.

Then I changed the authentication method to 4, didn't change any other setting - and it worked! (the client certificate already had to correct common name). Then I changed back to auth. method 3 and it worked also.

Very strange.

Anyways, Vip-ire thanks for this great contrib!

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #56 on: November 28, 2006, 11:59:39 AM »
Quote from: "jonic"
I installed the new beta5 on a new server, and I chose authentication method 3 and I just couldn't get my client to connect. I rechecked the settings, created the certificates again, but to no avail. I was getting a "TLS handshake error" right after I introduced my user name and password.

Then I changed the authentication method to 4, didn't change any other setting - and it worked! (the client certificate already had to correct common name). Then I changed back to auth. method 3 and it worked also.

Very strange.

Anyways, Vip-ire thanks for this great contrib!


Quite strange, I'll try to look why this is appening and I'll let you informed if I find something.
Thanks for the repport
C'est la fin du monde !!! :lol:

Offline jonic

  • *
  • 103
[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #57 on: November 28, 2006, 01:59:22 PM »
Update :
Auth. method 3 seems to work like method 4, meaning that I have to get a certificate for each client. If the common name for the client certificate isn't the same as the user-name I can't log in. And this only after selecting first method 4, and then switching back to method 3.

Hope this will help you sort thing out.

hestad

Re: Motion for SME Server 7
« Reply #58 on: November 29, 2006, 12:00:29 AM »
Quote from: "VIP-ire"
Quote from: "hestad"
How far did you get with the contrib for motion? I would like to help, if I can. I had motion running on 6.x.


I'll start a new thread when it will be ready for testing. For now, I wrote a panel to controle it, you can monitor as many cams as you wan't, you can set the time motion will be enabled, you can lunch an action each time a motion is detected (I just wrote a simple script to send a mail with the snapshot attached, but it's possible to make everything you want), there's a small php gallery to see the last snapshot and some other things... I don't know when it'll be ready because I havn't an IP cam anymore, but as soon as I get one, I'll continue the developpement and release a beta.


Very nice and thank you for your answer. Could you tell me which RPM's you installed on 7.x to get the latest motion package running?

[ANNOUNCE] smeserver-openvpn-bridge-fws-1.1-2.rpm
« Reply #59 on: November 29, 2006, 04:07:58 AM »
Quote
Collaboration
Users
Groups
Quotas
Pseudonyms
Information bays
Administration
Backup or restore
View log files
Mail log file analysis
Reboot or shutdown
Security
Remote access
Local networks
Port forwarding
Proxy settings
Configuration
Software installer
Date and time
Workgroup
Directory
Printers
Hostnames and addresses
Domains
E-mail
Antivirus (ClamAV)
Review configuration
Crontab Manager
Miscellaneous
Support and licensing
Create starter web site
Unknown
.rnd


I am still trying to get beta 5 going. I tried uninstalling everything and removing all directories and power down/up. I still have the "Unknown" selection possible at the bottom of my toolbar on the left of my smeserver  manager screen. Shouldn't this have gone away?

Anyways I am the point where I may wipe everything and start again (ouch) unless you have any ideas re fix.

Thx in advance for any help.

Ian