Koozali.org formerly Contribs.org

Web stats in SME?

yehaah

Web stats in SME?
« on: June 16, 2006, 10:29:19 AM »
I've been missing the web statistics since i moved from SME 6x to 7x.

Why not incorperate the web stats into SME 7.0 final?

Are web stats not a must for all web server owners?

Web stats in SME?
« Reply #1 on: June 20, 2006, 04:32:44 AM »
I think this is a great idea, but what you must realise is that not everyone uses SME as a webserver.

yehaah

Web stats in SME?
« Reply #2 on: June 20, 2006, 08:31:58 AM »
Well I don't use SME as a proxy server, but that dosn't mean that they can't have one in the distobution.

The same with the anti spam funktion in 7.0. I only use it on my mail server. I don't use it on my web server or in my gateway  :-D

Just because they put it in, and maybe make a link to it in the server-manager, doesn't meen that it can't be available.

The problem with adon stats is that they stop working after an upgrade  :cry:

Web stats in SME?
« Reply #3 on: June 29, 2006, 04:19:55 AM »
Good point I didn't look at it that way.  :-)

Web stats in SME?
« Reply #4 on: July 04, 2006, 08:13:33 AM »
The philosophy of the smeserver admins is to remove programs from the base into contribs, so I can't see awstats being added.

>The problem with addon stats is that they stop working after an upgrade

then raise a bug against the contrib, preferably with the solution

Web stats in SME?
« Reply #5 on: July 17, 2006, 09:22:20 PM »
dungog.net has a SME 7.0 package called smeserver-awstats. It integrates awstats into server-manager. It can be installed with yum if you have the dungog repository added:

http://www.dungog.net/sme/repo.php

Run at least this part (the other part is for dungog's paying customers):

 SME 7.0
1. From the command line enter the following, (or copy and paste into your ssh client)

db yum_repositories set dungog repository \
 BaseURL http://sme.dungog.net/packages/smeserver/7.0/i386/dungog/ \
 EnableGroups yes \
 GPGCheck no \
 Name 'SME Server 7 - dungog' \
 Visible yes \
 status enabled

<edited to install the right awstats rpm, don't get one from the awstats website>
You will need to obtain and install awstats RPM from:
http://dag.wieers.com/packages/awstats/
tested with awstats-6.5-1.2.el4.rf.noarch.rpm

You should be able to install with:
yum localinstall awstats-6.5-1.2.el4.rf.noarch.rpm
(or whatever the latest version number RPM is.)

then:
yum install smeserver-awstats

Wait 5 minutes then check for a "web statistics" link in server-manager. It will automagically populate with all your domains.
Tampa, FL USA

swissueli

Web stats in SME?
« Reply #6 on: July 19, 2006, 04:51:45 PM »
Hi all,

tried to instlal AWSTATS but getting the following errors:

Running Transaction
  Installing: smeserver-awstats            ######################### [1/1]
cp: cannot stat /var/www/awstats/icon/*': No such file or directory
cp: cannot stat /var/www/awstats/awstats.pl': No such file or directory
cp: cannot stat /var/www/awstats/lang': No such file or directory
cp: cannot stat /var/www/awstats/lib': No such file or directory
cp: cannot stat /var/www/awstats/plugins': No such file or directory
AWStats installed and enabled. Please check AWStats settings in the server-manager.

This is on a fresh SME 7 install.

Any help is highly apreciated.

Cheers, Ulrich

Web stats in SME?
« Reply #7 on: July 20, 2006, 03:31:18 AM »
Post it to the SME Server 7.0 bug tracker contribs section.
Tampa, FL USA

AWSTATS SME7
« Reply #8 on: July 20, 2006, 07:48:38 PM »
Well after a bit of trial and error and not finding anything definite on installing AWSTATS on SME7, I have come across 2 rpm's that when installed seem to work properly...

So I have copied them over to my FTP area  and they can be found at ftp://chaloner.ca/awstats

I installed them with the following commands after downloading them to a temporary directory;

# yum install *.rpm
# signal-event post-upgrade
# signal-event reboot

They seem to work just fine... I hope this helps someone...

Chaloner Hale

Web stats in SME?
« Reply #9 on: July 21, 2006, 02:40:16 AM »
Thankyou chaloner i had awstats on my old server but couldnt workout why it wouldnt work on the new. Your ftp files did the trick

Many Thanks
the above may work with a bit of help, down hill with the wind behind it

swissueli

Web stats in SME?
« Reply #10 on: August 02, 2006, 10:33:31 PM »
Hi guys,

that did the trick to my installation too.

First had to remove the two previously installed rpms but then it worked like a charm.

One more questions:

Would it be possible to access that awstats result page not only through the server-manager plugin but additional as an external web page? Any hints?

Cheers, Ulrich

Re: Web stats in SME?
« Reply #11 on: August 04, 2006, 12:11:56 AM »
Quote from: "yehaah"
I've been missing the web statistics since i moved from SME 6x to 7x.


Web statistics was not part of 6.0.x. (I don't know about 6.5;  I have never run that version).

versions
« Reply #12 on: August 11, 2006, 10:37:20 AM »
As the FTP-files seemes to be gone.....

Can anybody please post wich rpm's that are needed for awstats on SME7 ?

- - Chaloner ??

TIA
Kenn
...

Web stats in SME?
« Reply #13 on: August 11, 2006, 07:50:29 PM »
Does anybody know of any other locations for there rpm's as they no longer existst at this ftp location.
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

telleropnul

Web stats in SME?
« Reply #14 on: August 16, 2006, 08:41:40 AM »
ftp://chaloner.ca/

Look for awstats.tar

The RPMs are named:
awstats-6.5-1.2.el4.rf.noarch.rpm
smeserver-awstats-1.2-2.noarch.rpm

Also on my system they work like a charm out of the box.

Re: Web stats in SME?
« Reply #15 on: September 14, 2006, 05:09:40 AM »
Quote from: "CharlieBrady"
Quote from: "yehaah"
I've been missing the web statistics since i moved from SME 6x to 7x.


Web statistics was not part of 6.0.x. (I don't know about 6.5;  I have never run that version).
]


I think he meant that he could not find i to install into 7.0 .
...

IceDizzy

.
« Reply #16 on: September 20, 2006, 05:41:06 AM »
Posted in wrong place cant delete this message >:-|

IceDizzy

Web stats in SME?
« Reply #17 on: September 20, 2006, 05:49:09 AM »
Quote from: "telleropnul"
ftp://chaloner.ca/

Look for awstats.tar

The RPMs are named:
awstats-6.5-1.2.el4.rf.noarch.rpm
smeserver-awstats-1.2-2.noarch.rpm

Also on my system they work like a charm out of the box.


The rpms in the tarfile just works out of the box at my SME 7. Nice statistic-presentation also in servermanager.
God tip to pass to others. /Ice

unite07

awstats server-manager error
« Reply #18 on: October 10, 2006, 07:07:57 AM »
I am getting this error in the server-manager under Web statistics after what seamed like a successful install.


--------------------------------

Error: Plugin load for plugin 'hostinfo' failed with return code: Error: Can't locate Net/XWhois.pm in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /etc/e-smith/web/panels/manager/cgi-bin/.awstats/lib /etc/e-smith/web/panels/manager/cgi-bin/.awstats/plugins /etc/e-smith/web/panels/manager/cgi-bin/.awstats/plugins) at (eval 2) line 1.

Setup ('/etc/e-smith/web/panels/manager/cgi-bin/.awstats/awstats.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).


------------------------

the permissions look ok

i have uninstalled and reinstalled both rpm's:
awstats-6.5-1.2.el4fr.noarch.rpm
smeserver-awstats-1.2-2.noarch.rpm

 
and still the same error.


any help is greatly appreciated

unite07

awstats server-manager error question in the suggestion area
« Reply #19 on: October 13, 2006, 09:51:13 AM »
I don't know why no one else has had a similar error. or why i posted in the suggestion thread.  so my suggestion is, if you get this error:

Error: Plugin load for plugin 'hostinfo' failed with return code: Error: Can't locate Net/XWhois.pm

install this rpm:

perl-Net-XWhois-0.90-1.2.el4.rf.noarch.rpm

tiziano

Web stats in SME?
« Reply #20 on: October 22, 2006, 03:12:51 PM »
Hi have installed the awstats
in pannel control is ok !

but from
www.mysites.xxx/awstats
not view !

https://mail.puglianet.it/awstats

why?

 :?:

Offline LeoM

Web stats in SME?
« Reply #21 on: December 05, 2006, 12:15:17 PM »
Hi guys,

See nothing there.....

Anybody?

LeoM