Koozali.org formerly Contribs.org

Fallos en PHP

vertical

Fallos en PHP
« on: June 12, 2006, 10:06:54 AM »
Hola a todos,

Desde que he actualizado a PHP 4.3.10 y a Horde 3 me sale en el log continuamente este mensaje:


Code: [Select]


un 11 05:30:01 alf HORDE[19083]: [kronolith] DB Error: no such table: SELECT vfs_id FROM horde_vfs WHERE vfs_path  = '.horde/scheduler' AND vfs_name = 'horde_scheduler_kronolith' [nativecode=1146 ** Table 'horde.horde_vfs' doesn't exist] [on line 78 of "/home/httpd/html/horde/lib/Horde/Scheduler.php"]
Jun 11 05:35:00 alf php: PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/curl.so' - /usr/lib/php4/curl.so: cannot open shared object file: No such file or directory in Unknown on line 0
Jun 11 05:35:00 alf php: PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/domxml.so' - /usr/lib/php4/domxml.so: cannot open shared object file: No such file or directory in Unknown on line 0
Jun 11 05:35:00 alf php: PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mcrypt.so' - /usr/lib/php4/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0
Jun 11 05:35:00 alf php: PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mhash.so' - /usr/lib/php4/mhash.so: cannot open shared object file: No such file or directory in Unknown on line 0
Jun 11 05:35:00 alf php: PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/fileinfo.so' - libmagic.so.1: cannot open shared object file: No such file or directory in Unknown on line 0


Alguien sabe que es?

Muchas gracias

David (vertical)

Fallos en PHP
« Reply #1 on: July 29, 2006, 09:50:14 PM »
Ello indica claramente que no estan cargadas las librerias correspondientes para PHP.
Esto es debido a que has actualizado PHP desde un script .sh pero que no has visto algunas cosas.

Abre el script con un editor de textos (puedes pulsar F4 desde el mc) y podras ver secciones comentadas (esto es con un signo # a la izquierda de la linea) que deberias descomentar (borrarle el #) para que es script baje e instale esas extensiones que te faltan, y por eso te dan ese error.
En tu caso deberias descomentar las lineas en las que hace referencia a bajar los RPM de :
mcrypt; domxml;mhash;curl;fileinfo.

Luego guarda los cambios y ejecutalo nuevamente.

Normando

vertical

Fallos en PHP
« Reply #2 on: July 31, 2006, 06:34:06 PM »
Muchas gracias!!

Justo era eso, he podido arreglar todos menos libmagic.so.1, sabes como podria resolverlo?

Muchas gracias

vertical

Fallos en PHP
« Reply #3 on: July 31, 2006, 06:59:27 PM »
Perdona, fallo mio, ya he encontrado la libreria, estaba en un rpm llamado file.

Saludos!!