Koozali.org formerly Contribs.org

[ANNOUNCE] Webpanel for Subversion (webDAV) on SME Server 7

[ANNOUNCE] Webpanel for Subversion (webDAV) on SME Server 7
« Reply #30 on: September 18, 2006, 06:14:04 AM »
I've just tried the latest version of this contrib (1.0-4) and I'm running into a number of problems.  Am I the only one running into these issues?  

1) When attempting to create a new repository I get an error message that the name is too long.  The error message is missing the maximum length allowed.  This appears to be caused by a missing configuration property for maxRepositoryNameLength. (I created bug #1915 for this issue.)

2) After resolving the above issue by manually creating the configuration property I was able to successfully create a repository (at least according to the web interface) but I was unable to access it.  I checked /var/log/messages and it reported the following error:

Sep 17 21:43:44 port esmith::event[9024]: Running event handler: /etc/e-smith/events/actions/adjust-services
Sep 17 21:43:44 port esmith::event[9024]: No conf db entry for service httpd-s-smith

This appears to be caused by a typo.  (I created bug #1916 for this issue).

3) I've manually restarted the web server but now I get a "500 Internal Server Error" when attempting to access the repository URL.  It may be that the previous error resulted in the setup not completing properly.  In any case the web interface lied to me. :(

I really like the idea of this contrib but unfortunately the latest incarnation doesn't seem to be functional.

Thanks for your help...
Corey

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
[ANNOUNCE] Webpanel for Subversion (webDAV) on SME Server 7
« Reply #31 on: September 18, 2006, 12:05:14 PM »
Quote from: "cpuffalt"
I've just tried the latest version of this contrib (1.0-4) and I'm running into a number of problems.  Am I the only one running into these issues?  

1) When attempting to create a new repository I get an error message that the name is too long.  The error message is missing the maximum length allowed.  This appears to be caused by a missing configuration property for maxRepositoryNameLength. (I created bug #1915 for this issue.)

2) After resolving the above issue by manually creating the configuration property I was able to successfully create a repository (at least according to the web interface) but I was unable to access it.  I checked /var/log/messages and it reported the following error:

Sep 17 21:43:44 port esmith::event[9024]: Running event handler: /etc/e-smith/events/actions/adjust-services
Sep 17 21:43:44 port esmith::event[9024]: No conf db entry for service httpd-s-smith

This appears to be caused by a typo.  (I created bug #1916 for this issue).

3) I've manually restarted the web server but now I get a "500 Internal Server Error" when attempting to access the repository URL.  It may be that the previous error resulted in the setup not completing properly.  In any case the web interface lied to me. :(

I really like the idea of this contrib but unfortunately the latest incarnation doesn't seem to be functional.

Thanks for your help...
Corey
As soon as I find the time I will try and release a new version... I unfortunately had (and still don't have) no clean test machine and had to restore everything from scratch after my server crashed. I will follow up in your bug reports. Thanks so far!
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
[Announce] semserver-subversion-1.0-5.noacrh.rpm released
« Reply #32 on: September 26, 2006, 07:30:56 PM »
A new release of smeserver-subversion is available. This version fixes bugs 1915 and 1916.

Insatallation instructions can be found here.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline jvels

  • ***
  • 130
    • http://vels.dk
Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #33 on: September 26, 2006, 09:47:39 PM »
Quote from: "cactus"
A new release of smeserver-subversion is available. This version fixes bugs 1915 and 1916.

Insatallation instructions can be found here.


Page down   :cry:

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #34 on: September 26, 2006, 11:14:42 PM »
Quote from: "jvels"
Quote from: "cactus"
A new release of smeserver-subversion is available. This version fixes bugs 1915 and 1916.

Insatallation instructions can be found here.


Page down   :cry:
Nope... not as far as I know... the log file gives no error messages. Please try again... I don't have the fastest connection but it should be alive.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #35 on: September 27, 2006, 02:14:21 AM »
Quote from: "cactus"
Quote from: "jvels"
Quote from: "cactus"
A new release of smeserver-subversion is available. This version fixes bugs 1915 and 1916.

Insatallation instructions can be found here.


Page down   :cry:
Nope... not as far as I know... the log file gives no error messages. Please try again... I don't have the fastest connection but it should be alive.


Your site isn't accessible for me either...

Offline jvels

  • ***
  • 130
    • http://vels.dk
Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #36 on: September 27, 2006, 08:51:17 AM »
Quote from: "cactus"
Quote from: "jvels"
Quote from: "cactus"
A new release of smeserver-subversion is available. This version fixes bugs 1915 and 1916.

Insatallation instructions can be found here.


Page down   :cry:
Nope... not as far as I know... the log file gives no error messages. Please try again... I don't have the fastest connection but it should be alive.


I have tryed a other conenction :roll:
Have you consider to use sf.net or something else?

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #37 on: September 27, 2006, 07:49:54 PM »
Quote from: "jvels"
I have tryed a other conenction :roll:
Sorry I had a problem with my connection... everything should be ok now. Sorry for the inconvenience.
Quote from: "jvels"
Have you consider to use sf.net or something else?
Nope, not until now as everything went perfectly OK until now.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #38 on: September 27, 2006, 10:04:53 PM »
Quote from: "cactus"
Quote from: "jvels"
I have tryed a other conenction :roll:
Sorry I had a problem with my connection... everything should be ok now. Sorry for the inconvenience.
Quote from: "jvels"
Have you consider to use sf.net or something else?
Nope, not until now as everything went perfectly OK until now.


I was able to access your site briefly but it went down again before I could install the updated rpm.  Is there any chance that you could upload the rpms somewhere else.  Perhaps sf.net as was already suggested?

Thanks,
Corey

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #39 on: September 28, 2006, 07:53:27 PM »
Quote from: "cpuffalt"
I was able to access your site briefly but it went down again before I could install the updated rpm.  Is there any chance that you could upload the rpms somewhere else.  Perhaps sf.net as was already suggested?

Thanks,
Corey
Once again sorry... my router died, it worked for a while after restoring the configuration. It is now replaced and this should fix it permanently so please try again.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #40 on: September 29, 2006, 04:40:53 AM »
Quote from: "cactus"
Once again sorry... my router died, it worked for a while after restoring the configuration. It is now replaced and this should fix it permanently so please try again.


Ok so I managed to update to the latest version.  Was this tested version at all?  I just created a test repository with the following options: private, authentication required, don't force http over ssl and when I try to access the repository I get a "500 Internal Server Error".  When I check the http log it reports the following error:

[Thu Sep 28 20:33:03 2006] [crit] [client 10.2.2.94] configuration error:  couldn't check access.  No groups file?: /playground/

Did I do something wrong?

Thanks,
Corey

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #41 on: September 29, 2006, 10:53:42 AM »
Quote from: "cpuffalt"
Quote from: "cactus"
Once again sorry... my router died, it worked for a while after restoring the configuration. It is now replaced and this should fix it permanently so please try again.


Ok so I managed to update to the latest version.  Was this tested version at all?  I just created a test repository with the following options: private, authentication required, don't force http over ssl and when I try to access the repository I get a "500 Internal Server Error".  When I check the http log it reports the following error:

[Thu Sep 28 20:33:03 2006] [crit] [client 10.2.2.94] configuration error:  couldn't check access.  No groups file?: /playground/

Did I do something wrong?

Thanks,
Corey
Could you please report it to the bugtracker so I can follow up there?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Re: [Announce] semserver-subversion-1.0-5.noacrh.rpm release
« Reply #42 on: September 30, 2006, 06:40:16 PM »
Quote from: "cactus"
Quote from: "cpuffalt"

Ok so I managed to update to the latest version.  Was this tested version at all?  I just created a test repository with the following options: private, authentication required, don't force http over ssl and when I try to access the repository I get a "500 Internal Server Error".  When I check the http log it reports the following error:

[Thu Sep 28 20:33:03 2006] [crit] [client 10.2.2.94] configuration error:  couldn't check access.  No groups file?: /playground/

Did I do something wrong?

Thanks,
Corey
Could you please report it to the bugtracker so I can follow up there?


I've reported bug #1953.  Would you please consider changing the naming of the rpm to indicate that it's a beta or alpha version?

zzrpat

Successful install
« Reply #43 on: November 16, 2006, 08:32:00 AM »
Hi,

Reporting a successful install, once I read this and this

Note to others: you will need to reboot. Your repo is available at the URL:
http://yourserver/reponame
(assuming you aren't using SSL)

cactus: is there any chance you could add backslashes to the command at http://www.snetram.nl/?p=9 to allow for copy/paste?

Cheers!

Darren

Re: Successful install
« Reply #44 on: December 20, 2006, 11:59:20 AM »
Hi

I have successfully installed and created a new repository using the webserver panel but cannot access the new repository on the server via http.

Created cals all is created successfully using the webserver panel
but if I try access to http://myserver/cals
but just get the message:-

>>>>>>>>>>>
Forbidden
You don't have permission to access /cals on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request
<<<<<<<<<<<

When I look at the server I find the cals directory is created at
/home/e-smith/files/repositories/cals

whereas you would expect cals ibay to be created at
/home/e-smith/files/ibays/cals

Also cannot get the te installation help at the web address given
IE http://www.snetram.nl/?p=8  This address just times out, have try a couple of times and can get the other files but not this one.

Can anyone supply the install document, please...

Thanks.