Koozali.org formerly Contribs.org

Qmail / Remote Queue / Ping Problem Please help!

domh

Qmail / Remote Queue / Ping Problem Please help!
« on: May 21, 2006, 05:06:41 AM »
Hi there,

I am running 6.01 and up until a couple of days ago it has been working fine.  Checked the mail queue about 5 days ago and noticed that that the remote queue had about 80+ messages in it.  Unable to fix it so using qmHandle I cleared out all messages hoping this would fix it.  

However the messages just stacked up again.  I also noticed that I cannot ping from a putty connection to the outside world however I can lynx any site.  Going in works fine, I can connect to the server-manager remotely and can login via putty so it seems to be something associated with going out from the box.  A couple of errors I found in qmail-current:

Sorry,_I_wasn't_able_to_establish_an_SMTP_connection


Thanks

Dom

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: Qmail / Remote Queue / Ping Problem Please help!
« Reply #1 on: May 21, 2006, 10:43:33 AM »
Quote from: "domh"
Hi there,

I am running 6.01 and up until a couple of days ago it has been working fine.  Checked the mail queue about 5 days ago and noticed that that the remote queue had about 80+ messages in it.  Unable to fix it so using qmHandle I cleared out all messages hoping this would fix it.  

However the messages just stacked up again.  I also noticed that I cannot ping from a putty connection to the outside world however I can lynx any site.  Going in works fine, I can connect to the server-manager remotely and can login via putty so it seems to be something associated with going out from the box.  A couple of errors I found in qmail-current:

Sorry,_I_wasn't_able_to_establish_an_SMTP_connection


Thanks

Dom
Have you been able to run a mailserver on this account earlier or are you trying to get one running for the first time on this account? Does your provider allow you to run your own mail-server? Does your provider use anti-spam measures like blocking port 25 etc.? Did they change anything? Did you make any modifications?

Is there some more information in the qmail-current log that explain more details about the error or is there just the line you posted here?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline raem

  • *
  • 3,972
Re: Qmail / Remote Queue / Ping Problem Please help!
« Reply #2 on: May 21, 2006, 04:08:28 PM »
domh

>...the remote queue had about 80+ messages in it.

What makes you think that that is a problem ?
Are all of your outgoing messages not getting delivered or only some ?
Qmail will keep trying to deliver a message for 7 days, so it will stay in the queue for that long, before qmail gives up completely.

The log messages are probably telling you the problem, ie that your server could not establish a smtp connection with the server that is is trying to deliver a message to.

Theoretically on a busy server you could have hundreds (or even more) messages in the remote queue that cannot be delivered to other servers for a variety of reasons.
If the dates on any of those messages are older than 7 days then you do have a problem, but for 7 days qmail will keep retrying to deliver the messages, and then finally give up.
...

domh

Qmail / Remote Queue / Ping Problem Please help!
« Reply #3 on: May 25, 2006, 12:15:38 AM »
Hi All.

Ray, the remote queue kept building up this server only sends about 5 messages a day so that was a lot for it.  

I discovered the solution.  The ISP had blocked port 25 (Weird because I use the same ISP for my home server and no problems there).  We changed the STMP settings on server-manager to be the ISP's SMTP server and all worked again.  

CHeers All!