Koozali.org formerly Contribs.org

[ANNOUNCE] smeserver-backuppc

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-backuppc
« on: May 19, 2006, 03:30:48 PM »
hello everyone.
I've just finish a little contrib witch simplify the installation of backuppc 2.1.2 (with the last patch) on SME7.
I tested it on SME7rc2 and it seems to work great.
I'd like some people to test it and repport if there's problem.
Backuppc is a realy powerfull backup solution. One of his main features (The one wich was the most impressing for me) is an cgi interface for the restoration of the file. With this, every user can access their backups and restors the file they wan't without having to ask the administrator to do that.
you can have a full description on the official site: http://backuppc.sourceforge.net/

here the how-to: http://sme.firewall-services.com/spip.php?article3
here is the contrib http://sme.firewall-services.com/downloads/smeserver-backuppc/rpms/

I'm working on a interface to configure it through the server manager and a first simple version should be available soon.
C'est la fin du monde !!! :lol:

jcoleman

[ANNOUNCE] smeserver-backuppc
« Reply #1 on: May 21, 2006, 03:56:41 PM »
VIP-ire

Installed everything as per your howto and got the following error when logging in.  This is a stock sme7rc2 box.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@test.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

Any ideas?

-Jeff

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-backuppc
« Reply #2 on: May 21, 2006, 04:29:43 PM »
Well, I find it strange. I tried on two rc2 and it worked well.
Have you enable the exec of dynamic content on the ibay backup?

can you tell me what report this commands just after trying to acceed the admin page of backuppc
tail /var/log/httpd/error_log
tail /var/log/messages
ll /home/e-smith/files/ibay/backup/cgi-bin/
ll /usr/share/backuppc/lib/BackupPC/
ll /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf/

any error will runing the install script?

thanks for testing,
i'll do my best to figure out what's happened.
C'est la fin du monde !!! :lol:

[ANNOUNCE] smeserver-backuppc
« Reply #3 on: May 21, 2006, 11:59:06 PM »
Quote from: "jcoleman"

Any ideas?


Apache error log should tell you more.

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-backuppc
« Reply #4 on: May 22, 2006, 03:49:30 PM »
nobody has successfully installed it?
C'est la fin du monde !!! :lol:

jcoleman

[ANNOUNCE] smeserver-backuppc
« Reply #5 on: May 22, 2006, 04:17:52 PM »
VIP-ire,

My mistake.  A complete reinstall worked just fine.  My problem was a typo.  Once corrected, it worked perfectly as installed.

Now to test functionality....

Thanks for the contrib!

-jeff

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-backuppc
« Reply #6 on: May 29, 2006, 01:14:07 PM »
The first version of the panel is now ready, tested on two machines and it works.

You can download at http://sme.firewall-services.com/files/backuppc_panel_v1.0.tar.gz

and the howto at http://sme.firewall-services.com/files/howto_backuppc.pdf
C'est la fin du monde !!! :lol:

icpix

[ANNOUNCE] smeserver-backuppc
« Reply #7 on: May 29, 2006, 01:27:17 PM »
Quote from: "VIP-ire"
nobody has successfully installed it?

I tried. The filename is not as indicated for the tarball but I worked it out. The install script is in French(?) but I tried running it on my UK English server. Some of the directory structure is there but I feel there should be much more... I manually unzipped the tar and found many files... Now I don't whether the uninstall script is any better than the install wasn't;~/
----best wishes, Robert

icpix

[ANNOUNCE] smeserver-backuppc
« Reply #8 on: May 29, 2006, 01:36:32 PM »
Quote from: "VIP-ire"
The first version of the panel is now ready, tested on two machines and it works.

This time I manually unzipped the tar, then sh install...
[root@teri backuppc_panel_v1.0]# sh install
: command not found
: command not found
: command not found
: No such file or directory
: command not found
: No such file or directory
: No such file or directoryn
: No such file or directoryd
: No such file or directoryd
: No such file or directory
: ambiguous redirect
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directoryr
: No such file or directoryr
: No such file or directory
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directoryh
: No such file or directoryith/templates/etc/sudoers/30Backuppc
: No such file or directorymith/expand-template
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
install: line 52: -u: command not found
: No such file or directoryd
: No such file or directory
: No such file or directoryn
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directory
: command not found
: No such file or directorymith/expand-template
: No such file or directorymith/expand-template
Usage: /etc/rc.d/init.d/backuppc {start|stop|restart|reload|status}
: command not found
: No such file or directory
[root@teri backuppc_panel_v1.0]#

----best wishes, Robert

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-backuppc
« Reply #9 on: May 29, 2006, 02:42:01 PM »
Quote
The filename is not as indicated for the tarball

What do you mean by not as indicated? there's two diiferents archives:
       -one called smeserver-backuppc2.1.2.tar.gz for the program
       -one called backuppc_panel_v1.0.tar.gz for the server-manager panel
I don't see any mistake on the file name

Quote
The install script is in French

It's in french 'cause I'm french but should work on english server. I will provide an english version soon. the panel itself is in english.

Quote
I manually unzipped the tar

What do you mean by manually? don't you use the "tar xvzf" command as it's explained in the howto?

I'll try to provide the contrib in an rpm file as soon as I have the time.

does the install of the smeserver-backuppc2.1.2 succed? You cannot install the pannel since  it's not installed

Have you followed all the steps of the howto?
C'est la fin du monde !!! :lol:

icpix

[ANNOUNCE] smeserver-backuppc
« Reply #10 on: May 29, 2006, 05:46:44 PM »
I followed your earlier PDF etc... Now I follow your new PDF but there are errors and it's not particularly clear for me;~/ I have started over again and got further;~) I used the uninstall to help clear up my earlier attempt(s). Now installed once again and also run the panel installer. Can't see the panel yet... think I need to use some sort of signal-event command to restart the whole panel so I can see the new additional backuppc stuff. In my SME6 notes I have an entry for "refreshes menu link layouts" with the command </etc/e-smith/events/actions/navigation-conf> but this didn't do the trick this time (with SME7). Do I have to reboot (just to see the extra menu entry for the panel)?
----best wishes, Robert

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
[ANNOUNCE] smeserver-backuppc
« Reply #11 on: May 29, 2006, 06:01:47 PM »
the install script of backuppc-panel should rebuild the main server-manager page.
The errors apears for the smeserver-backuppc or the backuppc_panel?
can you see the admin page of backuppc at http://yourserver/backup/cgi-bin/BackupPC_Admin

If you want to clear all you can suppr the ibay backup and re-create it
You can also run this commands (even if the uninstall scripts should have done this)
rm -Rf /usr/share/backuppc
rm /etc/e-smith/web/functions/backuppc
rm /etc/e-smith/web/panels/manager/cgi-bin/backuppc
rm -Rf /etc/e-smith/db/configuration/defaults/backuppc/
rm /home/e-smith/db/backuppc
rm /etc/e-smith/templates/etc/sudoers/30Backuppc
rm -Rf /etc/e-smith/templates/home/e-smith/files/ibay/backup/files/conf/*
rm /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf/99authbackuppc
expand-template /etc/httpd/conf/httpd.conf
expand-template /etc/sudoers

If you cannot acced the admin page of backup there's probably an error creating the ibay, the user backuppc or the group backups
C'est la fin du monde !!! :lol:

icpix

[ANNOUNCE] smeserver-backuppc
« Reply #12 on: May 29, 2006, 06:18:14 PM »
Reboot did not make the new menuline entry (for backuppc) appear. Used the backuppc uninstall - errors. Used the backuppc install - errors. Now(!?) I see the new backuppc menuline entry in the server manager panel;~)
----best wishes, Robert

icpix

[ANNOUNCE] smeserver-backuppc
« Reply #13 on: May 29, 2006, 06:22:06 PM »
Our posts crossed in time. I have a panel now. I have not been able to access the http://yourserver/backup/cgi-bin/BackupPC_Admin stuff at all. Does it matter that my SME is serveronly ie not servergateway?
----best wishes, Robert

icpix

[ANNOUNCE] smeserver-backuppc
« Reply #14 on: May 29, 2006, 06:36:50 PM »
Cannot use h t t p://myserver/backup/cgi-bin/BackupPC_Admin - always 404.
Have server-manager panel showing backuppc stuff (4 lines of click here).
Group, User and iBay all setup as shown in PDF.
Issue might be how I access SME7 (serveronly) across my intranet.
Am uncertain exactly how to configure this as it doesn't seem to be like SME6.
To control/configure/install I use a PuTTy (SSH2) link.
To view and normally use I choose my intranet...
Is there a simple backup test to I can perform to test functionality?
----best wishes, Robert