Koozali.org formerly Contribs.org

FTP remote login

FTP remote login
« on: April 23, 2006, 10:24:42 PM »
I'm not sure but users cannot login to the primary ibay as admin

I mean don't you just go to ftp://admin@????? to login for ftp access and uploads etc.

of course using sftp or other client

I have remote access enabled, from anywhere so why would there be a problem ?

Please advise

FTP remote login
« Reply #1 on: April 24, 2006, 01:01:22 AM »
If using IE to browse your FTP site, just go ftp.externip.com then right click and go login as.
Otherwise it would be in the format of ftp://username:password@externip.com

no ftp loggin
« Reply #2 on: April 24, 2006, 03:25:18 AM »
I don't know why but I have no remote ftp login

I thought that all was working as it should cause it was working from my local machines, but I just found out today that i have no ftp remote login

Does the primary ibay have ftp access by default when logging on as root or admin etc. ? note: I have ftp web access enabled

I also get no ftp access to the users home folders, or any other ibays or users with group access, which has write,read access etc.

I get nothing from remote, I thought I all was fine cause I was using ftp programs to upload files, however I was using a local machine not realizing I have no remote ftp acces.

Anyhow I've read the documentation regarding ftp and ibays,users,groups etc. and I believe it should be working,but I must be missing something.

what is the typical remote login to access my primary ibay, and to upload files to my cgi-bin

according to the documentation it's either www.???.com/ibay for downloading or annonymous, or ftp://user:pass@ftp.yourdomain
However from my local machine also ftp://user:pass@yourdomain

Anyhow I just want to upload files, and the section for ftp (server-manager) says something about ftp and secure shell?
Do I have to enable remote ssh for remote shell etc. in order to get the ftp remote login working, or no?

Please advise

Thanks

Please advise on this subject

I don't know ?
« Reply #3 on: April 25, 2006, 04:57:27 AM »
I just don't know?

I should be able to login to an ftp folder or something from remote, but I just can't

What have I done wrong?
Someone please walk me thru the basic critical items to access my primary ibay ftp for uploading a php script etc.

I've followed the documentation and just don't get it.

Can you upload to primary from remote ?

Please advise

FTP remote login
« Reply #4 on: April 25, 2006, 05:57:03 AM »
Something that may or may not help is the user remote access contrib from dungog.net. It is in his free list, and it will help in keeping your ftp users where you want them.

Make sure that you have set ftp to allow public access. I would reccomend that you leave ftp password at accept passwords only from local networks if possible. Mine is set to accept passwords from anywhere.

These settings are near the bottom of the remote access page in server manager
If you think you know whats going on, you obviously have no idea whats going on!

FTP remote login
« Reply #5 on: April 25, 2006, 08:18:09 AM »
I don;t think dungog's contrib is working on sme 7 yet.
In server manager under FTP settings, select allow public access and in the box below it select accept passwords from anywhere.

That should give you external ftp access.

Be sure that everyone is using tough passwords though.

Also I don't think you can access the primary i-bay externally (I could be wrong on that point though) <digs out alfoil hat incase>

Something is wrong ?
« Reply #6 on: April 25, 2006, 12:54:39 PM »
I think something is wrong

I have ftp enabled pubic, and passwords from anywhere

I do not know why I cannot access my ibays from remote

I have initially been trying to access the primary ibay from remote, but I do not have access to any other ibays remotely either

Could this have anything to do with the DNS records ? I mean my domain is working and I added a DSN A record for my domain etc. site comes up remotely and webmail is working so I'm assuming that is ok, but the DNS wouldn't be able to block andy ftp ports would it ?

I don't know what else it could be I'll try some more

Someone please confirm that the admin can access the Primary ibay remotely ??? or not



anymore ideas would be great, thanks

FTP remote login
« Reply #7 on: April 25, 2006, 02:40:17 PM »
I do not think dns can block access, but you may want a ftp "C" record pointing to your domian .

When some one tries to connect with ftp, do they get any kind of error messages?

If they are connecting, are they getting only their home directory? if so, install the remote access panel I mentioned. That will allow you to control where they have access.
If you think you know whats going on, you obviously have no idea whats going on!

ibays
« Reply #8 on: April 25, 2006, 10:10:32 PM »
Hi all and thanks for the replies

Yes, some type of yahoo 220 error message and a permission 550 message all on the same popup window, and a reference to something about http://help.yahoo.com/help/us/ftp/???

basically it's some document about uploading to your ftp space, but I don't have ftp space with them, I only have domain services, but pehaps this is some C record things I have to change.

Regarding users, I've not tried really with thier home folders I'm mainly wanting access to the ibays, or primary ibay in which to allow someone to install a php script.

They are not living with me LOL so they have not local access, LOL
Anyhow,
I simply want to give them access, or even give them my admin user and pass at this point I don't care really I just want to see if there is any access at all for ftp folders.

I do not appear to have any access, for users home folders,ibays,primary ibay, or admin, nothing currently except local login access functioning as it should locally.

But when loggin locally it appears to work as it should, I'll try to edit the C record and see if that does anything, however there is a C record setup for Cname= *.foolishlys.com which is my domain but using(yahoo server)
I'll change it to destination my domain, and see if that changes the effect

and I added an A record for foolishlys.com destination my static IP

Site seems to work fine, but no ftp.Mail is working fine.

It will take 24-48 hours according to yahoo, for the updates so I'll see what happens and post the any changeS.
I'll post the result

Any other ideas for this topic would be great, I'm very excited about the project I'm working on and would love to get this solved.

In the mean time also can someone please confirm that SME will allow remote access to the primary ibay ??

Thanks

No change
« Reply #9 on: April 27, 2006, 12:36:54 AM »
I have not change, howeve I do have ftp access to user folders which I recently tried, and confirmed.

But still no access to ibays or primary ibay

Please confirm is there access to primary ibay from remote

Please advise
Thanks

FTP remote login
« Reply #10 on: April 27, 2006, 12:48:30 AM »
Unless they are admin, I do not beleive they can get out of their user folders. I will again suggest applying the user remote access contrib from dudgog. It is the easy way to allow them to get to where you want let your users into.

Bob
If you think you know whats going on, you obviously have no idea whats going on!

Thanks but ?
« Reply #11 on: April 27, 2006, 03:24:28 AM »
Thanks for the reply

But I don't really even care about any users access or ibays at the moment, I mainly want to access my primary ibay remotely so that I may upload my webpages or actually give my admin- user and password -to my partner to access remotely for php script installation.

I'll workout the users ibay access topic. later.

And I don't really want to use an addon cause when I upgrade I don't want any problems, I just want to use the SME default packages for upgrade purposes.

So the main question is: Does SME allow access to the primary ibay remotely ?
And If so, What is the method to access and review, because I'm having no luck accessing the primary at all.

The only reasone I've attempted to setup ibays and users/groups is to see if they would get access, in an attempt to figure out why I cannot seem to access the primary ibay remotely, and found out that I have no access to any ibays including the primary.

So now I'm not sure what to do, or why I can't seem to access ibays remotely. Nor can I access with the browser just for viewing.

However I do seem to be able to access the users home folders for some reasone without problems

I wonder if a re-install is needed, or how to diagnose this problem.

I am also getting some type of error (421 concurency limit has been reach) I don't understand this either.

I appreciate everyones help in this matter
Thanks

Without real reason this problem is solved
« Reply #12 on: April 30, 2006, 04:55:58 PM »
Hi all and thanks for the help

See: my other post FTP login 2

This problem appears to be solved, I'm not sure why or how exactly but I believe is a combonation of setting my ibays to no password needed, and also setting IE browser to passive, and also Yahoo may have made some changes without my knowledge since I've emailed them about this.

But I've made no real changes other then to change my ibay access to internet no passwords needed, and all of the suddent I can access my primary ibay remotely.

This does not make much sense since I cannot change the primary ibay configuration from the server-manager.
So I have to assume a bug, or yahoo fixed the problem
Thanks again to all I'm considering this topic solved

 :hammer: