Koozali.org formerly Contribs.org

CUPS - WINXP printing problem

CUPS - WINXP printing problem
« on: April 24, 2006, 09:08:08 PM »
Using a sme 6.0.1-01. Running cups-1.1.19-8smea1 from rvandenaker, thx btw. Frontends are winxp, sp2. Here's my problem: for users printing text-files is o.k. printing large grafic-files (apx. 100 MB) the winxp-client shows an error and is not printing. I installed the printer as admin (NOT administrator). Then I installed the printer as administrator - and the file has been printed. Left all settings on the default. The printer is a HP Color LaserJet 2840. Connected to the server as http://192.168.153.101:631/printers/hp_2840 from the client. CUPS is set up as a HP JetDirect, raw queue. The adress is socket://192.168.153.130:9100. The settings in the cups.conf and in the smb.conf should all be fine - the printer works with small or only text files. The server is up to date by yum.

Anybody any idea?
Thank's in advance
And then one day you find ten years have got behind you.

Time, 1973
(Mason, Waters, Wright, Gilmour)

Robert

CUPS - WINXP printing problem
« Reply #1 on: April 25, 2006, 10:36:42 PM »
Sometimes increasing the LogLevel of the cupsd scheduler can help you find out what's going on. You can do this with:

# mkdir -p /etc/e-smith/templates-custom/etc/cups/cupsd.conf
# cp /etc/e-smith/templates{,-custom}/etc/cups/cupsd.conf/20LogLevel
# sed -i s/info$/debug/ /etc/e-smith/templates-custom/etc/cups/cupsd.conf/20LogLevel
# signal-event cups-reconfigure

Feel free to e-mail me if you want me to have a look at the logs. My e-mail address is in the documentation for e-smith-cups.

Cheers,
Robert

CUPS - WINXP printing problem
« Reply #2 on: April 26, 2006, 09:33:16 AM »
I set the level on debug2 - I'll mail you the logs.

Thank's
Stefan
And then one day you find ten years have got behind you.

Time, 1973
(Mason, Waters, Wright, Gilmour)