Koozali.org formerly Contribs.org

Great news on Open-xchange in sme6/7

vinc28

Great news on Open-xchange in sme6/7
« on: April 15, 2006, 10:57:58 AM »
i have made the final version of ox 8.2 rc3 on both sme6 and sme7

with an update system

give me your feedback .......

for the sme7 version you don't need a special openldap anymore.
ox has drop the ACI options on ldap.


vincent.

my web site where you can found OX for SME:
smeserver http://e-smith.dyndns.org

Offline fixit

  • *
  • 216
    • http://www.fixitcomputers.com.au
Great news on Open-xchange in sme6/7
« Reply #1 on: April 15, 2006, 11:31:07 AM »
The Install went well, but logging in did not
.........

Offline fpausp

  • *
  • 728
Great news on Open-xchange in sme6/7
« Reply #2 on: April 15, 2006, 11:42:50 AM »
Hi,

Got this after my first try:

[root@server ox7rc1_sme7]# rpm -iUvh *.rpm
Fehler: Failed dependencies:
        perl-MIME-Lite is needed by sme7-open-xchange-conf-0.8.2-RC3.2.noarch


fpausp
Viribus unitis

Offline Tib

  • *
  • 571
    • http://www.tibors.net
Great news on Open-xchange in sme6/7
« Reply #3 on: April 15, 2006, 01:28:38 PM »
fixit

Try here

http://smeserver.free.fr/ox/


Regards,

Tib

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Great news on Open-xchange in sme6/7
« Reply #4 on: April 15, 2006, 05:37:06 PM »
Quote from: "fpausp"
Hi,

Got this after my first try:

[root@server ox7rc1_sme7]# rpm -iUvh *.rpm
Fehler: Failed dependencies:
        perl-MIME-Lite is needed by sme7-open-xchange-conf-0.8.2-RC3.2.noarch


fpausp

On SME7 don't use the rpm command but use the yum localinstall command to install local (e.g. downloaded) RPM's. Dependencies are then downloaded from the default repositories for the SME Server if they are found there....
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline jumba

  • ****
  • 291
  • Donations: July 2007 - $ 20.00
    • Smeserver på svenska!
Great news on Open-xchange in sme6/7
« Reply #5 on: April 15, 2006, 10:13:44 PM »
I tried the command yum localinstall sme7-open-xchange-0.8.2-RC3.21.noa rch.rpm
 and this is what I got:



Setting up Local Package Process
Examining sme7-open-xchange-0.8.2-RC3.21.noarch.rpm: sme7-open-xchange - 0.8.2-R C3.21.noarch
Marking sme7-open-xchange-0.8.2-RC3.21.noarch.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package sme7-open-xchange.noarch 0:0.8.2-RC3.21 set to be updated
--> Running transaction check
Setting up repositories
smeaddons                 100% |=========================|  951 B    00:00
contrib                   100% |=========================|  951 B    00:00
updates                   100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
smeos                     100% |=========================|  951 B    00:00
smeupdates                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
--> Processing Dependency: openldap-clients for package: sme7-open-xchange
--> Processing Dependency: sme7-tomcat >= 5.5.12 for package: sme7-open-xchange
--> Processing Dependency: perl-IO-Socket-SSL >= 0.96 for package: sme7-open-xch ange
--> Processing Dependency: perl-Net-SSLeay >= 1.26 for package: sme7-open-xchang e
--> Processing Dependency: sme7-postgresql >= 7.4.8 for package: sme7-open-xchan ge
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for openldap-clients to pack into transaction set.
openldap-clients-2.2.13-4 100% |=========================|  24 kB    00:00
---> Package openldap-clients.i386 0:2.2.13-4 set to be updated
--> Running transaction check
--> Processing Dependency: sme7-tomcat >= 5.5.12 for package: sme7-open-xchange
--> Processing Dependency: perl-IO-Socket-SSL >= 0.96 for package: sme7-open-xch ange
--> Processing Dependency: perl-Net-SSLeay >= 1.26 for package: sme7-open-xchang e
--> Processing Dependency: sme7-postgresql >= 7.4.8 for package: sme7-open-xchan ge
--> Finished Dependency Resolution
Error: Missing Dependency: sme7-tomcat >= 5.5.12 is needed by package sme7-open- xchange
Error: Missing Dependency: perl-IO-Socket-SSL >= 0.96 is needed by package sme7- open-xchange
Error: Missing Dependency: perl-Net-SSLeay >= 1.26 is needed by package sme7-ope n-xchange
Error: Missing Dependency: sme7-postgresql >= 7.4.8 is needed by package sme7-op en-xchange


Any ideas of how to continue?

Offline fpausp

  • *
  • 728
Great news on Open-xchange in sme6/7
« Reply #6 on: April 15, 2006, 11:28:12 PM »
got this now:

[root@server ox7rc1_sme7]# rpm -iUvh *.rpm
Fehler: sme7-tomcat-5.5.12-9.noarch.rpm: MD5 digest: BAD Expected(7fe12e11b1d9fd831bd2d6697f2b97d5) != (dd474a90e6efa055681ea8d4575ca227)
Fehler: sme7-tomcat-5.5.12-9.noarch.rpm cannot be installed
Viribus unitis

vinc28

Great news on Open-xchange in sme6/7
« Reply #7 on: April 16, 2006, 01:04:45 AM »
Quote from: "fpausp"
got this now:

[root@server ox7rc1_sme7]# rpm -iUvh *.rpm
Fehler: sme7-tomcat-5.5.12-9.noarch.rpm: MD5 digest: BAD Expected(7fe12e11b1d9fd831bd2d6697f2b97d5) != (dd474a90e6efa055681ea8d4575ca227)
Fehler: sme7-tomcat-5.5.12-9.noarch.rpm cannot be installed


repared release 5.5.12-10
sorry
 :pint:

Offline fpausp

  • *
  • 728
Great news on Open-xchange in sme6/7
« Reply #8 on: April 16, 2006, 09:54:44 AM »
I use a fresh installed sme7rc1 without any contribs.

ok, now i got this:

[root@server ox7rc1_sme7]# rpm -iUvh *.rpm
Fehler: Failed dependencies:
        openldap-clients is needed by sme7-open-xchange-0.8.2-RC3.21.noarch
    Suggested resolutions:
        openldap-clients-2.2.13-3.i386.rpm


fpausp
Viribus unitis

vinc28

Great news on Open-xchange in sme6/7
« Reply #9 on: April 16, 2006, 01:00:09 PM »
Quote from: "fpausp"
I use a fresh installed sme7rc1 without any contribs.

ok, now i got this:

[root@server ox7rc1_sme7]# rpm -iUvh *.rpm
Fehler: Failed dependencies:
        openldap-clients is needed by sme7-open-xchange-0.8.2-RC3.21.noarch
    Suggested resolutions:
        openldap-clients-2.2.13-3.i386.rpm


fpausp


ok i put this on my site
or try yum install openldap-clients

Offline fpausp

  • *
  • 728
Great news on Open-xchange in sme6/7
« Reply #10 on: April 16, 2006, 02:41:28 PM »
i used openldap-clients-2.2.13-4.i386.rpm:

[root@server ox7rc1_sme7]#  rpm -iUvh *.rpm
Preparing...                ########################################### [100%]
        package perl-DBD-MySQL-2.9004-3.1 is already installed
        file /etc/profile.d/tomcat-java.sh conflicts between attempted installs of sme-tomcat-5.5.12-6 and sme7-tomcat-5.5.12-10
        file /etc/rc.d/init.d/tomcat conflicts between attempted installs of sme-tomcat-5.5.12-6 and sme7-tomcat-5.5.12-10

[root@server ox7rc1_sme7]#
Viribus unitis

Offline jumba

  • ****
  • 291
  • Donations: July 2007 - $ 20.00
    • Smeserver på svenska!
Great news on Open-xchange in sme6/7
« Reply #11 on: April 16, 2006, 02:44:35 PM »
This is interesting indeed!

I've installed this, and solved all depends (I think!).

Now, trying to access http://myserver/cgi-bin/login.pl I get the following message when I try to log in:

Can not build up Socket!
SessionD running?

Plz advise me!

Offline jumba

  • ****
  • 291
  • Donations: July 2007 - $ 20.00
    • Smeserver på svenska!
Great news on Open-xchange in sme6/7
« Reply #12 on: April 16, 2006, 03:18:13 PM »
Proceeding a lot!

Somehow, I've succeeded in installing the system, and it seems to be working quite OK.

BUT:

I cannot change password, - for some reason the username became also the password, and that should be changed from within Open Exchange I think.

Using "Setu" -> "Password" results in:


HTTP Status 404 - /umin/myDataPasswd

type Status report

message /umin/myDataPasswd

description The requested resource (/umin/myDataPasswd) is not available.


Another issue:

Using the server-manager, adding an alias mail address results in the infamous Internal Server Error page...

vinc28

Great news on Open-xchange in sme6/7
« Reply #13 on: April 16, 2006, 07:53:14 PM »
Quote from: "jumba"
Proceeding a lot!

Somehow, I've succeeded in installing the system, and it seems to be working quite OK.

BUT:

I cannot change password, - for some reason the username became also the password, and that should be changed from within Open Exchange I think.



nop the password changing work only with the server-panel.


for the bug on the panels wenesday i fix it ( i hope!)

Offline fixit

  • *
  • 216
    • http://www.fixitcomputers.com.au
Great news on Open-xchange in sme6/7
« Reply #14 on: April 17, 2006, 07:27:05 AM »
I got this error msg on the installation process

pg_dump: [archiver (db)] connection to database "openexchange" failed: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
dropdb: could not connect to database template1: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
dropuser: could not connect to database template1: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
createdb: could not connect to database template1: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
psql: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
psql: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
psql: could not connect to server: No such file or directory
        Is the server running locally and accepting
        connections on Unix domain socket "/tmp/.s.PGSQL.5432"?
Starting : tomcat                                          [  OK  

I got this error in the server-manager

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

add user : subscription to group: users
Undefined ERROR - LDAP CODE
See Server Log for Details!
ERROR

http://192.168.1.50/cgi-bin/login.pl

ERROR: Authentification failed

What is missing or have I done something wrong

Thanks, Russell
.........