Koozali.org formerly Contribs.org

give a user root privileges

give a user root privileges
« on: March 13, 2006, 02:52:37 PM »
I need to give a user root privileges. I am using rsync with ssh  to back up a few remote servers, and want to get all directories that are below  /home/e-smith/files/. If I use a standard user, there is a bunch of stuff that I am denied access to. If I use root. then I must leave “Allow administrative command line access over secure shell” as Yes, which I would prefer not to do, and I do not have to do if I assign a normal user name.
Any help or thoughts greatly appreciated.


A little more info. This all started when I built a new server for backup. I had established keys originaly for a user from the old server, but created new keys for root on the new server. The old server is 6.01, the new server is 7pre4. On the 7pre server I started with root as the user on the remote server and I am able to leave the "allow" at "no"
Do not want to confuse the issue, but too much info is better than too little.
TIA

Bob
If you think you know whats going on, you obviously have no idea whats going on!

CKConsulting

give a user root privileges
« Reply #1 on: March 15, 2006, 05:30:51 AM »
I'm trying to do the same thing but I was thinking about just adding permissions for "testuser" to the directories below /home/e-smith/files/users.

Rick

give a user root privileges
« Reply #2 on: March 15, 2006, 06:53:56 AM »
Rick

Maybe I will work on that also. I did a little more checking, and no matter what, I have to leave “Allow administrative command line access over secure shell” as Yes in all cases that "root" is the user.
If you have another or better solution, I am interested


Bob
If you think you know whats going on, you obviously have no idea whats going on!

CKConsulting

give a user root privileges
« Reply #3 on: March 15, 2006, 01:55:39 PM »
I'm using dungogs rsyc panel and the usershellaccess panel.
When you set up the user for shell access there is an option for sudo access.
I enabled it but it doesn't seem to do anything.
Do I need to run a command to put the user in sudo mode?
From what I understand sudo gives that user root like access????

Rick

Pacjack

give a user root privileges
« Reply #4 on: March 15, 2006, 04:48:28 PM »
Quote from: "CKConsulting"

I enabled it but it doesn't seem to do anything.
Do I need to run a command to put the user in sudo mode?
From what I understand sudo gives that user root like access????

Rick

Using sudo, the user can execute commands as root. Still needs the root password.

(first hit at google: http://www.gratisoft.us/sudo/man/sudo.html)

Landry

give a user root privileges
« Reply #5 on: March 15, 2006, 08:52:13 PM »
Err, this is a common mistake. If you use sudo, you need only users' password, and NOT root password.
Code: [Select]
user@server$sudo reboot
password:"user_password"

CKConsulting

give a user root privileges
« Reply #6 on: March 15, 2006, 09:02:42 PM »
So do I need to run each command starting with sudo?  
sudo rsync
or
Once I set sudo, am I running with sudo rights until I log off?

Thanks
Rick

give a user root privileges
« Reply #7 on: March 15, 2006, 10:03:26 PM »
Short email discussion with Stephen Nobel at dungog, and he says that I am stuck using "root" to get all the stuff I want using rsync. Sudo gives you root access for only a short time. This works.He also has an updated / corrected version of the rsync contrib for 7pre4. It is not in the repository yet, but I would guess that it will be soon.

Bob
If you think you know whats going on, you obviously have no idea whats going on!

CKConsulting

give a user root privileges
« Reply #8 on: March 16, 2006, 03:15:48 AM »
Any thoughts on giving the backup user rights to those directories?
Rick