Koozali.org formerly Contribs.org

yum update: identical dependency loop exceeded

aaron

yum update: identical dependency loop exceeded
« on: March 08, 2006, 06:41:28 PM »
I upgraded a longtme e-smith box (from pre 512 days) from its current Mitel 6 Unsupported to contribs 601. The upgrade seemed to go A-OK.

I then downloaded and installed the python & yum RPM then did the yum update. The update aborts with a "dependency loop exceeded error":

[root@shopserver updates]# yum update
Gathering package information from servers
Getting headers from: SME Server 6.0.1 os
Getting headers from: SME Server 6.0.1 updates
Getting headers from: SME Server 6.x base updates
Finding updated packages
Downloading needed headers
Resolving dependencies
....identical dependency loop exceeded
package php-pgsql needs php = 4.1.2-2es3 (not provided)
package php-pgsql needs php = 4.1.2-2es3 (not provided)

So apparently the component "php-pgsql" requires "php 4.1.2-2es3". I *think* I am correct in checking the installed PHP version by:

[root@shopserver root]# rpm -qa | grep php
php-imap-4.1.2-7.3.6es1
php-pgsql-4.1.2-2es3
e-smith-php-1.10.0-01
php-ldap-4.1.2-7.3.6es1
php-mysql-4.1.2-7.3.6es1
php-4.1.2-7.3.6es1

So it appears PHP is 4.1.2-7+ so does this mean the php-pgsql need that exact version - i thought a higher version would suffice.

Or am I on the wrong track completely?

Any tips or suggestions greatly appreciated.

Offline wellsi

  • *
  • 475
    • http://www.wellsi.com
yum update: identical dependency loop exceeded
« Reply #1 on: March 09, 2006, 11:23:13 PM »
This was also raised on DevInfo


>Package php-pgsql needs php = 4.1.2-2es3 (not provided)

Php-pgsql was not provided in the original SME 6.x releases, so the update
Does not provide a new version of this.

However the build system did generate this file which is currently available

At (not tested) :
http://wellsi.com/sme/patches/6.0/php-pgsql-4.1.2-7.3.18.legacy.sme1.i386
rpm
----

However - unless you know that you really need php-pgsql I recommend that you remove it. This simpler option was suggested by Charlie and solved the problem for others.

----

A very easy way to see what RPMs are included in all 6.x distros is look at http://wellsi.com/sme/info/sme6releases-iso-versions.html

There's another page with even more SME versions and their original RPMS http://wellsi.com/sme/info/smereleases-rpms.html


For information: SME 5.5 and earlier all had php-pgsql, SME 5.5 had 4.1.2 and earlier 5.x versions had 4.04


So unless you really need it then just remove php-pgsql.

Ian
............

aaron

yum update: identical dependency loop exceeded
« Reply #2 on: March 10, 2006, 08:01:24 PM »
Ian, thanks for taking the time to respond.

I did remove the php-pgsql RPM (rpm -e php-pgsql) as suggested and the yum update now proceeds as expected without error or warning.

Many thanks for the tip and also for the reminder to check DevInfo for secondary Searches, I'd forgotten about that resource.

Aaron.

PS:

FYI, I did try to install the update from the link you provided but it appeared need other items. I dont have a need for the RPM in question so I just removed it.

error: failed dependencies:
        php = 4.1.2-7.3.18.legacy.sme1 is needed by php-pgsql-4.1.2-7.3.18.legacy.sme1
        postgresql-libs is needed by php-pgsql-4.1.2-7.3.18.legacy.sme1
        libpq.so.2   is needed by php-pgsql-4.1.2-7.3.18.legacy.sme1