Koozali.org formerly Contribs.org

Getting to /webmail/ on another internal webserver via SME6

Pacjack

Getting to /webmail/ on another internal webserver via SME6
« on: February 28, 2006, 10:25:21 PM »
I would like to use one SME 6.01 server for www (web, html/php/mysql) and another SME server (7 pre3) as mailserver.

I have forwarded port 80 to the www server and port 25/110 to the mail server by changing the settings in my firewall (SpeedTouch 716v5 router). My websites and e-mail are working very well.

How to get to the /webmail/ directory on the mailserver from the internet? I only have one external IP address, so i can only forward port 80 once to one internal IP addres (web). Something in the Apache config?

Pacjack

Getting to /webmail/ on another internal webserver via SME6
« Reply #1 on: March 01, 2006, 10:09:08 AM »
I tried using the proxypass contrib @ http://mirror.contribs.org/smeserver/contribs/aloveless/contribs/proxypass/dmc-mitel-proxypass-0.0.1-3.noarch.rpm



Code: [Select]
Path   Target   Description   HTTP   HTTPS   ValidFrom    
/webm/ http://192.168.1.161/webmail/ none yes yes all

But when I browse to http://external_ip/webm/ I notice the browser is redirected to http://192.168.1.161/ instead of getting the right data trough the SME Server. Something wrong with this contrib or am I doing something weird?

Getting to /webmail/ on another internal webserver via SME6
« Reply #2 on: March 01, 2006, 02:10:05 PM »
Can you paste all lines that have the word ProxyPass and ProxyPassReverse from the /etc/httpd/conf/httpd.conf file here.  Then we can see if it's apache that's getting it wrong or the contrib.
Smile :-)......

Pacjack

Getting to /webmail/ on another internal webserver via SME6
« Reply #3 on: March 01, 2006, 02:55:39 PM »
from httpd.conf:
Code: [Select]

Listen 0.0.0.0:80
# ProxyPass: /webm/
# Description: none
ProxyPass //webm/ http://192.168.1.161/webmail/
ProxyPassReverse //webm/ http://192.168.1.161/webmail/
<Location //webm/>
    order deny,allow
    deny from all
    allow from all
</Location>

Getting to /webmail/ on another internal webserver via SME6
« Reply #4 on: March 01, 2006, 03:34:39 PM »
The only thing that looks wrong to me is the double slash (//).  But I've had a quick play and that doesn't make a difference.

I would check that you are not doing something funny else where.

Any ideas anyone else?
Smile :-)......

Pacjack

Getting to /webmail/ on another internal webserver via SME6
« Reply #5 on: March 01, 2006, 03:47:34 PM »
Thanks genzil. Except for RayMitchell talking about possibly having to use server-gateway mode (wich seems unlikely to me), I can't think on anything else funny on my server.

I hope someone has another suggestion.

Offline mrjhb3

  • *
  • 1,188
    • John Bennett Services
Getting to /webmail/ on another internal webserver via SME6
« Reply #6 on: March 12, 2006, 06:05:42 AM »
Quote from: "Pacjack"
Thanks genzil. Except for RayMitchell talking about possibly having to use server-gateway mode (wich seems unlikely to me), I can't think on anything else funny on my server.

I hope someone has another suggestion.


You could try to put a redirect directive in httpd.conf

Redirect /webmail
http://yourserver.com/webmail

Here is a link for reference. http://httpd.apache.org/docs/1.3/mod/mod_alias.html#redirect

JB
......

boss_hog

Getting to /webmail/ on another internal webserver via SME6
« Reply #7 on: March 13, 2006, 05:33:14 AM »
Hey Pacjack,
what you have in the httpd.conf appears to match my testing.
One simple thing we often overlook is restarting apache.

Try running this command at the CLI:

# /etc/rc.d/rc7.d/S86httpd-e-smith restart

The ProxyPass contrib has worked as expected on my server.
Good luck
Joe

Getting to /webmail/ on another internal webserver via SME6
« Reply #8 on: March 17, 2006, 02:00:40 AM »
Hi,

I have only ever used 6.5 so not sure if this option will be available in 6.01 but thought Id suggest it anyway.

Can you set Webmail to use HTTPS in stead of HTTP?? If so then you could forward port 443 through to your mail server and do it that way.

I'm guessing someone must have thought of this already and the fact that nobody has posted it, probably means you can't do it, but worth trying.  :lol:

I'd be interested to know if it is possible.

Kit Norriss
...