Koozali.org formerly Contribs.org

[Announce] : release of smeserver-sme7admin-1.1.0

[Announce] : release of smeserver-sme7admin-1.1.0
« Reply #60 on: December 05, 2006, 10:30:40 AM »
after a reinstall of the server and sme7admin i get this:
Error at RRDs::graph(sessions.PNG) : Garbage ': ' after command: COMMENT:Max:

Number of opened tcp connections for ssh, ftp, vpn, afp and netbios protocols.

what went wrong?
all dependencies have been installed

Offline mmccarn

  • *
  • 2,518
[Announce] : release of smeserver-sme7admin-1.1.0
« Reply #61 on: December 08, 2006, 07:02:34 AM »
The latest version of RRDTool uses a different syntax than the one used by sme7admin and I think produces the errors you're seeing.

The "right" version for sme7admin:
# rpm -q rrdtool
rrdtool-1.0.50-1.2.el4.rf

The "wrong" version (at least until sme7admin is updated & re-released):
rrdtool-1.2.15-1.el4.rf.i386.rpm (I don't have it loaded anywhere so I can't show you the exact "rpm -q rrdtool" output...)

Here's the post I made when I ran into this problem with "sysstat": http://forums.contribs.org/index.php?topic=32803.0.  This thread also has info on how to solve the problem and where to get a "good" copy of rrdtool.

[Announce] : release of smeserver-sme7admin-1.1.0
« Reply #62 on: December 24, 2006, 09:22:25 PM »
Is there a way to change the VPN port that sme7admin monitors? I prefer to use openvpn, and would like to watch port 1194 instead
If you think you know whats going on, you obviously have no idea whats going on!

Offline Daniel B.

  • *
  • 1,694
    • Firewall Services, la sécurité des réseaux
[Announce] : release of smeserver-sme7admin-1.1.0
« Reply #63 on: December 26, 2006, 01:10:28 PM »
You need to edit the file /usr/bin/sme7admind ligne 982 :

if (/tcp\s+\d+\s+\d+\s\S+:1723\s+\S+\s+ESTABLISHED/)$sessions_vpn++;

Remplace 1723 with openvpn port number (1194 by default), then restart sme7admin  /etc/init.d/sme7admind restart
C'est la fin du monde !!! :lol:

[Announce] : release of smeserver-sme7admin-1.1.0
« Reply #64 on: December 26, 2006, 01:53:13 PM »
Thanks, I will give it a try


Bob
If you think you know whats going on, you obviously have no idea whats going on!

[Announce] : release of smeserver-sme7admin-1.1.0
« Reply #65 on: December 26, 2006, 02:59:49 PM »
That did not work, nothing for the vpn shows up in the graphs. It also seems to break displaying port 22 connection. When I do a "netstat -a -n" the openvpn connection does not show. I will just change it back.

Thanks

Bob
If you think you know whats going on, you obviously have no idea whats going on!