Koozali.org formerly Contribs.org

server-manager lockout!!

martinhick

server-manager lockout!!
« on: January 02, 2006, 09:43:09 PM »
I have recently installed two new computers. One was to replace my old server2000 (needed to run MS SQL) and the other a Suse Server.

I now cannot get into server manager following message

ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: http://192.168.42.5/server-manager

The following error was encountered:

    * Connection Failed

The system returned:

    (111) Connection refused

The remote host or network may be down. Please try the request again.

Your cache administrator is admin@kmcomputers.co.uk.
Generated Mon, 02 Jan 2006 20:37:01 GMT by smetestserver.kmcomputers.co.uk (squid/2.5.STABLE6)

I can use Putty to SSH and can administer via the setup or the text web service.

Does anyboy now why the connection is refused and what I may be able to do to fix the problem. I have tried from linux and windows clients. All get the same message

Desperatley

Martin

sebastian_sw

server-manager lockout!!
« Reply #1 on: January 02, 2006, 10:37:57 PM »
I had the same problems here,

Try:

# service httpd-admin restart

martinhick

server-manager lockout!!
« Reply #2 on: January 02, 2006, 11:38:04 PM »
Thanks sebastian,

Tried that no result. Also now rebooted but still the same.

Martin

Offline byte

  • *
  • 2,182
server-manager lockout!!
« Reply #3 on: January 03, 2006, 12:25:17 PM »
Which version SME you using and what does your /var/log/messages & apache logs tell you?

Have you installed any additional packages on your server?
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline irian

  • *
  • 184
server-manager lockout!!
« Reply #4 on: January 03, 2006, 01:05:16 PM »
Have you checked your local (wks) firewall config?

Irian

server-manager lockout!!
« Reply #5 on: January 03, 2006, 04:38:07 PM »
https://192.168.42.5/server-manager

server-manager lockout!!
« Reply #6 on: January 03, 2006, 04:41:29 PM »
Don't forget to say Oh yea.....!!

Offline byte

  • *
  • 2,182
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

martinhick

server-manager lockout!!
« Reply #8 on: January 03, 2006, 08:35:12 PM »
https://192.168.42.5/server-manager

Produces:-

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: 192.168.42.5:443

The following error was encountered:

Connection Failed
The system returned:

    (111) Connection refusedThe remote host or network may be down. P



https://192.168.42.5:980/server-manager

this produces :-

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: 192.168.42.5:980

The following error was encountered:

Access Denied.
Access control configuration prevents your request fro


all this used to work on a saved favorite.

MArtin

Offline byte

  • *
  • 2,182
server-manager lockout!!
« Reply #9 on: January 03, 2006, 08:46:16 PM »
Martin.

Have you had a look in the logs? any errors there?

maybe try disabling proxy and seeing if that solves it ?!

To disabled have a look here...

http://forums.contribs.org/index.php?topic=29469.0
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

dlw63

server-manager lockout!!
« Reply #10 on: January 03, 2006, 09:21:45 PM »
Just to concur with martinhick.  I am running 7.0 beta 8 and  this morning  I wasn't able to get into webmail or into server-manager. I also have a friend runing the same version and he is also having the same problem. What caused this and what is the soloution. It had been fine for the last 30 days. I frequently am in my system to monitor webmail and I know it was working on Friday Dec 30th 2005.

dlw63

server-manager lockout!!
« Reply #11 on: January 03, 2006, 11:23:27 PM »
Ok I found this in the Advanced Forums. This fixed mine and my friends problem. Telnet to the system and run it.

Posted By Robert


"signal-event post-upgrade", followed by "signal-event reboot" should solve the problem.

martinhick

server-manager lockout!!
« Reply #12 on: January 04, 2006, 09:02:09 PM »
Thanks Robert,

the lines

signal-event post-upgrade

signal-event reboot

in a ssh session as root fixed the problem.

Is this a bug with 7.0 beta 8. If so I wil report it.

Martin

server-manager lockout!!
« Reply #13 on: January 05, 2006, 04:53:55 PM »
I am running SME V7 Beta8 and I am also locked out of the server-manager and webmail.

I have just entered in those "signal-event" commands and am waiting for it to reboot... Fingers crossed.

Something in the "Automatic Update - software installation" must have installed and screwed things up.

I haven't seen anything about this in the bug tracker... has it been reported as a bug?
...

server-manager lockout!!
« Reply #14 on: January 05, 2006, 05:00:26 PM »
All Fixed :) with those commands
...

Robert

server-manager lockout!!
« Reply #15 on: January 06, 2006, 04:19:07 PM »
Quote from: "AaronG"
I am running SME V7 Beta8 and I am also locked out of the server-manager and webmail.

I have just entered in those "signal-event" commands and am waiting for it to reboot... Fingers crossed.

Something in the "Automatic Update - software installation" must have installed and screwed things up.

I haven't seen anything about this in the bug tracker... has it been reported as a bug?

I'm not sure if this counts as a real bug considering that upgrades between betas are not supported and that an upgrade is basically "yum update && signal-event post-upgrade && signal-event reboot" and that this symptom appears to be caused by running the command "yum update" alone (this gets run automatically).

server-manager lockout!!
« Reply #16 on: March 15, 2007, 04:27:40 AM »
These solutions didn't work for me. Submitted a bug tracker

martinhick

server-manager lockout!!
« Reply #17 on: May 19, 2007, 11:01:49 AM »
This has not fixed my problem
I have upgraded to the latest version but still no luck.
I am not running any programs that were not on the original release.

I am currently using an upgraded version starting at 7.0 rc1

Maybe I need to do a complete reinstall.  Unfortunatly without server manager I do not remember all my settings