Koozali.org formerly Contribs.org

printing to a print server via SME (601)

aaron

printing to a print server via SME (601)
« on: September 27, 2005, 07:22:39 PM »
We have a couple Hawking print servers for USB & parallel printers. I'm trying to get e-smith set up to be the prime printer server but am getting nowhere!

The existing printer setup on the workstation is initially set to use the Print Server software which creates custom port (this is what I want to get away from)

It is also working a-ok if set up on the workstation under TCP/IP printing with the address of 192.168.1.31, Protocol LPR, and LRP Queue Name of lp2. The Port Setting shows a dimmed 515.

I assume, perhaps incorrectly, that I should be able to set up a network printer defintion on e-smith that establishes the IP / port / queue combo. I've set up numerous combos of the address and this lp2 but no joy. Suggestions or pointers?

Once the SME printer is defined I assume I can create a new Workstation printer that is a Network Printer, browse to the SME machine (where the previously test printers do indeed show up) and then specify the correct printer driver when asked, is this valid?

This is on a SME 601 server - it has been running like a charm although in adding/deleting some of the printers I am finding some odd behaviour in the printer web config ( page never re-appears and printer is not being deleted from the accounts file.

Offline raem

  • *
  • 3,972
Re: printing to a print server via SME (601)
« Reply #1 on: September 29, 2005, 01:38:20 AM »
aaron

> I assume......I should be able to set up a network > printer defintion on e-smith that establishes the > IP / port / queue combo.

Read the manual, especially the bit about creating a hostname first !
http://mirror.contribs.org/smeserver/contribs/bobk/SME_Manual/chpt-13.4.html


> This is on a SME 601 server .....printer is not
> being deleted from the accounts file

I believe this was a bug & was fixed long ago, check the bug tracker.
...

Offline raem

  • *
  • 3,972
printing to a print server via SME (601)
« Reply #2 on: September 29, 2005, 02:07:04 AM »
Add hostname
Hostname - printerhostname
Visibility - Local
Location - Local
Local IP - print server IP eg 192.168.1.31 (not in use by anything else or reserved for DHCP use)


Add printer
Name - printsharename
Description - shared printer name & model & location
Location - remote
Remote address - printerhostname
Remote name - raw
...

aaron

printing to a print server via SME (601)
« Reply #3 on: October 03, 2005, 03:27:29 AM »
Thanks, Ray, for pointing me back to the good old manual (doh!). I had referneced it before I posted but overlooked the critical remark regarding being signed as a validated server user - I had been doing my testing as an Administrator on a Win2000 station. As soon as I logged out and back in as domain (e-smith) user BOOM, a-ok.

For the benefit of others, the original Port & Remote Name (non-raw) was correct to forward print requests (via e-smith) to printers behind this particular print server device.

Offline edform

  • *
  • 178
    • http://www.workgroupsolutions.co.uk
printing to a print server via SME (601)
« Reply #4 on: October 23, 2005, 11:05:56 PM »
Quote
This is on a SME 601 server - it has been running like a charm although in adding/deleting some of the printers I am finding some odd behaviour in the printer web config ( page never re-appears and printer is not being deleted from the accounts file.


This is a known bug in that version of the software. The solution is to update the printer configuration rpm with
e-smith-LPRng-1.11.0-05.noarch.rpm which you can find here...

http://mirror.contribs.org/smeserver/releases/6.0/os/e-smith/RPMS/

Ed Form