Koozali.org formerly Contribs.org

cron error

Offline zoran

cron error
« on: June 24, 2005, 03:06:47 PM »
I recently started getting this message after spamassasin OR ClamAV was updated.  I don't remember which one exactly, since they both recently updated themselves...

/etc/cron.daily/run_usa:

/usr/sbin/USA: [: too many arguments

 
How can I fix this?

Zoran

gardnc

cron error
« Reply #1 on: June 25, 2005, 10:33:28 PM »
On my 6.0.1 SME the script in /usr/sbin named USA does not require any parameters.  The /etc/cron.daily/run_usa entry does not send any parameters:

/etc/cron.daily/run_usa

#!/bin/bash
/usr/sbin/USA &

Does your USA script require arguments or does your cron tab include them in the text?

Offline Curly

  • ***
  • 114
cron error
« Reply #2 on: June 26, 2005, 12:20:22 AM »
I had the same error, even a manual update didn't help. After adding a 'set -x' to /usr/sbin/USA I noticed something in the log:

/var/log/USA.log

2005-06-25 21:12:36 perl-Mail-SpamAssassin-3.0.4-1 is still waiting to be installed manually.
2005-06-25 21:12:36 SpamAssassin is NOT up to date.

So I downloaded the rpm from swerts-knudsen's website, installed it (rpm -Uvh) and now everything works as expected.
.......................................

Offline brianr

  • *
  • 904
cron error
« Reply #3 on: June 26, 2005, 10:34:37 AM »
I am also getting this at all my systems, infact they are all still on 3.0.3 at this moment, and they fail to update every night.

I spent some time trying to debug the USA script, but haven't yet found the offender.  

If anyone else has some time, I am sure we'd all be grateful!
Brian j Read
(retired, for a second time, still got 3 installations though)
.........

Offline mrjhb3

  • *
  • 1,186
    • John Bennett Services
cron error
« Reply #4 on: June 26, 2005, 06:29:44 PM »
I had this as well.  This is what I did to fix it.
I downloaded these 3 files:
perl-Mail-SpamAssassin-3.0.4-1.i386.rpm  
spamassassin-3.0.4-1.i386.rpm  
spamassassin-tools-3.0.4-1.i386.rpm

from here:
http://mirror.contribs.org/smeserver/contribs/index.php?subdir=swerts-knudsen%2FSpamFilter&sortby=date

Then did a rpm -Uvh *.rpm and all seems to be good now.  Something is definitely going on with the downloads.  The last 2 times with clam and the last time with spamassassin when doing a rpm -Uvh I keep getting cpio errors.  This is on 2 different systems.  A manual download has always corrected this.

GL,

JB
......

Michiel

Re: cron error
« Reply #5 on: July 06, 2005, 02:27:20 AM »
Quote from: "zoran"
/usr/sbin/USA: [: too many arguments
How can I fix this?


This bug has been fixed in version 0.4. You should get this version automatically by 4am your time.

Please let me know if you still see this error message.

Michiel