Koozali.org formerly Contribs.org

Open-Xchange (SME7): progress, requests, testing

duncan

Open-Xchange (SME7): progress, requests, testing
« Reply #45 on: June 03, 2005, 10:59:33 AM »
Quote from: "guest22"
I agree, a contrib area is free of charge.. Simply apply for one at staff AT contribs.org...


Do we have access to our contrib areas again?

DarkMirage

Open-Xchange (SME7): progress, requests, testing
« Reply #46 on: June 03, 2005, 12:30:34 PM »
Wow, thats one really old script you're looking for  :-D .

I am at the point of (again) upgrading my newest development to the latest versions, and creating an updated install script. If nothing comes up, I should have it for you in 1 or 2 days.

It includes a better rpm-based installation, split from dependencies (meaning you may install and configure those yourself by ignoring the script).

I would be willing to place the rpm for OpenXchange, Java I'm not so sure about. Does anyone know where/how I can do that?

(edits)
Wait, it's right there..

Well, I have applied for a contrib area, and I am currently downloading the latest alpha. I noticed I was already up to date with Open-Xchange (v0.8.0-2) so that should save me some time.

Something which keeps on bugging me in the manager panel... Does anyone know what to trigger to have SME update the /home/e-smith/db/navigation/navigation.*?

Maybe I can find some db function at last moment..
If not, OpenXchange will remain below "Unknown"
Found it

Open-Xchange (SME7): progress, requests, testing
« Reply #47 on: June 03, 2005, 04:48:22 PM »
Quote from: "duncan"
Do we have access to our contrib areas again?

Mine works, but I have read that others are not working too, so you're not alone.  I'll put open-exchange/java rpms into my directory if anyone has them made.

Open-Xchange (SME7): progress, requests, testing
« Reply #48 on: June 03, 2005, 04:54:09 PM »
Quote from: "DarkMirage"
Does anyone know what to trigger to have SME update the /home/e-smith/db/navigation/navigation.*?

Code: [Select]
signal-event post-upgrade and
Code: [Select]
reboot (when done) will always work when you are unsure.  In the yum panel for SME7 those will be the actions that will be available to be run after installing an addon.

guest22

Open-Xchange (SME7): progress, requests, testing
« Reply #49 on: June 03, 2005, 08:54:20 PM »
I maintain 'mirror.contribs.org/smeserver/contribs/misc' which is the place for 'not yet have our own home or can not access our area'. So if you need a temp area, please let me know or even better send me your work, and I will put it up in 'mirror.contribs.org/smeserver/contribs/misc'. Ruffdogs is working on the FTP issue, Please let them know your _exact_ problem, it will help a great deal.

guest

DarkMirage

Open-Xchange (SME7): progress, requests, testing
« Reply #50 on: June 03, 2005, 11:00:01 PM »
@greg, when I said I need the navigation db to be updated, I meant it needs to be rebuild by reading the headers in /etc/e-smith/web/functions...
The post-upgrade did not when I tested it.

I'm adding it using DB::db now, seems to work, although I need to get deeper into the rpm spec file scripting... At this point you need to initialise at least ones before the panel shows up right, and it will not be removed (well, a lot won't, as I haven't worked out the uninstall procedure just yet).

@HF, that would be great, maybe you could pm me with an address to send the tarball containing all rpms and scripts? I expect to have the last bugs worked out in one or two days.

Open-Xchange (SME7): progress, requests, testing
« Reply #51 on: June 03, 2005, 11:20:05 PM »
Quote from: "DarkMirage"
@greg, when I said I need the navigation db to be updated, I meant it needs to be rebuild by reading the headers in /etc/e-smith/web/functions...
The post-upgrade did not when I tested it.

I'm adding it using DB::db now, seems to work, although I need to get deeper into the rpm spec file scripting...


Please join one of the developer mailing lists (devinfo, or the developer list at sourceforge) and ask your questions there. A good number of the people there who could help you don't hang out in the Forums. I'm sure they'd be interested to know what you are up to, and be happy to help.

Open-Xchange (SME7): progress, requests, testing
« Reply #52 on: June 03, 2005, 11:51:18 PM »
Quote from: "DarkMirage"
@greg, when I said I need the navigation db to be updated, I meant it needs to be rebuild by reading the headers in /etc/e-smith/web/functions...
The post-upgrade did not when I tested it.

Charlie's right - better to join the sourceforge mailing list at this point.  You've done an awesome job so far figuring things out - I think we have a good basis for making a smeserver-openxchange rpm now for the configuration.

I said post-upgrade AND reboot ;-)  Check again after the reboot.

DarkMirage

Open-Xchange (SME7): progress, requests, testing
« Reply #53 on: June 04, 2005, 12:16:23 AM »
Actually, the version I am currently working on has an array of new functions, and is rpm-based (I have managed to include all Open-Xchange specific configuring into the rpm and the events the service uses.)

All that is needed besides installing the e-smith-open-xchange##.rpm, as I have named it, is installing the dependencies and doing some very minimal configuring to get them to work with Open-Xchange.

I would like to say all is going well with the new install, however...I started using alpha 17, which really doesn't do much for the new server-manager panel (see the alpha dev thread).

I have subscribed to the mailing list, and will be watching it for a bit before asking. Still plenty I want to try myself ( I am trying to learn a bit from this.. ).

guest22

Open-Xchange (SME7): progress, requests, testing
« Reply #54 on: June 04, 2005, 09:19:34 AM »
@DarkMirage: Mail me at RequestedDeletion .a t. star-support.com

Open-Xchange (SME7): progress, requests, testing
« Reply #55 on: June 04, 2005, 03:14:43 PM »
The command you are probably looking for is:

/etc/e-smith/events/actions/navigation-conf

and ignore all the error messages.

 :-D
Kevin in WV 8-)......

DarkMirage

Open-Xchange (SME7): progress, requests, testing
« Reply #56 on: June 04, 2005, 04:23:25 PM »
Thanks for the posts but I actually figured out how to do this in the rpm (spec file):
Code: [Select]
%post
/sbin/e-smith/db \
/home/e-smith/db/navigation/navigation.en-us \
set OpenXchange service status uninitialised
%postun
/sbin/e-smith/db \
/home/e-smith/db/navigation/navigation.en-us \
delete OpenXchange


This is exactly what I wanted, so it's al good now (untill I start adding languages offcourse  :hammer: )

DarkMirage

Open-Xchange (SME7): progress, requests, testing
« Reply #57 on: June 04, 2005, 08:59:36 PM »
The Wiki has been updated, and includes a link to the complete installation package, no longer requiring any builds

I'll be writing some usefull documentation to add to the wiki, and following up on some changes i've been thinking of
(although it should be a while before I post any changes).

Please post/comment any problems you find during testing so I can have a look at those.

jazbokes

errors..
« Reply #58 on: June 05, 2005, 09:36:24 AM »
[root@dallas openxchange]# tar -zxPf SME7-Open-Xchange.tgz
[root@dallas openxchange]# ls
e-smith-open-xchange  SME7-Open-Xchange.tgz
[root@dallas openxchange]# ./e-smith-open-xchange
useradd: user ox exists
useradd: user tomcat4 exists
warning: /OX-tmp/ant-1.6.2-3jpp.noarch.rpm: V3 DSA signature: NOKEY, key ID c431416d
warning: /OX-tmp/fontconfig-2.2.1-13.i386.rpm: V3 DSA signature: NOKEY, key ID 025e513b
warning: /OX-tmp/perl-IO-Socket-SSL-0.94-0.dag.rhel3.noarch.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
########################################### [100%]
        package XFree86-libs-data-4.3.0-81.EL is already installed
        package fontconfig-2.2.1-13 is already installed
        package XFree86-libs-4.3.0-81.EL is already installed
        package XFree86-Mesa-libGL-4.3.0-81.EL is already installed
./e-smith-open-xchange: line 6: /etc/init.d/rhdb: No such file or directory
su: user postgres does not exist
ERROR: Cannot create output file //var/lib/pgsql/data/pg_hba.conf.5302 No such file or directory
 at /sbin/e-smith/expand-template line 45
ERROR: Cannot create output file //etc/tomcat5/tomcat5.conf.5303 No such file or directory
 at /sbin/e-smith/expand-template line 45
./e-smith-open-xchange: line 32: /etc/init.d/rhdb: No such file or directory
./e-smith-open-xchange: line 33: /etc/init.d/tomcat5: No such file or directory

guest22

Open-Xchange (SME7): progress, requests, testing
« Reply #59 on: June 05, 2005, 10:55:53 AM »
@jazbokes: Did you start that on a clean and fresh install, or did you already tried the 'old' script?