Koozali.org formerly Contribs.org

"kill" doesn't work (?)

ergozd

"kill" doesn't work (?)
« on: March 14, 2005, 08:29:53 PM »
Hi!

Running top gives
Code: [Select]
 8:24pm  up 35 days, 22:43,  1 user,  load average: 3.04, 3.08, 3.08
176 processes: 173 sleeping, 3 running, 0 zombie, 0 stopped
CPU0 states: 16.0% user, 83.0% system,  9.0% nice,  0.0% idle
CPU1 states: 22.0% user, 77.0% system, 19.0% nice,  0.0% idle
Mem:  1030720K av, 1019800K used,   10920K free,       0K shrd,   35100K buff
Swap:  261112K av,   97344K used,  163768K free                  821600K cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND
 8509 root      20   0   872   80    60 R    85.0  0.0 29944m vim
23034 root      18   0  1352  548   528 R    78.5  0.0  2618m vim
28813 root      18  10  6920 6724   592 D N  28.9  0.6 436:33 clamscan
17997 root      15   0  1080 1080   788 R     5.6  0.1   0:00 top
 4775 mysql     10   0 13616 3140  1236 S     0.9  0.3   2:07 mysqld
    1 root       8   0   472  444   412 S     0.0  0.0   1:05 init
    2 root       9   0     0    0     0 SW    0.0  0.0   0:24 keventd

I then try to kill 8509 and 23034 BUT they still are active...

Code: [Select]
[root@XXXX]# kill 8509
[root@XXXX# kill 23034
[root@XXXX]# ps -efa|grep vim
root      8509     1 98 Feb21 ?        20-19:06:30 vim lfck.conf
root     23034     1 89 Mar12 ?        1-19:40:46 vim services
root     18020 16895  0 20:25 pts/5    00:00:00 grep vim


So what do I do to kill these running processes?

Best rgds, Ergin

Offline Curly

  • ***
  • 114
"kill" doesn't work (?)
« Reply #1 on: March 14, 2005, 09:16:18 PM »
use an extra parameter with the kill command:

kill -9 <process-id>

That should do it
.......................................

Re: "kill" doesn't work (?)
« Reply #2 on: March 14, 2005, 10:16:27 PM »
Quote from: "ergozd"

So what do I do to kill these running processes?


Curly has the right solution. But you also want to avoid those runaway processes. Either make sure you log out of vim before disconnecting your remote session, or update all the vim packages - you've hit a bug in vim.

ergozd

"kill" doesn't work (?)
« Reply #3 on: March 14, 2005, 11:04:09 PM »
Thank you both for your help.

Curly, thanx for the extra flag. Checked in man pages, must have missed it. :-(

Charlie, I have "latest-updates" for rh73 of vim, probably will look around to find newer version.

Best rgds, Ergin

"kill" doesn't work (?)
« Reply #4 on: March 14, 2005, 11:53:44 PM »
Quote from: "ergozd"

Charlie, I have "latest-updates" for rh73 of vim, probably will look around to find newer version.


Google for "MichaelSoulier vim".