Koozali.org formerly Contribs.org

dansguardian and Ray's howto (need help)

Offline raem

  • *
  • 3,972
dansguardian and Ray's howto (need help)
« Reply #30 on: July 11, 2007, 06:01:18 PM »
The functionality discussed in this thread is built in to the current rpms released by dungog for sme7 & is configured with db commands.
See the new Howto
http://wiki.contribs.org/Dansguardian
...

Offline kevinb

  • *
  • 237
dansguardian and Ray's howto (need help)
« Reply #31 on: July 12, 2007, 07:40:00 AM »
Great Job Ray! Thanks,

I believe I found a typo:

Code: [Select]
Modifying Firewall and Proxy
[edit] Configuring your system to force Dansguardian usage & prevent bypassing
Dansguardian uses port 8080 for web proxy requests. If your browser does not use port 8080 then Dansguardian filtering will be bypassed. To force this usage & prevent users bypassing filtering you should do the following steps:

1) Configure your sme server to use Transparent Proxy port 8080 and to block direct access to the squid proxy port 3128 & redirect port 80 to port 8080

Note the functionality to create custom firewall rules using iptables is built in to the rpms provided by http://www.dungog.net

config setprop squid TransparentPort 8080
config setprop dansguardian portblocking yes
signal-event post-upgrade; signal-event-reboot
To return Transparent Proxy port to default value and to disable portblocking

config delprop squid TransparentPort 3128
config delprop dansguardian portblocking
signal-event post-upgrade; signal-event-reboot


I believe the last line should be:

Code: [Select]
signal-event post-upgrade; signal-event reboot


Note no dash before "reboot".

Also is:

Code: [Select]
To return Transparent Proxy port to default value and to disable portblocking

config delprop squid TransparentPort 3128
config delprop dansguardian portblocking
signal-event post-upgrade; signal-event-reboot


correct or should it be:

Code: [Select]
config setprop squid TransparentPort 3128



Kevin

Offline raem

  • *
  • 3,972
dansguardian and Ray's howto (need help)
« Reply #32 on: July 12, 2007, 12:35:28 PM »
kevinb

> I believe I found a typo:
> Note no dash before "reboot".

It wasn't there before, but slipped in during later editing. Fixed now.
...