Koozali.org formerly Contribs.org

[Announce] How to install/upgrade to Horde 3.0

[Announce] How to install/upgrade to Horde 3.0
« Reply #75 on: March 13, 2005, 09:53:09 PM »
I don't have cron configured yet.
I run only through command line
In the kronolith configuration the server name is "localhost" and email "reminders". I don't know what happens if set to the real server name and a real email.
Other issue. In my log searching for "fileinfo" I see this:
Mar 13 14:18:51 internetserver php: PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/fileinfo.so' - libmagic.so.1: cannot open shared object file: No such file or directory in Unknown on line 0

PicsOne

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #76 on: March 13, 2005, 11:31:57 PM »
It looks like to fix your libmagic.so.1 error, you need to install the file-4.12-3db_rh73.i386.rpm.  The php rpm's you install don't include that.  You can get that from Dan Brown's contribs directory, he originally put it together, or from my contribs directory.

JB
......

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #77 on: March 15, 2005, 05:33:12 AM »
Quote from: "PicsOne"
About kronolith reminders, I read your thread at horde list, and I tryed this and run ok. I use at command line:
/usr/bin/php /home/httpd/html/horde/kronolith/scripts/reminders.php

Run ok, and I get the reminders emails.

I use php 4.3.10 from Greg script
http://ergin.dyndns.org/download/php4.3.10-upgrade.sh
If you want to try, remove your current php version, and all extensions
Before execute, uncomment the lines for curl, mcrypt, mhash, domxml, xmlrpc

Then create a php custom template file named 70DynamicExtension71 and write this:
extension=domxml.so
extension=curl.so

Save, expand php, and restart httpd.
I use curl because moregroupware use it.
Of course, you can load other extensions if you need it.
Tell me if you can run reminders ok with this php version.
Another module use reminders is nag, but I not tested yet.
Other issue for kronolith is the free/busyURL.


OK, now that my head is out of my hind-end, I am ready to move a little further with this.  I have been able to get reminders working with the PHP rpm's in my contrib directory and with the PHP rpm's mentioned above.  I don't know much about the various PHP modules and what value they add, so whatever the majority wants, that is what I will use.  I also found a libmycrypt and libmhash rpm to use so you don't have to install with --nodeps, and all of the php modules in the php.ini file load fine when httpd is restarted.  I don't know who I downloaded those PHP rpm's from, but I can get them put on my contribs space.  The last piece to get working, IMO, is free/busy.  It looks like there are 2 ways to make this work.  One with an LDAP schema extension, and one using the mysql backend.  I don't know enough about LDAP, so I have chosen the latter.  

I have setup a default calender, set permissions, , set my default address book to use for free/busy lookups, added another user on the system to my personal address book.  Tried to add an event, then invite attendees, and get the error that no freebusyURL exists.  I have posted a quesiton on the Kronolith to see if anyone can shed some light on what else needs to be done.

JB
......

[Announce] How to install/upgrade to Horde 3.0
« Reply #78 on: March 15, 2005, 10:07:11 PM »
free/busy needs to have the free/busy url for your own name as well as the users you want to invite in the addressbook you select.  Then my error was from not setting allow_url_fopen = ON in php.ini.  After changing that it works.  My plan was to use mysql to create a shared addressbook for everyone, put in the free/busy url for all those addresses, and use it for free/busy look-ups.  Of course it would be nice if the free/busy url was filled in automatically.  (I already use multiple shared mysql addressbooks with the old horde version)

[Announce] How to install/upgrade to Horde 3.0
« Reply #79 on: March 15, 2005, 11:02:51 PM »
Better (for security) to edit or make a httpd.conf template adding something like this:

Code: [Select]
<Directory /home/httpd/html/horde>
     php_admin_flag allow_url_fopen on
</Directory>


I'm working on Horde 3 rpms for SME 7.  What I'm up to right now is figuring out what templates need to be made, and how best to break down each one.  I'll keep you all updated.

Greg

Offline wyron

  • *
  • 275
    • http://www.ideast.dk
[Announce] How to install/upgrade to Horde 3.0
« Reply #80 on: March 15, 2005, 11:25:58 PM »
Quote from: "hordeusr"
Then my error was from not setting allow_url_fopen = ON in php.ini.  After changing that it works.

I can't seem to find the template fragment where you set  the allow_url_fopen to on.
The fragment in templates/etc/php.ini only refers to a variable?
Greetings
wyron
...

[Announce] How to install/upgrade to Horde 3.0
« Reply #81 on: March 16, 2005, 02:02:39 AM »
I just got rid of the variable and set it directly.  Keep in mind this is a test server I'm working with.  Testing the feasibility of switching to the latest horde version via SME.  This is the better way to do it (in a httpd.conf template):
<Directory /home/httpd/html/horde>
     php_admin_flag allow_url_fopen on
</Directory>
FYI, this is also need for horde weather(which works very nice, my users will like it)
All we use is webmail (horde/imp/etc...) for email, so everything has to work perfect.  This is why I messed around with ingo/procmail so the vacation part will work for my users--I like the server side sorting into folders part of it.  IMP's PGP encryption stuff works nice.  I found a bug in nag that will be fixed in the next release.  Using phpa increased the speed greatly (had to up the size to 16 mb) and decreased server load.  Gollem(file manager) also works nice.  If someone wants to take a look at it, send me an email and I'll set you up with a temp userid/password.

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #82 on: March 16, 2005, 02:07:10 AM »
Quote from: "hordeusr"
free/busy needs to have the free/busy url for your own name as well as the users you want to invite in the addressbook you select.  Then my error was from not setting allow_url_fopen = ON in php.ini.  After changing that it works.  My plan was to use mysql to create a shared addressbook for everyone, put in the free/busy url for all those addresses, and use it for free/busy look-ups.  Of course it would be nice if the free/busy url was filled in automatically.  (I already use multiple shared mysql addressbooks with the old horde version)


hordeusr,

I have one thing to say.  "Hell yeah, you da man!!"  8-)
I was missing that allow_url_fopen = ON as well.  All is now working.  I don't know mysql that well.  How do you or have you created additional shared address books for your users?

Thanks again,

JB
......

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #83 on: March 16, 2005, 02:08:03 AM »
Quote from: "wyron"
Quote from: "hordeusr"
Then my error was from not setting allow_url_fopen = ON in php.ini.  After changing that it works.

I can't seem to find the template fragment where you set  the allow_url_fopen to on.
The fragment in templates/etc/php.ini only refers to a variable?


It's part of the config db, you can do this?

/sbin/e-smith/config setprop php AllowUrlFopen On
/sbin/e-smith/expand-template /etc/php.ini
/etc/e-smith/events/actions/restart-httpd-full

JB
......

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #84 on: March 16, 2005, 02:12:20 AM »
Quote from: "hordeusr"
I just got rid of the variable and set it directly.  Keep in mind this is a test server I'm working with.  Testing the feasibility of switching to the latest horde version via SME.  This is the better way to do it (in a httpd.conf template):
<Directory /home/httpd/html/horde>
     php_admin_flag allow_url_fopen on
</Directory>
FYI, this is also need for horde weather(which works very nice, my users will like it)
All we use is webmail (horde/imp/etc...) for email, so everything has to work perfect.  This is why I messed around with ingo/procmail so the vacation part will work for my users--I like the server side sorting into folders part of it.  IMP's PGP encryption stuff works nice.  I found a bug in nag that will be fixed in the next release.  Using phpa increased the speed greatly (had to up the size to 16 mb) and decreased server load.  Gollem(file manager) also works nice.  If someone wants to take a look at it, send me an email and I'll set you up with a temp userid/password.


You think it's better to set it in the httpd.conf file rather than setting the config db setting?  Got a howto for phpa?  I haven't tried Gollem, I'll be dropping you a line.

JB
......

[Announce] How to install/upgrade to Horde 3.0
« Reply #85 on: March 16, 2005, 02:48:59 AM »
Quote from: "mrjhb3"


You think it's better to set it in the httpd.conf file rather than setting the config db setting?  Got a howto for phpa?  I haven't tried Gollem, I'll be dropping you a line.

JB

Yes because then it's only set for the horde folder and not globally.  I don't have a howto, but the install instructions are pretty easy.  
Download the correct version of phpa
created a file: /etc/e-smith/templates-custom/etc/php.ini/70DynamicExtension76phpa
with this text:

zend_extension="/usr/lib/php4/php_accelerator_1.3.3r2.so"
phpa.shm_size = 16

put the php_accelerator_1.3.3r2.so file in that folder
put the phpa_cache_admin in the root folder
expand the php.ini template
restart httpd
login into horde
move through all the horde modules a few times to cache the php stuff.
after you have moved through the modules a few times everything should load quicker.
in the root folder run
./phpa_cache_admin -mv and see how much memory is being used to verify it's working.  I use it on our production server with excellent results.  It's most noticeable when I have lots of horde users using horde and the server just laughs (instead of slowing down).

Offline wyron

  • *
  • 275
    • http://www.ideast.dk
PHP notice:
« Reply #86 on: March 18, 2005, 12:20:05 PM »
I've discovered an error notice in my 'messages' log:
Several lines over the past few days state...
PHP notice: Undefined offset: 0 in /home/httpd/html/horde/imp/lib/IMP.php on line 585

That line is in the section to add the list of mailboxes to the lists, and it simply reads: if (is_null($filter[0]))

I don't get it - how can that be an undefined offset ??
Greetings
wyron
...

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
Re: PHP notice:
« Reply #87 on: March 18, 2005, 02:26:40 PM »
Quote from: "wyron"
I've discovered an error notice in my 'messages' log:
Several lines over the past few days state...
PHP notice: Undefined offset: 0 in /home/httpd/html/horde/imp/lib/IMP.php on line 585

That line is in the section to add the list of mailboxes to the lists, and it simply reads: if (is_null($filter[0]))

I don't get it - how can that be an undefined offset ??


That is a bug in Horde and will be fixed in their next stable release.  If you want to fix it now, you need to read the Horde archives and find the fix someone posted a while back..

JB
......

dswillia

[Announce] How to install/upgrade to Horde 3.0
« Reply #88 on: March 19, 2005, 02:06:37 AM »
ok so no errors on a fresh install of 6.5, but when using the server-manager I get the following error "The requested URL /horde/sme/index.html was not found on this server."  I have looked and sure enough there is no index.html... did I miss something?

Regards

Offline mrjhb3

  • *
  • 1,184
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #89 on: March 19, 2005, 03:07:22 AM »
Quote from: "dswillia"
ok so no errors on a fresh install of 6.5, but when using the server-manager I get the following error "The requested URL /horde/sme/index.html was not found on this server."  I have looked and sure enough there is no index.html... did I miss something?

Regards


No, you didn't miss anything, you just caught me in mid-change.  I take you are trying to click on the Horde Admin Setup?  I believe I had a typo.  I have just tested the install on a new server with an updated script and it seems to work fine for me.  I'll be uploading that shortly.  I can try to help you fix what you have now, or you can just reload the server after I have updated the script, etc.

To fix:

mkdir -p /home/httpd/html/horde/sme  [may already be there]

mkdir -p /etc/e-smith/templates-custom/home/httpd/html/horde/sme/index.html [may already be there]

wget -nc mirror.contribs.org/smeserver/contribs/jbennett/horde30/10sme.index.html

cp 10sme.index.html /etc/e-smith/templates-custom/home/httpd/html/horde/sme/index.html/

cp /etc/e-smith/templates-default/template-begin-html /etc/e-smith/templates-custom/home/httpd/html/horde/sme/index.html/template-begin

/sbin/e-smith/expand-template /home/httpd/html/horde/sme/index.html

HTH and sorry about that,

JB
......