Koozali.org formerly Contribs.org

[Announce] How to install/upgrade to Horde 3.0

Offline wellsi

  • *
  • 475
    • http://www.wellsi.com
[Announce] How to install/upgrade to Horde 3.0
« Reply #45 on: February 25, 2005, 06:39:58 PM »
Patching an existing RPM is not so difficult - I've even managed to do this :-) It's also in the doucmentation/development pages.

Making the TGZs into RPMs is not something that I have tried.

I can understand that Shad & Charlie want to keep in line with the fedora-legacy versions of the main apps. It makes sense from a distro point of view. This is something that we must live with.

So in the fedora7.3 lifetime this would remain a community add-on. Either as a script or RPMs.

The main push should be to get this in a good shape whilst the move to CentOS4 is underway.

In order to get this into any ISO the scripts/hacks need to be slowly removed leading to modifications to the e-smith-xxx RPMs. This work would largely be common for both RH7.3 & CentOS4 bases (I hope)

I certainly will help with this.
............

pldtm

[Announce] How to install/upgrade to Horde 3.0
« Reply #46 on: February 27, 2005, 03:03:00 PM »
a response for mrjhb3 from the 18 Feb 2005 23:24 ;

no problem with pear, no problem with php.ini and 50path...

fileinfo was written about 10 times in php.ini ( rewritten in several steps and at differents custom templates). i changes every custom templates in order to keep only one "extension=fileinfo.so"

but still the same white page.
I'm wondering if it isn't a typo error in a horde file as a ?> missing. I'll check this

thanks for your response and sorry for my late response


pldtm

Offline mrjhb3

  • *
  • 1,182
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #47 on: February 28, 2005, 05:31:39 AM »
Quote from: "pldtm"
a response for mrjhb3 from the 18 Feb 2005 23:24 ;

no problem with pear, no problem with php.ini and 50path...

fileinfo was written about 10 times in php.ini ( rewritten in several steps and at differents custom templates). i changes every custom templates in order to keep only one "extension=fileinfo.so"

but still the same white page.
I'm wondering if it isn't a typo error in a horde file as a ?> missing. I'll check this

thanks for your response and sorry for my late response


pldtm


Look in /var/log/messages and see/post what error you are getting when you try to go to http://yourserver/horde or http://yourserver/webmail.

I had problems this weekend downloading some of the pear modules and if I wasn't watching my install, it would error out and continue.  I then get the blank white page.  At a minimum, here are the pear modules and versions, you should see with a pear list


root@my65test root]# pear list
Installed packages:
===================
Package          Version State
Archive_Tar      1.2     stable
Cache            1.5.4   stable
Console_Getopt   1.2     stable
DB               1.6.8   stable
Date             1.4.3   stable
File             1.1.0   stable
Fileinfo         0.2     beta
HTTP             1.3.4   stable
HTTP_Request     1.2.4   stable
Log              1.8.7   stable
Mail             1.1.4   stable
Mail_Mime        1.2.1   stable
Net_DIME         0.3     beta
Net_SMTP         1.2.6   stable
Net_Socket       1.0.6   stable
Net_URL          1.0.14  stable
PEAR             1.3.5   stable
SOAP             0.8.1   beta
Services_Weather 1.3.1   stable
XML_Parser       1.2.5   stable
XML_RPC          1.2.0   stable
XML_Serializer   0.15.0  beta
XML_Util         1.1.1   stable

If you don't see the above versions, then that could be the issue.  

JB
......

[Announce] How to install/upgrade to Horde 3.0
« Reply #48 on: March 01, 2005, 05:14:58 AM »
A little questions

What happens with original rpms for horde and imp (2.x)?
What happens with template located at /etc/templates/home/httpd/html/horde?
What happens with post-upgrade/S65conf-kronolith, mnemo and nag?
And issue for Greg. Your eaccelerator with files run ok, but rpm version don't work with horde because in the inbox show me only the header of the email message, and not body. Ufff, very hard to discover this iisue. I have ins/uninstalled several times horde for this iisue  :hammer:
I have installed TREAN for horde and run ok (bookmarks) but only run previus version of HEAD, because the latest don't run with the latest stable horde version.
I have installed MIMP (webmail for mobile phones) and run prefect!!!!!!
Download the latest HEAD version, untar, all .dist without .dist, copy the imp servers.php template to custom-templates/home/httpd/html/horde/mimp/config/servers.php and expand
Configure in administration panel, and then activate in registry.php into horde config folder. If you want to see, set to active,, else set to hidden (better).
Follow this how to to set horde authentication to imp AND mimp.
http://wiki.horde.org/display.php?page=MIMPHowTo

The last question. I can't compile fileinfo, but in other machine. I can copy the file fileinfo.so and paste into /usr/lib/php4 to load in my server?
I use php4.3.10-3.eo script for greg

Offline mrjhb3

  • *
  • 1,182
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #49 on: March 01, 2005, 02:36:03 PM »
All answers pertain to the unofficial upgrade script.

Quote from: "PicsOne"
A little questions
What happens with original rpms for horde and imp (2.x)?


Nothing.  They are still installed.  If needed, you could roll back to Horde 2.x.  See horde20-restore.sh in /root/horde20-restore

Quote from: "PicsOne"

What happens with template located at /etc/templates/home/httpd/html/horde?
What happens with post-upgrade/S65conf-kronolith, mnemo and nag?

Currently nothing, they are left in tack.  The kronolith, mnemo, and nag files may cause some issues for others if webmail settings are changed.  I forgot about those files.  I'll have to re-load my test server and modify the script to remove those actions, then place them back in the horde20-restore.sh file.

Quote from: "PicsOne"

The last question. I can't compile fileinfo, but in other machine. I can copy the file fileinfo.so and paste into /usr/lib/php4 to load in my server?
I use php4.3.10-3.eo script for greg


I have been thinking about modifying the script to just copy this file in the correct place and trying to get rid of the devrpms needed.  I may look into doing this as well.
......

pldtm

[Announce] How to install/upgrade to Horde 3.0
« Reply #50 on: March 03, 2005, 02:54:54 PM »
hi


i did pear list and all is ok.

Could my white page be a permission problem?
because typo seems ok
in message there are no error

If there's no solution can i re install horde 2 from my cd?




pldtm

Offline mrjhb3

  • *
  • 1,182
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #51 on: March 03, 2005, 05:07:43 PM »
Quote from: "pldtm"
hi


i did pear list and all is ok.

Could my white page be a permission problem?
because typo seems ok
in message there are no error

If there's no solution can i re install horde 2 from my cd?

pldtm


I can't duplicate this issue.  Here are my thoughts.  Did you already have php-4.3.10 installed?  If so, remove that and install the php rpm's from the script, then expand the php.ini template, and restart httpd and try again.  I had some initial issues when using the earlier releases of Dan Brown's PHP rpm's.  I haven't tested the latest versions.

If you need to revert back, look in /root/horde20-restore.  There should be a file called horde20-restore.sh that you could run.  I'd also reccommend getting the most current one from my contribs directory.

That's all I got.  I have installed this many times on my two test boxes, which are different, and for 6.0.1 and 6.5 without the issue you have.  If you are getting a blank page, some log should be showing you something.  If not /var/log/messages, then var/log/httpd/acess something, I believe.  I'm not in front of my server to give you the correct path.

JB
......

[Announce] How to install/upgrade to Horde 3.0
« Reply #52 on: March 03, 2005, 09:34:09 PM »
Yes, i'd say try again and skip my "step 3" that installs php, and use johns step 4 that includes that.

Offline mrjhb3

  • *
  • 1,182
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #53 on: March 04, 2005, 06:14:43 AM »
Hello all,

I just updated the Horde 3.0 section of the upgrade script (Step 4).  I have removed all of the manual entry.  You should be able to install and let it go.
It's probably not the most elegant script, but hey, I'm not really a programmer.  I have tested this on 6.0 and 6.5RC1.  Give it a go on a test box and let me know your results.  One thing I would be interested in is if anyone has any issue with the fileinfo.so that gets copied to the system.  I wanted to try to eliminate the need for the devrpms.  If people have issues, then I'll get that added back in.

Thanks,
John H. Bennett III
SME 6.5RC1 Update Scripts
......

Offline mrjhb3

  • *
  • 1,182
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #54 on: March 04, 2005, 06:35:20 AM »
Quote from: "PicsOne"
I have installed MIMP (webmail for mobile phones) and run prefect!!!!!!
Download the latest HEAD version, untar, all .dist without .dist, copy the imp servers.php template to custom-templates/home/httpd/html/horde/mimp/config/servers.php and expand
Configure in administration panel, and then activate in registry.php into horde config folder. If you want to see, set to active,, else set to hidden (better).
Follow this how to to set horde authentication to imp AND mimp.
http://wiki.horde.org/display.php?page=MIMPHowTo


I tried following your instructions for MIMP, but I can't get this to work all the way? Whenever I change to use the composite driver, then add the info from the mimp howto, when I try to login, I get just a blank screen.  When I remove the composite and mimp additions, all is back to normal.  Then I can click on mobile mail and it will work from there. Just not when you try to go to the initial page either using /webmail /horde, or /horde/imp.  If you still have a copy of your horde/conf.php would you post it.  I'd like to compare it with the one I am using and see where I might be wrong at.

Thanks,

JB
......

Offline wyron

  • *
  • 275
    • http://www.ideast.dk
[Announce] How to install/upgrade to Horde 3.0
« Reply #55 on: March 04, 2005, 07:57:58 AM »
I just got a 6.5RC1 into production yesterday.
Ran your new script, jb, and Horde works like a charm !!!
By the way . . anyone know where I can get at the locale file?
The danish translation leaves some room for improvement - plenty of room, actually !
I'd be happy to return the result to the organization in charge of development as a token of my gratitude.
Greetings
wyron
...

[Announce] How to install/upgrade to Horde 3.0
« Reply #56 on: March 04, 2005, 02:41:35 PM »
Sorry for the long post
Mini Howto
Donwload latest MIMP HEAD version
Untart it
Copy contents to /horde/mimp
Into config folder:
for f in *.dist; do cp $f basename $f .dist; done
Change in horde config file registry.php mimp status to ACTIVE
Login into horde and go to Administration, Configuration and choose MIMP
Under Mail Server Settings set to False to display servers.
Under Composse settings check CC header and BCC header
Then Save COnfiguration
Code: [Select]

mkdir -p /etc/e-smith/templates-custom/home/httpd/html/horde/mimp/config
cp -r /etc/e-smith/templates/home/httpd/html/horde/imp/config/servers.php /etc/e-smith/templates-custom/home/httpd/html/horde/mimp/config
/sbin/e-smith/expand-template /home/httpd/html/horde/mimp/config/servers.php

Now, go to Mobile Mail in horde and click. You see in the rigth panel the login screen. Login with the same user name and password of the current mailbox you are using. Sen a message to the surrent email and if all are ok you receive the email the email. If you go to normal horde you see the same email in your inbox.
Well, all run ok. Logout from mimp.
To avoid the doubble authentication in the mobile phone, you need change authentication mode in horde congiruation
Go to horde configuration, authentication tab, and set  backend to "Composite authentication". Save your configuration file
Now, open your horde conf.php file and paste at the end following code:
Code: [Select]

$conf['auth']['params']['drivers'] = array(
    'imp' => array('driver' => 'application',
                   'params' => array('app' => 'imp')),
    'mimp' => array('driver' => 'application',
                    'params' => array('app' => 'mimp')));
$conf['auth']['params']['loginscreen_switch'] = _horde_select_loginscreen';

if (!function_exists('_horde_select_loginscreen')) {
    function _horde_select_loginscreen()
    {
        require_once 'Horde/Browser.php';
        $browser = &new Browser();
        if ($browser->isMobile()) {
            return 'mimp';
        }
        return 'imp';
    }
}

Go to horde registry.php file again and set mimp to hidden, because you don't need mimp into imp. When you logged via web you see IMP. but via cellular phone you see MIMP.

For JB, this is my conf.php file:


 
Code: [Select]

<?php
/* CONFIG START. DO NOT CHANGE ANYTHING IN OR AFTER THIS LINE. */
// $Horde&#58; horde/config/conf.xml,v 1.74.2.3 2005/02/03 16&#58;57&#58;42 jan Exp $
$conf['debug_level'&#93; = E_ALL;
$conf['max_exec_time'&#93; = 0;
$conf['use_ssl'&#93; = 2;
$conf['server'&#93;['name'&#93; = $_SERVER['SERVER_NAME'&#93;;
$conf['server'&#93;['port'&#93; = $_SERVER['SERVER_PORT'&#93;;
$conf['compress_pages'&#93; = true;
$conf['umask'&#93; = 077;
$conf['session'&#93;['name'&#93; = 'Horde';
$conf['session'&#93;['cache_limiter'&#93; = 'nocache';
$conf['session'&#93;['timeout'&#93; = 0;
$conf['cookie'&#93;['domain'&#93; = $_SERVER['SERVER_NAME'&#93;;
$conf['cookie'&#93;['path'&#93; = '/horde';
$conf['sql'&#93;['phptype'&#93; = 'mysql';
$conf['sql'&#93;['persistent'&#93; = false;
$conf['sql'&#93;['protocol'&#93; = 'unix';
$conf['sql'&#93;['hostspec'&#93; = 'localhost';
$conf['sql'&#93;['username'&#93; = 'horde';
$conf['sql'&#93;['password'&#93; = 'xxxxxxxx';
$conf['sql'&#93;['database'&#93; = 'horde';
$conf['sql'&#93;['charset'&#93; = 'iso-8859-1';
$conf['auth'&#93;['admins'&#93; = array&#40;'xxxxxx@printing.com.ar'&#41;;
$conf['auth'&#93;['checkip'&#93; = true;
$conf['auth'&#93;['driver'&#93; = 'composite';
$conf['signup'&#93;['allow'&#93; = false;
$conf['signup'&#93;['approve'&#93; = true;
$conf['signup'&#93;['preprocess'&#93; = false;
$conf['signup'&#93;['queue'&#93; = false;
$conf['log'&#93;['priority'&#93; = PEAR_LOG_NOTICE;
$conf['log'&#93;['ident'&#93; = 'HORDE';
$conf['log'&#93;['params'&#93; = array&#40;&#41;;
$conf['log'&#93;['name'&#93; = LOG_SYSLOG;
$conf['log'&#93;['type'&#93; = 'syslog';
$conf['log'&#93;['enabled'&#93; = true;
$conf['log_accesskeys'&#93; = false;
$conf['prefs'&#93;['params'&#93;['table'&#93; = 'horde_prefs';
$conf['prefs'&#93;['params'&#93;['driverconfig'&#93; = 'horde';
$conf['prefs'&#93;['driver'&#93; = 'sql';
$conf['datatree'&#93;['params'&#93;['table'&#93; = 'horde_datatree';
$conf['datatree'&#93;['params'&#93;['driverconfig'&#93; = 'horde';
$conf['datatree'&#93;['driver'&#93; = 'sql';
$conf['group'&#93;['driver'&#93; = 'datatree';
$conf['cache'&#93;['default_lifetime'&#93; = 1800;
$conf['cache'&#93;['params'&#93;['dir'&#93; = Horde&#58;&#58;getTempDir&#40;&#41;;
$conf['cache'&#93;['driver'&#93; = 'file';
$conf['token'&#93;['driver'&#93; = 'none';
$conf['mailer'&#93;['params'&#93;['sendmail_path'&#93; = '/usr/lib/sendmail';
$conf['mailer'&#93;['params'&#93;['sendmail_args'&#93; = '-oi';
$conf['mailer'&#93;['type'&#93; = 'sendmail';
$conf['vfs'&#93;['params'&#93;['vfsroot'&#93; = '/tmp';
$conf['vfs'&#93;['type'&#93; = 'file';
$conf['sessionhandler'&#93;['type'&#93; = 'none';
$conf['image'&#93;['convert'&#93; = '/usr/X11R6/bin';
$conf['problems'&#93;['email'&#93; = 'webmaster@example.com';
$conf['menu'&#93;['always'&#93; = false;
$conf['menu'&#93;['links'&#93;['help'&#93; = 'all';
$conf['menu'&#93;['links'&#93;['options'&#93; = 'authenticated';
$conf['menu'&#93;['links'&#93;['problem'&#93; = 'never';
$conf['menu'&#93;['links'&#93;['login'&#93; = 'all';
$conf['menu'&#93;['links'&#93;['logout'&#93; = 'authenticated';
$conf['hooks'&#93;['username'&#93; = false;
$conf['hooks'&#93;['preauthenticate'&#93; = false;
$conf['hooks'&#93;['postauthenticate'&#93; = false;
$conf['hooks'&#93;['authldap'&#93; = false;
$conf['kolab'&#93;['enabled'&#93; = false;
/* CONFIG END. DO NOT CHANGE ANYTHING IN OR BEFORE THIS LINE. */
$conf['auth'&#93;['params'&#93;['drivers'&#93; = array&#40;
    
'imp' => array&#40;'driver' => 'application',
                   
'params' => array&#40;'app' => 'imp'&#41;&#41;,
    
'mimp' => array&#40;'driver' => 'application',
                    
'params' => array&#40;'app' => 'mimp'&#41;&#41;&#41;;
$conf['auth'&#93;['params'&#93;['loginscreen_switch'&#93; = '_horde_select_loginscreen';

if &#40;!function_exists&#40;'_horde_select_loginscreen'&#41;&#41; &#123;
    
function _horde_select_loginscreen&#40;&#41;
    
&#123;
        
require_once 'Horde/Browser.php';
        
$browser = &new Browser&#40;&#41;;
        
if &#40;$browser->isMobile&#40;&#41;&#41; &#123;
            
return 'mimp';
        &
#125;
        
return 'imp';
    &
#125;
&#125;

[Announce] How to install/upgrade to Horde 3.0
« Reply #57 on: March 04, 2005, 03:41:16 PM »
The script works great.  One question though:
Does anyone have the correct rpms that will install wvhtml?
This message appears when I try to open a .doc attachment:
The program used to view this data type (/usr/bin/wvHtml) was not found on the system.

[Announce] How to install/upgrade to Horde 3.0
« Reply #58 on: March 04, 2005, 07:08:13 PM »
Long story shortened.  I'm working on configuring INGO to use procmail.  I have it somewhat set-up.  The rules part works (Ingo sets up the sorting via procmail on the server).  Using the change root contrib I had to change the ftp root to unrestricted...also had to change the permissions for that directory in proftpd.conf.  Changed the folder delimiter from . to ; in /lib/script/procmail.php.  Added this line to .procmailrc:
INCLUDERC=$HOME/.procmailrc.horde
Altered /config/backends.php to fit my needs.
Obviously a better way may exist.  
Anway, my problem right now is vacation.  This line for vacation in .procmailrc.horde doesn't work:
FILEDATE=ls -lcn --time-style=+%s 'vacation.username@mydomain.org' | awk '{ print $6 + (604800) }'

I get this error message in my procmail log:
ls: unrecognized option --time-style=+%s'


The whole vacation part is here:
:0
{
  FILEDATE=ls -lcn --time-style=+%s 'vacation.username@mydomain.org' | awk '{ print $6 + (604800) }'
  DATE=date +%s
  DUMMY=test $FILEDATE -le $DATE && rm 'vacation.username@mydomain.org'

  :0 Whc: vacation.lock
  * $^To:.*username@mydomain.org
  * !^X-Loop: username@mydomain.org
  * !^FROM_DAEMON
  | formail -rD 8192 vacation.username@mydomain.org
    :0 ehc
    | (formail -rI"Precedence: junk" \
       -A"X-Loop: username@mydomain.org" \
       -i"Subject: on vacation" ; \
       echo "because" \
      ) | $SENDMAIL -oi -t

}

Any idea what can be done to fix this?  IMHO, I think having Ingo use procmail and generate vacation messages would be nice.

Offline mrjhb3

  • *
  • 1,182
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #59 on: March 05, 2005, 08:01:07 PM »
Quote from: "PicsOne"
For JB, this is my conf.php file:


Thanks for posting this.  I was missing the last }.  I have this now working in the script, which I will post later on today.

JB
......