Koozali.org formerly Contribs.org

[Announce] How to install/upgrade to Horde 3.0

Offline mrjhb3

  • *
  • 1,179
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #150 on: March 05, 2006, 06:00:57 AM »
Quote from: "calisun"
That is why in my post I have provided a link to Gregs post where he explains how to install Kronolth.

If you know a link to rpm's and "how-to" page for Nag/Mnemo/Gollem/Mimp, I would greatly appreciate it.


I've just uploaded updated SME 7 RPM's for Kronolith, Nag, Mnemo, and Gollem to http://mirror.contribs.org/smeserver/contribs//jbennett/sme7/

Thanks goes to Greg Swallow for getting these started.

There were some older ones in these directories, so give the mirrors time to sync.

Here are some additional details you need to know to do.

Grant the horde user additional rights

From the console or ssh console

Code: [Select]


mysql

GRANT SELECT , INSERT , UPDATE , DELETE , CREATE ON horde . * TO 'horde'@'localhost';
flush privileges;

exit

Modify gollem default template
Code: [Select]

cd /etc/e-smith/templates/home/httpd/html/horde/config/registry.php
pico -w 620AppRegistryGollem

change gollem to active
change gollem-block inactive

Code: [Select]

signal-event post-upgrade ; signal-event reboot


For gollem to work
server-manager/remote access
ftp settings
   Allow access only from local networks
   Accept password only from local networks

gollem
 Defaults to users home dir, but users can click on root and see other users dir can't currently find a way to not allow access to root

kronolith reminders won't work because of php version included in SME7/CentOS 4.2.  It's the CGI version instead of the CLI version.

JB
......

Offline mrjhb3

  • *
  • 1,179
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #151 on: April 27, 2006, 05:54:14 PM »
Anyone that has used the horde script on their 6.x box, should probably run the lastest version to update to horde 3.0.10.  I say this because I subscribe to the horde list and people are reporting being hacked that are not running 3.0.10.

JB
......

Offline holck

  • ****
  • 271
Wvhtml
« Reply #152 on: May 23, 2006, 09:36:40 PM »
Quote from: "hordeusr"
The script works great.  One question though:
Does anyone have the correct rpms that will install wvhtml?
This message appears when I try to open a .doc attachment:
The program used to view this data type (/usr/bin/wvHtml) was not found on the system.

I found the rpm here. Installed nicely and seems to work.
Jesper
......

pbearne

[Announce] How to install/upgrade to Horde 3.0
« Reply #153 on: May 29, 2006, 08:13:19 PM »
Hi

Are you plan to write one of you magic SH scripts to auto this for us ??


Paul

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Problems with Permissions in Kronolith
« Reply #154 on: June 22, 2006, 12:12:30 AM »
I'm able to install all the rpms for the new horde stuff, on an SME RC3 server.  That works fine.  My problem is any calendar, notepad, or task list I create to share,  I am unable to give any permissions to it.  I select the calendar, the permissions button appears under it, but I never get to the permission popup window.  At one time earlier in the year I had this working on an SME server b3, b5 or b7, one of the earlier beta versions.   Any insights would be appreciated.

taxaw

link for those who plan to upgrade from sme6.0.1 to sme7
« Reply #155 on: May 06, 2007, 04:58:13 PM »
http://forums.contribs.org/index.php?topic=30680.0
I'm about to test this bug fix.
I'll come back later.