Koozali.org formerly Contribs.org

[Announce] How to install/upgrade to Horde 3.0

Offline mrjhb3

  • *
  • 1,183
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #135 on: November 30, 2005, 04:25:10 PM »
Ed,

Look at the notes in the install_horde30.sh and you will see that the new install no longer uses php-accelerator, but uses php-eaccelerator.  So running the old_install tried to install things that are no longer in the downloads area.  To fix this, look in /etc/e-smith/templates-custom/etc/php.ini and remove the lines for php-accelerator, expand /etc/php.ini, verify that the php-accelerator line is no longer present, then restart httpd-e-smith, and those messages should go away.

Also, I ran into an issue when I rebooted my server, where the old php-eaccelerator cache files wasn't rendering my mesages correctly.  Only showing the headers.

I have fixed this by adding the following to /etc/rc.local

rm -f /var/cache/php-eaccelerator/*

That way, when I reboot my server, the stale cache entries are removed.

You can also verify that you are running php-eaccelerator by running php -v via the console


PHP 4.3.10 (cli) (built: Mar  1 2005 08:30:27)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with eAccelerator v0.9.2, Copyright (c) 2004-2005 eAccelerator, by eAccelerator

Also, the pear lines seem to hang, because I send the output to /dev/null so you don't see it.  Everytime, you run the script, it tries to do a pear ua (upgrade-all currently installed pear modules), depending on the last time you ran it, it could take a while.  You can remove the /dev/null from the pear portion and see what it's doing at that time.

I'll update the script as time permits with the above change.

HTH,

JB
......

Offline edform

  • *
  • 178
    • http://www.workgroupsolutions.co.uk
[Announce] How to install/upgrade to Horde 3.0
« Reply #136 on: December 01, 2005, 01:25:46 AM »
Thanaks for all that JB. I've sorted it out

You said...
Quote

Also, the pear lines seem to hang, because I send the output to /dev/null so you don't see it. Everytime, you run the script, it tries to do a pear ua (upgrade-all currently installed pear modules), depending on the last time you ran it, it could take a while. You can remove the /dev/null from the pear portion and see what it's doing at that time.


But my situation wasn't like that. When I ran the old script the PHP download could be seen flashing away like crazy on my router, but with the normal script absolutely nothing happened; the system just sat and looked at me - no download ever took place.

Ed Form

Offline mrjhb3

  • *
  • 1,183
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #137 on: December 07, 2005, 05:53:58 AM »
Ed,

I think I know what you are talking about.  When the pear.php.net site is not available, then the pear portion just hangs until it times out.  At least that is what I experienced tonight.  Then the script continues, but when I try to open webmail, I get a blank page.  So, being dependent on that website being availabe is an issue. I'll have to think and see if I can find a way around that.  Suggestions welcomed.

JB
......

Kronolith reminder
« Reply #138 on: December 09, 2005, 09:44:10 AM »
Since I've installed Horde3 on my SME6.5RC1 and upgraded PHP to php4.4.1 (Ergin's script), every 5 minutes I get this message:

Cron <root@server> /usr/bin/php /home/httpd/html/horde/kronolith/scripts/reminders.php

eAccelerator requires Zend Engine API version 20021010.
The Zend Engine API version 20050606 which is installed, is newer.
Contact eAccelerator at http://eaccelerator.sourceforge.net for a later version of eAccelerator.


There seems to be nothing wrong (I think), It's just not practical to clean up your administrator emailbox every day.
Is there a way to stop this reminder, or if I'm wrong (I wouldn't be surprised) what is wrong with Kronolith and is it fixable?

Freek
...

Offline mrjhb3

  • *
  • 1,183
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #139 on: December 09, 2005, 02:30:08 PM »
Disclaimer -  With any PHP version greater than what the script installs by default, you are pretty much on your own.  The script installs 4.3.10, The warning states this.

You can check your pear modules with pear list.  This is what is on my server:
[root@myserver root]# pear list
Installed packages, channel pear.php.net:
=========================================
Package          Version  State
Archive_Tar      1.3.1    stable
Cache            1.5.5RC4 beta
Console_Getopt   1.2      stable
DB               1.7.6    stable
Date             1.4.6    stable
File             1.2.2    stable
HTTP             1.4.0    stable
HTTP_Request     1.3.0    stable
Log              1.9.2    stable
Mail             1.1.9    stable
Mail_Mime        1.3.1    stable
Net_SMTP         1.2.7    stable
Net_Socket       1.0.6    stable
Net_URL          1.0.14   stable
PEAR             1.4.5    stable
SOAP             0.9.1    beta
Services_Weather 1.3.2    stable
XML_Parser       1.2.7    stable
XML_RPC          1.4.4    stable
XML_Serializer   0.18.0   beta
XML_Util         1.1.1    stable


The reminders.php is for sending out Calendar reminders.  It is in /etc/crontab.  If you don't want that, then remove this file:  /etc/e-smith/templates-custom/etc/crontab/80HordeReminders

Then expand-template /etc/cron.d, then restart cron
/etc/e-smith/events/actions/restart-crond.

You should look in your logs and see what error is being given.  More than likely, it's because of a non-installed Pear module.  Others have used that version and have had install additional pear modules.  You should be able to search on horde php 4.4

GL,

JB
......

gknoll

install_horde30_sme7.sh
« Reply #140 on: January 24, 2006, 03:00:07 AM »
Hey all,

I just did a fresh intall of SME 7.opre1 and run yum update
All went well.
Now I want to upgrade to Horde 3.0, specificly I want Kronolith.
So I downloaded and ran the script install_horde30_sme7.sh
from http://mirror.contribs.org/smeserver/contribs//jbennett/

Ran the script and this is what I got:

Downloading files from http://mirror.contribs.org/smeserver/contribs/jbennett/horde30

Downloading and Installing user-manager

Preparing...                ########################################### [100%]
   1:perl-Unicode-String    ########################################### [ 50%]
   2:perl-Unicode-IMAPUtf7  ########################################### [100%]
Preparing...                ########################################### [100%]
   1:e-smith-userpanel      ########################################### [100%]
WARNING in /etc/e-smith/templates//etc/httpd/admin-conf/httpd.conf/90e-smithAcce                                ss30user: *WARNING* esmith::config(/home/e-smith/accounts) called with old datab                                ase path. The following package needs to be updated:  at /usr/lib/perl5/site_per                                l/esmith/config.pm line 374
        esmith::config::TIEHASH('esmith::config', '/home/e-smith/accounts') call                                ed at /etc/e-smith/templates//etc/httpd/admin-conf/httpd.conf/90e-smithAccess30u                                ser line 9
        eval 'E;

    foreach $file (@files)
    {
        next unless ( defined ($panelshash{$file}) );
        $OUT .= "\\n";
        $OUT .= "    <Files $file>\\n";
        $OUT .= "        AuthName \\"SME User manager\\"\\n";
        $OUT .= "        AuthType Basic\\n";
        $OUT .= "        AuthExternal pwauth\\n";
        $OUT .= "        require user admin$panelshash{$file}\\n";
        $OUT .= "    </Files>\\n";
    }

    $OUT .= "</Directory>\\n";
;' called at /usr/lib/perl5/vendor_perl/5.8.5/Text/Template.pm line 319
        Text::Template::fill_in('Text::Template=HASH(0x8476c78)', 'HASH', 'ARRAY                                (0x82da10c)', 'PACKAGE', 'esmith::__TEMPLATE__::1', 'BROKEN', 'CODE(0x845e468)',                                 'UNTAINT', 1, ...) called at /usr/lib/perl5/vendor_perl/5.8.5/Text/Template.pm                                 line 382
        Text::Template::fill_in_file('/etc/e-smith/templates//etc/httpd/admin-co                                nf/httpd.conf/90e-s...', 'HASH', 'ARRAY(0x82da10c)', 'PACKAGE', 'esmith::__TEMPL                                ATE__::1', 'BROKEN', 'CODE(0x845e468)', 'UNTAINT', 1, ...) called at /usr/lib/pe                                rl5/site_perl/esmith/templates.pm line 528
        esmith::templates::processTemplate('HASH(0x813df54)') called at /sbin/e-                                smith/expand-template line 45
WARNING: Template processing succeeded for //etc/httpd/admin-conf/httpd.conf: 1                                 fragment generated warnings
 at /sbin/e-smith/expand-template line 45
Restarting httpd-admin [  OK  ]
Restarting httpd-e-smith [  OK  ]


This installation only supports SME 7.0.x - Exiting...

I don't get it. Can anyone help?
Thanks
Greg

Offline mrjhb3

  • *
  • 1,183
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #141 on: January 24, 2006, 03:56:15 AM »
Greg,

That script for sme7 is very, very old and not tested for pre1.  There have been many changes to sme7, since I put that together.  I will remove that file so no one else runs into this issue.  Greg Swallow has been working on the horde rpms for 7.x.  He has done a great job of putting the packages together complete with templates.  If Greg happens to read this, maybe he won't mind me or him including the link to his WIP RPM's.

If you really still need to use Kronolith with sme7, then you should be able to pick out the items in the script that you need to use.  But, you will have to make sure you modify it to download the appropriate tar.gz files.

I have not touched or looked at this for a long time.

John Bennett
......

gknoll

install_horde30_sme7.sh
« Reply #142 on: January 24, 2006, 04:07:02 AM »
OK, well thank you for the reply. But now my webmail is completely broken.
Is there anyway to undo what was done?
I am not a newbi, but then I am not that experianced at coding.
Could you give me an idea as to what was changed and how I could change it back?
Any help would be great. If anything I'll just wipe it and start it over with a fresh install. No biggie, good learning experiance.
By the way nice family :-)

Regards

Greg

gknoll

install_horde30_sme7.sh
« Reply #143 on: January 24, 2006, 04:34:34 AM »
OK I got my web mail back
I un installed the one RPM that did work and my mail came back.
 :pint:  Miller time.
I'll work on the Kronolith

Thanks

[Announce] How to install/upgrade to Horde 3.0
« Reply #144 on: February 12, 2006, 05:56:43 AM »
G'Day all

I have an annoying issue with one both upgraded to H3.0

Every time I modify an email setting and the email-update routine runs it bombs H3.0 so that I get a blank page instead of the login page; the H3.0 restore fixes the prob.

Anyone got some suggetions of what/where to focus on to resolve this issue.

Couldn't find anything useful in the logs

BTW - system is a fully yum'd 6.0.1 with lots of contribs installed (I do have the exclusions in yum.conf for the webmail modules)

Cheers
..................

[Announce] How to install/upgrade to Horde 3.0
« Reply #145 on: February 13, 2006, 04:32:35 AM »
I would not recomment upgrading to Horde3 on SME 6 or 6.5.  If you ever decide to upgrade to SME7, it will give you upgrade problems.
If I were you, I would upgrade to 7pre2 it is 99% production ready and it comes with Horde3.

Many contribs will give problems, SME delopers do state to use contribs at your own risk. Before upgrading to SME7, run contribs removal script:

http://no.longer.valid/phpwiki/index.php/SME6.0.1Contribs-RemovalScript

Once you upgrade to SME7, just follow steps in attached link to install kronolith.

http://forums.contribs.org/index.php?topic=28690.0
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

[Announce] How to install/upgrade to Horde 3.0
« Reply #146 on: February 13, 2006, 04:42:26 AM »
This box is a fresh build of 6.0.1 and if I want SME7 on it it will be rebuilt from scratch - coming from the Windows world my philosophy is to always do a clean build instead of an upgrade.  The extra work upfront pays off in the long run with a more reliable and robust system.

Now about that prob .....
..................

Offline mrjhb3

  • *
  • 1,183
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #147 on: February 13, 2006, 08:43:14 PM »
Quote from: "calisun"
I would not recomment upgrading to Horde3 on SME 6 or 6.5.  If you ever decide to upgrade to SME7, it will give you upgrade problems.


I have opened bug 760 to deal with this and have uploaded a removal script.  Link to bug report, http://bugs.contribs.org/show_bug.cgi?id=760.  Link to other forum post, http://forums.contribs.org/index.php?topic=30680.msg128487#msg128487

Quote from: "calisun"
If I were you, I would upgrade to 7pre2 it is 99% production ready and it comes with Horde3.


Yes, it comes with Horde 3, but currently you get only horde/imp/turba/ingo.  There are WIP RPM's available from Greg Swallow for Kronolith/Nag/Mnemo/Gollem/Mimp

John Bennett
......

[Announce] How to install/upgrade to Horde 3.0
« Reply #148 on: February 17, 2006, 01:01:05 AM »
That is why in my post I have provided a link to Gregs post where he explains how to install Kronolth.

If you know a link to rpm's and "how-to" page for Nag/Mnemo/Gollem/Mimp, I would greatly appreciate it.
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline mrjhb3

  • *
  • 1,183
    • John Bennett Services
[Announce] How to install/upgrade to Horde 3.0
« Reply #149 on: February 17, 2006, 04:57:10 AM »
Quote from: "calisun"
That is why in my post I have provided a link to Gregs post where he explains how to install Kronolth.

If you know a link to rpm's and "how-to" page for Nag/Mnemo/Gollem/Mimp, I would greatly appreciate it.


I am working on those, building off of Greg's start.  It will take some time to learn the SME way.  Currently the RPM modules are built, but still need some work in the areas of automatically creating the SQL tables, probably some minor tweaks.  The smeserver-xxx specific modules that create the templates, need to be created.

JB
......