Koozali.org formerly Contribs.org

$80 USD via Paypal for Open-Xchange install

$80 USD via Paypal for Open-Xchange install
« Reply #90 on: November 16, 2005, 10:47:02 PM »
Hi,

  I just wanted to check in on this.  I've been doing some testing with SME 7.0 and the Open eXchange install just fine on SME7.0BETA5.  Here is how:

Code: [Select]

mkdir oxinstall;cd oxinstall

wget http://smeserver.free.fr/ox/ox7/apache-mod_jk-2.0-2.noarch.rpm
wget http://smeserver.free.fr/ox/ox7/openldap-2.2.13-2aci.i386.rpm
wget http://smeserver.free.fr/ox/ox7/openldap-clients-2.2.13-2aci.i386.rpm
wget http://smeserver.free.fr/ox/ox7/openldap-servers-2.2.13-2aci.i386.rpm
wget http://smeserver.free.fr/ox/ox7/perl-IO-Socket-SSL-0.96-4.noarch.rpm
wget http://smeserver.free.fr/ox/ox7/perl-Net-SSLeay-1.26-2.i386.rpm
wget http://smeserver.free.fr/ox/ox7/postgresql-7.4.8-1.RHEL4.1.i386.rpm
wget http://smeserver.free.fr/ox/ox7/postgresql-jdbc-7.4.8-1.RHEL4.1.i386.rpm
wget http://smeserver.free.fr/ox/ox7/postgresql-server-7.4.8-1.RHEL4.1.i386.rpm
wget http://smeserver.free.fr/ox/ox7/sme-j2sdk-1.4.2-2.i386.rpm
wget http://smeserver.free.fr/ox/ox7/sme7-openexchange-0.8.0.5-06.noarch.rpm
wget http://smeserver.free.fr/ox/ox7/sme7-openexchange-conf-0.8.0.5-06.noarch.rpm
wget http://smeserver.free.fr/ox/ox7/sme7-postgresql-7.4.8-1.noarch.rpm
wget http://smeserver.free.fr/ox/ox7/sme7-tomcat-5.0.28-15.noarch.rpm
rpm -iUvh --force *.rpm


NOTE BENE: I had to use the --force because of pecularities with a couple of the OpenLDAP rpms.

Okay... this will install every thing, but it will not initialize properly.  You need to do a:

/usr/local/open-xchange/bin/initall_ox

Even then... it's going to do a funny thing with the passwords.  You password will end up being your username.

FINAL NOTE: There is a connector that allows you to use M$ Outlook with Open eXchange.  But it is not GPL.  It is apparently priced at $25/user or thereabouts.
Jay Farschman
ICQ - 60448985
jay@hitechsavvy.com

ylon

$80 USD via Paypal for Open-Xchange install
« Reply #91 on: November 18, 2005, 08:19:15 PM »
Received a link to your success from:
http://smeserver.free.fr/punbb/viewtopic.php?pid=24#24

After going through your steps, jfarschman, on b6 (I see that b7 was just released today) I am getting an authentication error when using my username : username for logging into http://server-name/cgi-bin/login.pl.

Any thoughts on this?

$80 USD via Paypal for Open-Xchange install
« Reply #92 on: November 18, 2005, 09:30:25 PM »
Yes....

  I'll bet it changed your password to be the same as your username.  Try

username ylon
password ylon
Jay Farschman
ICQ - 60448985
jay@hitechsavvy.com

ylon

$80 USD via Paypal for Open-Xchange install
« Reply #93 on: November 19, 2005, 04:30:24 PM »
That's what I meant by "username : username"  I had entered the username as password as well without any luck.

Offline jester

  • *
  • 496
$80 USD via Paypal for Open-Xchange install
« Reply #94 on: November 21, 2005, 09:03:22 AM »
Ylon, try running: "/usr/local/open-xchange/bin/initall_ox" again

ylon

$80 USD via Paypal for Open-Xchange install
« Reply #95 on: November 21, 2005, 01:23:21 PM »
Thanks jester, yes, I'd already tried that...

Offline jester

  • *
  • 496
$80 USD via Paypal for Open-Xchange install
« Reply #96 on: November 21, 2005, 01:36:23 PM »
Have you got users under the Open-Xchange (ox)> User configuration?! Btw you can't login with the admin account!

jester.

ylon

$80 USD via Paypal for Open-Xchange install
« Reply #97 on: November 21, 2005, 04:40:04 PM »
Yes, I do have a user and no I am not using admin.  No dice.

ylon

$80 USD via Paypal for Open-Xchange install
« Reply #98 on: November 21, 2005, 09:12:33 PM »
Well, just tried updating to b7 to see what would happen, ran the install (I forced an install since I'd upgraded just to be sure that all of the pkgs installed) and it appears that the pre script fails from what I'm seeing here:

Setting right user and group. This can take a long time depending on the
used filesystem. Please be patient.
Setting user and group ...

Important: for the first time rebuild all the base and destroy the old ones init type ---------> initall_ox
 for recreate the ldap base only use ---------> /usr/local/open-xchange/sbin/scan_users.sh

for starting the server now wait 10sec and type: service openexchange start

Warning-Warning-Warning-Warning-Warning-Warning-Warning-Warning
You must use rpm -e sme7-openexchange-conf to delete this rpm.
and re-install it with rpm -ivh sme7-openexchange-conf-0.8.0.5-06.noarch.rpm

error: %pre(sme7-openexchange-conf-0.8.0.5-06.noarch) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping sme7-openexchange-conf-0.8.0.5-06



So I did remove it as it explains and tried installing that particular package with the same error:

#rpm -ivh sme7-openexchange-conf-0.8.0.5-06.noarch.rpm
Preparing...                ########################################### [100%]

Warning-Warning-Warning-Warning-Warning-Warning-Warning-Warning
You must use rpm -e sme7-openexchange-conf to delete this rpm.
and re-install it with rpm -ivh sme7-openexchange-conf-0.8.0.5-06.noarch.rpm

error: %pre(sme7-openexchange-conf-0.8.0.5-06.noarch) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping sme7-openexchange-conf-0.8.0.5-06

centreit

Install Warning
« Reply #99 on: January 10, 2006, 01:38:54 PM »
To fix the Warning about using rpm -e sme7-open-xchange-conf do the following:

mv /usr/lib/perl5/site_perl/esmith/util.pm.old /usr/lib/perl5/site_perl/esmith/util.pm

However I still have an issue after upgrading from 0.8.0.5-2. I can get to the login page but when I try and log in it just sits at the "Redirecting to" page. I have tried re-initialising my database (using initall_ox) to no avail.

Any hints?

Thanks,

Daniel Davis

ryan

$80 USD via Paypal for Open-Xchange install
« Reply #100 on: January 11, 2006, 03:52:04 AM »
I have used SME for years, but recently got Scalix community edition running on Centos4, authenticating against Fedora Directory Server.  I have FDS replicating to another site.  Samba schema and user info is stored in FDS.  Win XP Pro/Home use Pgina to login against FDS LDAP using SSL.  

Scalix community edition is not full open source, but it is free and allows 25 "enterprise" users which includes a MAPI connector for Outlook....Outlook functions as if it where talking to a Exchange server.  Scalix allows unlimited "community users" which have IMAP/POP3 for inbox, the web client has contacts and a personal calendar.  I have to say the Scalix web access application is very nice.  

I am now looking at the Chandler/Cosmo project for open source shared calendars.   It looks like I will be able to replace Active Directory and Exchange with soon....

Sorry if this posting is in the wrong place, but I have wanted the same functionality of OpenXchange on SME.....the open source Open Xchange is a challenge to say the least.  Nice job and collaboration on a common goal!

Ryan

What is the finail Count?
« Reply #101 on: March 28, 2006, 11:06:54 PM »
Sorry.
"No One Will Ever Need More Than 640K Ram"
                                                                              Bill Gates, 1981
......

What is the finail Count?
« Reply #102 on: March 28, 2006, 11:07:09 PM »
Quote from: "totodiaz"
Last count I had it was up to $500.00 dlls, plus $250.00 from jester.

As somebody said, this will make a Golden product.
I'm starting testing today.


I have installed a SME 6.5 BOX, it is my Samba+OpenLDAP+PDC+OpenExchange, the authentication center is LDAP. I'm review my howto to update it to this SME version, how many I can win for my work?, (little bit of hours becouse I'm working with LDAP from a long long time).

Henry G.

Read it in http://forums.contribs.org/index.php?topic=34388.0
"No One Will Ever Need More Than 640K Ram"
                                                                              Bill Gates, 1981
......

xionofchaos

Open Xchange SME 7.1
« Reply #103 on: May 24, 2006, 04:37:31 AM »
Thanks to everyone for contributing to this project, I have OX working on an SME 7.1 pre release.

I'm looking at getting rid of our exchange server all together though.  I've installed the oxtender rpm however I cannot get MSOutlook to connect to the SME as an exchange server.

sme7-open-xchange-oxtender-4.0.2-2.noarch.rpm

I must be missing something here because every time I try outlook tells me that a registry extension is missing.

Does anyone know where I can download the MSOutlook plugin to allow me to use outlook with Open Exchange?