Koozali.org formerly Contribs.org

Scalix on SME

ztasevski

Scalix on SME
« on: July 05, 2004, 10:46:10 AM »
Hi,

Anyone tried Scalix on SME ?

http://www.scalix.com

might just be the sought after MS Exchange alternative ?

steveb413

Scalix
« Reply #1 on: July 12, 2004, 12:35:47 AM »
trying to install now however it requires sendmail which is no problem but the install wizard looks for the file /etc/redhat-release I copied the file from a full standard rehat 7.3 install and it still dosent work "redhat-release is not owned by any package" anyone know of a work around for this?

Thanks,

Steve

ztasevski

Scalix on SME
« Reply #2 on: July 12, 2004, 07:12:09 AM »
hi steve

i think that you need to create a scalix username and group !

then try chmoding it and giving ownership and group permission to scalix for /etc/redhat-release?

ztasevski

Scalix on SME
« Reply #3 on: July 13, 2004, 07:07:56 AM »
any luck with it ?

steve413

that didnt work
« Reply #4 on: July 13, 2004, 05:01:59 PM »
Well that didn't work however I took the redht-release stock rpm and installed and that fixed the problem you have to install xwindows to use the scalix-wizard the install routine. now I have another problem when I uninstall qmail and install sendmail useing the e-smith-postfix contrib the dns portion of SME gets all screwed up any ideals on this one.

Thanks

Steve

Scalix on SME
« Reply #5 on: July 14, 2004, 12:17:13 AM »
If anyone has success with this, I'm sure many others would be interested!

G

steve413

Scalix on SME
« Reply #6 on: July 14, 2004, 01:06:01 AM »
I have installed the Scalix system on a stock Redhat 7.3 system and it is great I would sure like to figure out how to make it work with SME server.

silasp

Scalix on SME
« Reply #7 on: February 19, 2006, 02:18:31 PM »
There's a tip about getting scalix to work on centos here
http://www.scalix.com/community/viewtopic.php?t=516

It's a bit out of date. Version 10 seems to install most of the stuff in the above guide automatically.

I tried it with the community edition, version 10 on SME server 7rc3

(EDITED - The howto that works is below).

Offline Franco

  • *
  • 1,170
    • http://contribs.org
Scalix on SME
« Reply #8 on: February 19, 2006, 07:26:43 PM »
Another tip from the same forum suggests the use of Java 1.4 and not 1.5, what version do you have it running?

These are the requirements to have it running on CentOS, and some report success.

arjanvl

Scalix on SME
« Reply #9 on: February 20, 2006, 08:24:53 AM »
Silasp,

Have you tried:
http://[localhost.domain.com]:8080/sac

Jakarta Tomcat needs to be running for scalix. You need to manually start up tomcat from your tomcat directory \*tomcatdir*\bin\startup.sh.
Scalix webaccess (http://[localhost.domain.com]:8080/webmail) and the Scalix Administration Console (SAC) both need tomcat to run.

Cheers,

Arjan

silasp

Scalix 10 on SME 7rc3 - works (ish)
« Reply #10 on: February 24, 2006, 12:37:08 AM »
[updated 28-Mar-06] Fixed some problems
[updated 29-Mar-06] Stopped some extra services, can now send / receive
[updated 30-Mar-06] Configure sendmail

Thanks for the suggestions, guys.
I finally got it working. But it seems to have broken some of the SME stuff:
This how-to is NOT RECOMMENDED on anything other than a test server. It can send and receive email, but does not integrate properly into the SME ldap (yet).

==== BEGIN HOWTO ====

# Using scalix 10 and SME server 7 pre-release 3 (other versions will
# probably work)

pico -w /etc/yum.conf

# change the relevant sections as shown

[addons], [base] and [centosplus]
enabled=1
gpgcheck=0
enablegroups=1

# remove qmail. (in a nasty way)
rpm -e qmail --nodeps

# Yum some required dependencies
yum install sendmail tcl tk compat-libstdc++-296 compat-libstdc++-33 cyrus-sasl-plain

# Get the scalix installer
http://www.scalix.com/communityedition/index.html
# Scroll to the bottom, pick the Redhat Enterprise 3 or 4 version, enter
# your email address, and agree to the licence.

# Download and unpack the scalix tar.gz file
wget [link], tar -xzvf *.gz

# Change release version to fool scalix. (otherwise won't install)
cp /etc/redhat-release /etc/redhat-release.orig
pico /etc/redhat-release
# (Replace with "Red Hat Enterprise Linux ES release 4 (Nahant)" without
# quotes.)

# "Remember" changes to /etc/redhat-release on restart
cp -f /etc/redhat-release /etc/motd

# Stop SME conflicting services and also disable on startup.
cd /etc/init.d/

./imap svdisable
./pop3 svdisable
service ldap svdisable
./qpsmtpd svdisable
./smtp-auth-proxy svdisable
./sqpsmtpd svdisable

# NOTE: This may not actually disable the services.
# The SME developers might know...

# Change ldap port - service is stopped anyway, you can skip this
# pico /etc/e-smith/db/configuration/defaults/ldap/TCPPort
# change from 389 to 390

# Configure Tomcat:
# go to your scalix install directory and
./scalix-installer
# Accept the default settings, (except for warning, pick install anyway)

# Add scalix commands to shell path
PATH=/opt/scalix/bin:$PATH

# Run again to configure tomcat:
./scalix-installer

# Select option 3 - reconfigure
# Components > 1,2,3
# Accept defaults, but answer "no" to
#Do you want to integrate Tomcat with Apache using Scalix JK connector?
# and "yes" to "Are you sure you want to remove it (the JK connector)"
# Accept the other defaults.

# Make scalix startup automatically on restart
ln -s /etc/init.d/scalix /etc/rc.d/rc7.d/S82scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc7.d/S82scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc7.d/S56sendmail

ln -s /etc/init.d/scalix /etc/rc.d/rc6.d/K03scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc6.d/K03scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc6.d/K03sendmail

# Configure tcpwrappers to work with sendmail:
mkdir -p /etc/e-smith/templates-custom/etc/hosts.allow
pico /etc/e-smith/templates/etc/hosts.allow/sendmail
Code: [Select]

sendmail: 127.0.0.1


expand-template /etc/hosts.allow


# Then go to administration console:
http://your.webserver.com:8080/sac

# set up your users. then logon to webmail:
http://your.webserver.com:8080/webmail

=== Post installation tasks (optional) ===
All of this info was lifted from the Scalix Knowledgebase
http://portal.knowledgebase.net/display/1/index.asp?c=4664

# * Get SSL working with scalix

cd /usr/java/jre1.5.0_04/bin
./keytool -genkey -alias tomcat -keyalg RSA

# (Enter the information required. Make a note of your keystore
# password - eg "newpassword")

pico -w /opt/scalix-tomcat/conf/server.xml

# Scroll down and uncomment the ssl section, also add
# keystorePass="newpassword"(as shown below)
Code: [Select]

<!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->

<Connector port="8443" MaxThreads="150" minSpareThreads="25" maxSpareThreads="75" enableLookups="false" disableUploadTimeout="true" acceptCount="100" debug="1" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" keystorePass="newpassword" />

<!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 -->


service scalix-tomcat restart

# Now you can access sac and webmail over SSL as follows:
# Administration console:
https://your.webserver.com:8443/sac

# Webmail:
https://your.webserver.com:8443/webmail


# Integrate clamav
pico -w /etc/group

# add clamav to the end of the scalix line so it reads something like:
scalix:x:454:clamav

cd /var/opt/scalix/rules

pico -w ALL-ROUTES.VIR
Code: [Select]

VIRUS-UNCLEANED=1 ACTION=REJECT NDN-INFO=!ndninfo.txt
VIRUS-UNCLEANED=0 VIRUS-FOUND=1 ACTION=ALLOW NOTIFY="A virus was found in your message. It was successfully cleaned and sent to the recipient. However we highly recommend that you install or update your virus protection software and scan your computer for viruses."


pico ndninfo.txt
Code: [Select]

A virus was found in your message. The virus could not be cleaned and thus the message was not sent to the recipient.  We highly recommend that you install or update your virus protection software and scan your computer for viruses.


cp /opt/scalix/examples/general/omvscan.map /var/opt/scalix/rules
chown root omvscan.map
chmod 555 omvscan.map

# Restart clam
service clamd restart

#(clamav appears to work. Have tested by sending the clam.exe test file
# from the clamav tarball and got the "your message contains a virus"
# message. Need to test sending an infected msg TO the scalix server)


# * Integrate Spam Assassin
# Install some things:
yum install sendmail-devel

mkdir /root/rpm
cd /root/rpm
wget http://dag.wieers.com/packages/spamass-milter/spamass-milter-0.3.0-1.2.el4.rf.i386.rpm

(if it's not there try googling for spamass-milter.rpm - you want the redhat 4 version)

rpm -Uvh *.rpm

cd /var/opt/scalix/sys/
cp smtpd.cfg smtpd.cfg.orig
pico -w smtpd.cfg

Scroll to the bottom, add this line ...
SMTPFILTER=TRUE
... above the line: RELAY accept 127.0.0.1

cp /etc/mail/sendmail.cf /etc/mail/sendmail.cf.orig
pico -w /etc/mail/sendmail.cf
Change selected lines to the following:

O OperatorChars=.:%@!^/[]+
(delete the last =)

O InputMailFilters=Spamassassin
(delete #, append =Spamassassin)
then below O InputMailFilters=Spamassassin, add the following lines
Code: [Select]

# Milter options
#O Milter.LogLevel
O Milter.macros.connect=b, j, _, {daemon_name}, {if_name}, {if_addr}
O Milter.macros.helo={tls_version}, {cipher}, {cipher_bits}, {cert_subject}, {cert_issuer}
O Milter.macros.envfrom=i, {auth_type}, {auth_authen}, {auth_ssf}, {auth_author}, {mail_mailer}, {mail_host}, {mail_addr}
O Milter.macros.envrcpt={rcpt_mailer}, {rcpt_host}, {rcpt_addr}


In the section MAIL FILTER DEFINITIONS, add the following line:
Code: [Select]
Xspamassassin, S=local:/var/run/spamass.sock, F=, T=C:15m;S:4m;R:4m;E:10m

chkconfig --add spamass-milter
chkconfig --level 345 spamass-milter on

ln -s /etc/rc.d/init.d/spamass-milter /etc/rc.d/rc7.d/S91spamass-milter
ln -s /etc/rc.d/init.d/spamass-milter /etc/rc.d/rc6.d/K04spamass-milter

# Turn spam filtering on in the server manager
http://your-server.com/server-manager
# Email > Change email filtering settings
# Enable spam filtering, alter other settings as you see fit,
# scroll down, click save

cd /etc/rc.d/init.d/

./sendmail restart
./spamass-milter restart

# Check spamd is running
netstat -lnp | grep spamd
# If you don't get a line like "tcp 0 0 127.0.0.1:783..."
# then run the following command
/usr/bin/spamd -d
 
omoff -d 0 smtpd
omon smtpd

(That seems to work. Log files look ok. )

=== end post installation tasks ===


==== END HOWTO =====

[UPDATE] I added some extra services to the "stop services" list, following the suggestions made by other posts in this forum (see below). Send / receive works from webmail and Outlook connector on local accounts. I haven't tested anything else.

I can log into Horde using the scalix admin details. This means it might be possible to point other SME services to the scalix LDAP and get a working system  

However, at the moment, several SME services are broken.

[UPDATE] Scalix now reloads on restart. Hooray! However, I will leave the old "fix" instructions as a reference.

========================
To reinstall scalix, keeping existing mailboxes:

(Just in case SME ldap started, somehow)
service ldap stop

./scalix-installer
Option 4 (uninstall)
Remove everything but the mailbox store.

./scalix-installer
Accept defaults, use existing mailbox store

./scalix-installer
Select option 3 - reconfigure
Components > 1,2,3
Accept defaults, but answer "no" to
Do you want to integrate Tomcat with Apache using Scalix JK connector?
and "yes" to "Are you sure you want to remove it (the JK connector)"
Accept the other defaults.

It will then come back up again with all your users and emails intact
==========================

Anyone got any ideas about any of this?

[UPDATE] It has been suggested that having both LDAP servers running at the same time is the way to go. I think we would be better trying to get the SME server services to use the scalix ldap, after scalix has been installed.

Cheers,
Silas.

strombergtec

SeLinux
« Reply #11 on: February 25, 2006, 12:54:26 AM »
Is selinux enabled on your system?  That fixed my problem on FC4, I then enabled the jk connector and was able to get to my stuff without the :8080

Somthing to try...

strombergtec

LDAP problems
« Reply #12 on: February 25, 2006, 04:24:17 AM »
Another thing is that scalix runs its on ldap server on port 389, which seems to break it if you try and change the port.  This is probably why you could log in with sxadmin crendentials to horde, it killed the sme ldap.

You might be able to get it to work by assigning another ip to the eth interface and only allow either ldap server to listen on one ip.  Just an idea, i am not sure that would work...

I have made scalix on another machine authenticate to the sme ldap server, which somewhat defeats the purpose.

This task seems very interesting as a contrib because any of the opensource groupware seems overcomplicated compared to scalix!

silasp

LDAP problems
« Reply #13 on: February 26, 2006, 01:10:07 AM »
Thanks strombergtec! LDAP clash sounds like the issue.

Ok, so to get scalix to work with sme, one would have to either:
[1] Have both scalix and SME LDAP servers running simeltaneously
[2] Have scalix LDAP server, and get SME components to talk to it
[3] Have SME LDAP server, and get Scalix components to talk to it

And you say you have gotten [3] working. Can you post a howto?
It seems like a good strategy as you would not have to import your existing SME users into the (new) Scalix LDAP.

Cheers,
Silas.

strombergtec

How i got scalix running
« Reply #14 on: February 26, 2006, 03:47:13 PM »
I had 2 seperate hardware boxes running,  that was the only way i could make it work.  

To have scalix auth to the sme box the scalix ldap must still be running.

You can see what scalix processes are running with "omstat -a" you will see ldap in that list.

The only way seems to be if we could make the 2 ldap's coexist on the same machine, without changing from port 389.

psypher

So has anyone cracked this one yet?
« Reply #15 on: March 27, 2006, 03:48:20 PM »
I am very keen to try to get this to work. I am busy d/l the new scalix 10 and sme 7rc1. i have had some experience with scalix plus i have friends and employers who are partnered with scalix and can hopefully give some insight and advice, they have also been on training done by scalix. scalix on sme would be awesome. Sure you need x to install which is pretty annoying but you can do it with command line but complicated. prob easier to just install x, install scalix and uninstall x again. once it's installed it's all web gui and cli from there.

these damn d/l's are taking forever.

i am not too familiar with ldap configuration. but is it possible to have both the ldap's running on the same server but making sme work on another port. have i got that right, the main prob is that they use the same port and getting confused?

but i think the best would be for sme to read scalix's ldap as sme would be more open and easier to config. as i understand it, scalix is semi oss. most of the core systems and web mail is closed. figured this out when my company wanted to change the default font in the webmail.

i have the next 4 days to work on this, so hopefully somebody has some ideas. i'll also have an update once i have gotten everything installed and maybe some ideas from my friends

strombergtec

scalix on sme
« Reply #16 on: March 27, 2006, 04:18:53 PM »
I agree that getting this to work with sme would be big for both sme and scalix.  For me the showstopper is that the scalix ldap server port number seems to be hardcoded into scalix.  If you try to change it, it will break!

If there is another way to go about this i would definately help if i can!

Maybe for us groupware hungry individuals we should find one that works and focus on it.  I like opengroupware because it is almost stable and could easily be rolled up for sme.  Though if scalix worked I would love that!

psypher

Progress So far
« Reply #17 on: March 28, 2006, 06:57:20 PM »
I got mail between webmail accounts to work. Figured out that scalix smtp could not start properly as sme smtp was still on. stopped:
qpsmtpd
smtp-auth-proxy
sqpsmtpd

and had no more errors (methodname=send) when trying to send a webmail and all mail worked great.

But the ldap problem is still there. When I install scalix according to the howto everything works fine, but once I reboot i cannot log into sxadmin or webmail. keep getting incorrect username problems. even if I don't let sme ldap server start on boot. also removed that from the rc7.d dir.

does anyone know where scalix stores it's ldap conf file, might be a clue to how it starts. as far as I can tell you should be able to run scalix ldap from anywhere on any port. where did somebody on this post change the scalix ldap port?

gonna try changing sme ldap port and see what happens. just annoying cos the only way so far to get scalix working again is to re-install scalix. but at reboot all is broken again

strombergtec

Scalix on SME
« Reply #18 on: March 28, 2006, 07:37:03 PM »
Are you sure the scalix ldap is running (check with "omstat")?  I had tried to change the scalix ldap port but it would not start, you will have to change the sme ldap port...  Not sure what that will break? Might want to ask one of the dev's.  

Did you use the j2re package provided with scalix?  I had a problem with that of FC4?

Could any of your partner friends talk scalix into helping us out?  I could definately see a benefit for them making a scalix install package for sme!  As most offices want more that just email and don't want multiple servers.

psypher

Scalix on SME
« Reply #19 on: March 28, 2006, 09:07:41 PM »
my friend was a bit busy today, couldn't really give me any real answers. not so sure they would be able to get real snwers out of scalix either. there would hev to be some money in it for them i think, so if a client specifically askes for it. i know when we started migrating our exchange to scalix and insisted on centos our partner said scalix doesn't really support it but they will. and so since we bought 200 licenses from them they made it work. but centos is easy, this isn't.

 how did you change that scalix ldap port? i am a bit lost here, I know linux but a lot of this stuff I have never had to deal with. ldap is very new to me. IS it possible to run 2 ldap servers from the same server? can some of the dev's let us know that if we change sme's ldap port things will break.

i am starting a new post on scalix's forum with what we have done so far, maybe somebody there will pick it up and help us out. if we lucky maybe even florian, the guy who trained my friends.

psypher

Scalix on SME
« Reply #20 on: March 28, 2006, 10:11:15 PM »
OK so i tried changing the scalix ldap. changed it in  
/var/opt/scalix/sys/slapd.conf
and /etc/opt/scalix/webmail/swa.properties
restarted ldap with omoff and omon
when  i try to log in with webmail, firefox keeps telling me that a pop-up is being blocked even though blocking is off. couldn't get any further. btw when i did a netstat i could see both sme ldap on port 389 and scalix ldap on 390
changed it all back and it worked again

then i changed ldap port in /etc/openldap/ldap.conf to 390 and started /etc/rc.d/init.d/ldap and here i am dumbfounded. even though the conf file says 390 ldap keeps starting up on 389 according to netstat. why does it do this, i even changed the e-smith template so that it doesn't overwrite the setting. i tried a reboot and still running on 389, am I missing something?
course reboot now killed scalix again so I have to reinstall.

going to bed now, if anybody has any ideas i would really love to hear them

silasp

scalix
« Reply #21 on: March 29, 2006, 09:21:19 AM »
Thanks for your help. I have incorporated your suggestions into the howto.
We're pretty close. Scalix webmail works and even though restarting still breaks scalix, it can be fixed without losing mailboxes.

I need help from a (SME and or scalix) god to do the following:

[1] Sort out the LDAP issues.
I suspect that getting the SME services to use the scalix LDAP will be the best approach. I say that because Horde appears to automatically use the scalix LDAP, so it might be easy to get the other services to do so.

[2] Integrate ClamAV / Spamassasin with scalix.
[UPDATE] I think I've done this, after reading through the scalix knowledgebase. I've updated the howto accordingly, but haven't tested these yet. I also got SSL working.

Calling all ye gods. Anyone up for the task?

psypher

Scalix on SME
« Reply #22 on: March 29, 2006, 01:20:38 PM »
Yeah your right, i only had to re-install the scalix server component  and keep the message store  and it works again.

doing some reading up on ldap to see if I can figure it out.

started this thread: http://www.scalix.com/community/viewtopic.php?p=8761#8761 on scalix community forum. got a sorta hopefull reply.

silasp

Solved two problems
« Reply #23 on: March 30, 2006, 02:16:37 AM »
I managed to get scalix to start automatically on sme server restart.

Here's what you need to do:
[1] Stop SME conflicting services and also disable on startup)
cd /etc/init.d/

./imap svdisable
./pop3 svdisable
service ldap svdisable
./qpsmtpd svdisable
./smtp-auth-proxy svdisable
./sqpsmtpd svdisable

[2] Make scalix startup automatically on restart
ln -s /etc/init.d/scalix /etc/rc.d/rc7.d/S51scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc7.d/S51scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc7.d/S50sendmail

ln -s /etc/init.d/scalix /etc/rc.d/rc6.d/K03scalix
ln -s /etc/init.d/scalix-tomcat /etc/rc.d/rc6.d/K03scalix-tomcat
ln -s /etc/init.d/sendmail /etc/rc.d/rc6.d/K03sendmail

I have amended the how-to accordingly. Now we just need to get the SME services to talk to the Scalix LDAP (maybe), and spamassasin / clamav integration.

[update] re: send/receive email to/from a remote email address? I just made another edit to the install howto. You have to add sendmail to /etc/hosts.allow before it will send email to external networks.

Here's how:
Configure tcpwrappers to work with sendmail:
mkdir -p /etc/e-smith/templates-custom/etc/hosts.allow
pico /etc/e-smith/templates/etc/hosts.allow/sendmail
Code: [Select]

sendmail: 127.0.0.1


expand-template /etc/hosts.allow

Silas.

silasp

Updated howto
« Reply #24 on: March 30, 2006, 09:29:55 AM »
Hi there.
I just extensively updated the howto. There are numerous enhancements and fixes. It's well worth a look.

We're at the stage now where Scalix basically works with SME, including SSH, spamassassin and clamav. (although I haven't really tested the last two yet, there may be some minor config bugs to sort out).

This is fairly exciting. If we tidy this up a bit more and package the whole thing into an install script, this could really rock!

Cheers,
Silas.

psypher

Scalix on SME
« Reply #25 on: March 30, 2006, 11:57:45 AM »
Awesome, well done silasp, reboot and it all still works. i have done all that you suggested, gonna test the spamassassin and clamav and will let you know. i had an issue with the ssl though, when i try those webpages firefox wants to d/l a BIN file, is this a firefox issue or is there something wrong in the config?

just a note, someone did mention that selinux is the reason why they couldn't run the jk connector, is that the same issue here, if yes how can we disable it or make it work? I couldn't find any selinux stuff on the box but i might be looking in the wrong places.

I agree that getting sme to talk to scalix ldap is the solution, having two ldap's is silly plus then we have to setup ldap synching. but getting sme to talk to scalix is beyond me at the moment, i have to learn it eventually but right now i don't have the time. I will be on holiday from fri 31 till 18 april with no pc at hand so unfortunately i won't be able to help. but lets hope that your request to the sme gods is answered and someone helps us out with that one.

but otherwise well done for getting this working. i will let you know bout the mail filter software

psypher

Scalix on SME
« Reply #26 on: March 30, 2006, 07:24:36 PM »
after spam and antivirus integration i couldn't send mail anymore, i rebooted and saw that half the services did not start, i started them and then mail worked again, rebooted again and now firefox won't allow the pop-up sac and swa to open even though po-ups are off

silasp

scalix
« Reply #27 on: April 03, 2006, 09:16:02 AM »
Thanks for the feedback. Ok, solved the problem with the services not starting - discovered that clamd needs to start before scalix, otherwise the service router does not start.

Also made a couple of other little fixes: restarting clamd, enabling spamd from the user panel (service spamd start does not work properly), and others I have no doubt forgotten.

Have another look at the how-to post.

As for the popup issue, I think it is with firefox. I'm using Firefox 1.5.0.1 on windows 2000, allowing all pop-ups from 192.168.1.x (the scalix server) and I haven't had any issues . It should work with hostnames too.

Cheers,
Silas.

strombergtec

scalix raw
« Reply #28 on: April 04, 2006, 05:39:57 AM »
Has anyone noticed the "scalix raw" complete with permission to redistribute packages?  It also allows you to set the ldap port during setup!  This must be pretty new to their site, as i have not noticed it before.

Could possibly be rolled into an easy to install contrib!

Scalix on SME
« Reply #29 on: April 06, 2006, 12:32:44 AM »
All this work in getting Scalix to an SME server is admirable and I look forward to seeing it finished.  

In the meantime, those wanting to 'play' with Scalix might be interested in trying a 'creative' solution:

I installed Centos 4 on a box, installed Scalix to that and then installed VMWare's new Server (still in Beta) and SME7 as a virtual.

They talk to each other nicely as two separate machines.  Others may see  a number of other advantages in running this sort of environment.


Klaus
......

dkabanga

Scalix on SME
« Reply #30 on: May 12, 2006, 05:31:53 AM »
Any new news on this subject ?

Thx,

Dkabanga

davehg

Scalix - Food for thought....
« Reply #31 on: May 17, 2006, 05:37:52 PM »
Here is what I can tell you after doing some serious research over last few days regarding Scalix on a variety of platforms and the best way to accomplish what I am trying to do (an easy to use MS SBS replacement). Take what you will from it

1. Scalix is using a pre-standard LDAP implementation. This product is old - an evolution of the HP OpenMail product. So linking SME to their LDAP will probably be more trouble than it is worth.

2. You cannot change the LDAP port in the standard Scalix version installers (CE, Small Business, Enterprise).

3. The Community Edition RAW allows you to change LDAP to a different port (they suggest 3890) if you are using an existing instance of LDAP, and redistribute, at the cost of the GUI installer (text only install on CE-R), so perhaps it could be bundled in an RPM with a script to make the needed change to the /etc/redhat-release file, as well as any other changes and then start the installer.

4. If you are looking for ability to host either Scalix Small Business or Enterprise down the road (due to # of Outlook users required), you will need to ask Scalix if you can ugrade CE-Raw to SB or Ent, like you can the standard version of CE, so you retain the modified port, or move it to a different server.

Finally - You WILL need every bit of RAM they say, as I tried it with 416M on an Athlon 850-powered box running SuSE 10.0 OSS for just me and my wife, and it was slow approaching on unusable. The Java rendering of the UI was like watching paint dry. I'd probably suggest no less than 1G or RAM and a 1G Mhz processor or better for a business for snappy performance

davehg

More about Scalix LDAP
« Reply #32 on: May 18, 2006, 03:13:10 PM »
Here is an interesting post on Scalix forum:

http://www.scalix.com/community/viewtopic.php?t=189&highlight=ldap+standard

1. It tells us that Scalix uses LDAP as a translation agent for LDAP data and does not store it in LDAP but in a construct called DIRECTORY

2. It tells us that it can sync it's data to an external instance of LDAP using omldapsync

So....the $20 question...

If we have 2 instances of LDAP running, SME on port 389, and Scalix on 3890 (installed using Community Edition RAW). could we use omldapsync to end the LDAP issues that seem to be core to Scalix running on SME?

davehg

Another useful Scalix forum link
« Reply #33 on: May 18, 2006, 03:30:42 PM »
This one pretty much verified what I stated in my previous two posts:

http://www.scalix.com/community/viewtopic.php?t=2058&highlight=omldapsync

1. That Scalix uses a non-standard LDAP
2. That you can run 2 LDAPs on one box
3. That you can sync the 2 LDAPS using omldapsync

This was a direct reply by the Scalix Moderator to a question about using Scalix's LDAP as the the central LDAP for a company, but I think we can use it to fix the issues that have been mentioned earlier.

ALSO:

Can somone link the HOW-TO that has been mentioned? I cannot seem to find it.

Thanks!

Scalix on SME
« Reply #34 on: May 18, 2006, 05:28:39 PM »
I was assuming that the HOW-TO mentioned is the one that appears on page one of this thread. The last time that I looked, I couldn't find it on the HOW-TO  section of this site...
Ryan

davehg

Scalix on SME
« Reply #35 on: May 18, 2006, 06:38:43 PM »
Thanks Haymann!!!

btw: Old Buffalonians never die, they just thaw out!

D. Gross
SUNY@Bflo class of 90

Scalix on SME
« Reply #36 on: May 19, 2006, 09:10:51 PM »
Quote from: "davehg"
Old Buffalonians never die, they just thaw out!
:lol: We rarely notice the whole global warming thing... :lol:

Thanks for looking at the Scalix integration, I hope to have time to play with this soon. Horde is nice, but Scalix (and Zimbra) look very nice indeed.
Ryan

reiniero

Re: Another useful Scalix forum link
« Reply #37 on: July 07, 2006, 03:08:18 PM »
Quote from: "davehg"
This one pretty much verified what I stated in my previous two posts:

http://www.scalix.com/community/viewtopic.php?t=2058&highlight=omldapsync

1. That Scalix uses a non-standard LDAP
2. That you can run 2 LDAPs on one box
3. That you can sync the 2 LDAPS using omldapsync

....


Hi - PMFJI.
I'm looking into replacing my SME6 box with Ubuntu+OpenLDAP+Samba+Scalix. It seems that one should be able to:
1. run Scalix LDAP on another port than 389.
By using the Scalix raw installer:
http://www.scalix.com/wiki/index.php?title=Scalix_CE_Raw/Installation
see Setting up a Non-Default LDAP Port Number:
edit /var/opt/scalix/sys/slapd.conf, change port number
and in /etc/opt/scalix/webmail/swa.properties:
swa.ldap.1.port=389
swa.ldap.2.port=389
and in
/etc/opt/scalix/caa/scalix.res/config/ubermanager.properties
ubermanager.query.server.port=389

2. Apparently, one should be able to extend the ldap schema for an openldap server with scalix specific info. Then, the scalix LDAP server can hand off authentication requests to the normal OpenLDAP server.
See
http://www.scalix.com/community/viewtopic.php?t=2703&start=0&postdays=0&postorder=asc&highlight=
(at davidz' post of June 13 2006)

1+2 together: it should be possible to keep the existing infrastructure (LDAP-wise anyway), define your users in SME and run Scalix next to it.
Although I haven't tried this in SME, I'm looking at implementing a similar arrangement in Ubuntu.
Hope this gives some hope ;)

Scalix on SME
« Reply #38 on: February 17, 2007, 07:08:45 PM »
Klaus buena idea!

Interesting, you use VMWare Player, which is free too for running SME inside the same box you installed CentOS+Scalix.

Do you think it is an stable solution?

joskra

scalix on sme 7.1
« Reply #39 on: March 24, 2007, 02:35:43 PM »
Is there anything new about installing scalix on sme 7.1??

i installd scalix as written in the howto but i cant open sac or webmail

any ideas??

thanks a lot

Scalix on SME
« Reply #40 on: March 27, 2007, 10:14:53 PM »
Just my 2 cents...

I have a fair amount of experience with SME Server.

I have one production Scalix installation that has been in since last September (I think)..

I have been through one major Scalix upgrade cycle (V 10 to V 11).

Here are a couple of comments:

1) SME is big and complex.
2) Scalix is big and complex.
3) I don't think it is a realistic goal to run them side by side on the same machine.
4) Unless you use virtualization!
5) I have numerous production VMware Server installations and most have SME 7 too.
6) I suggest using SME 7 as the host OS if using VMware Server.
7) I suggest using Centos as the Scalix VM guest OS.
8) Use a beefy machine (my install was on a new dual-Xeon 3.0GHz 4U server with hardware RAID 5).
9) Performance suffers in a (VMware) VM.  (I am about to test Xen on a beefy new server with hardware assisted virtualization).
10) Run performance-critical processes on the host OS, if practical.
11) Anything that uses an Outlook Connector (plugin) will cause you problems beyond your expectations (I have tried several).
12) Wait until the dust settles before upgrading Scalix!  You have been warned.

These comments are all based on experience and only represent my recommendations...not what is possible.

G