Koozali.org formerly Contribs.org

FTP-access doesn't work

Wietse

FTP-access doesn't work
« on: August 17, 2001, 07:22:37 PM »
Somehow, I cannot create proper FTP-accounts on my e-smith server. I can connect to them, but then I get this message:

220 FTP server ready.
331 Password required for wietse.
230 Anonymous access granted, restrictions apply.

I am absolutely sure that I am using the correct password, cause if I enter a wrong one, I don't even get that far:

331 Password required for wietse.
530 Login incorrect.

If I login as above (with the correct password), I can see the files listed in that directory, but I can NOT upload a file to that account:

550 file.exe: Permission denied

I am 99% percent sure that the settings are correct (there must be something wrong though, hehe). In the "remote access" area of the e-smith manager, I've set "FTP user account access:" to "public" and "FTP access limits:" to "normal". Then, in the created i-bay, I've set "User access via file sharing or user ftp:" to "Write = Admin, read = "Everyone", and "Public access via web or anonymous ftp:" to "Entire internet (password required)", as all described in the online manual. But, as stated on top of this message, I can have a proper connection, but I want to be able to upload files! I think it is in the "write = admin" part, but there are no other options......

I am working on this problem for some time now, and I think I tried all the possibilities. Is there anyone who might know what could be wrong!?!?!

Thanks very much in advance!
Wietse (a very pleased e-smith user)
The Netherlands

Michael Maxwell

Re: FTP-access doesn't work
« Reply #1 on: August 18, 2001, 01:04:35 AM »
Hi

As you said

"Write = Admin, read = "Everyone" in your ibay :)

Only the user ~admin has the rights to upload

You need to set up a group and allow the group to have write access to that ibay

Michael Maxwell

Wietse wrote:
>
> Somehow, I cannot create proper FTP-accounts on my e-smith
> server. I can connect to them, but then I get this message:
>
> 220 FTP server ready.
> 331 Password required for wietse.
> 230 Anonymous access granted, restrictions apply.
>
> I am absolutely sure that I am using the correct password,
> cause if I enter a wrong one, I don't even get that far:
>
> 331 Password required for wietse.
> 530 Login incorrect.
>
> If I login as above (with the correct password), I can see
> the files listed in that directory, but I can NOT upload a
> file to that account:
>
> 550 file.exe: Permission denied
>
> I am 99% percent sure that the settings are correct (there
> must be something wrong though, hehe). In the "remote access"
> area of the e-smith manager, I've set "FTP user account
> access:" to "public" and "FTP access limits:" to "normal".
> Then, in the created i-bay, I've set "User access via file
> sharing or user ftp:" to "Write = Admin, read = "Everyone",
> and "Public access via web or anonymous ftp:" to "Entire
> internet (password required)", as all described in the online
> manual. But, as stated on top of this message, I can have a
> proper connection, but I want to be able to upload files! I
> think it is in the "write = admin" part, but there are no
> other options......
>
> I am working on this problem for some time now, and I think I
> tried all the possibilities. Is there anyone who might know
> what could be wrong!?!?!
>
> Thanks very much in advance!
> Wietse (a very pleased e-smith user)
> The Netherlands

Enrico Sørensen

Re: FTP-access doesn't work
« Reply #2 on: August 18, 2001, 03:33:35 AM »
Hey All,
I have some of the same problems. I have created a group teachers and they have read and write access via ftp - via Internet and password. When I update the Ibay it works fine for a while but then after some time a day or 2 you can't connect before a have updated the Ibay again? Is it about cron or?
                                                                                 Best regards Enrico.

Wietse

Re: FTP-access doesn't work
« Reply #3 on: August 18, 2001, 03:21:35 PM »
Thanks for the reply's!
I know that the "problem" is the write=admin, and I know that I can select the write=group thingie. But, I can only set this user in a group if I create a user account. Problem: the user account cannot have the same name as the i-bay. How can I set the i-bay (or user which I have to make), in a group to give it access? I tried some settings, but I cannot work it out...

Any suggestions/ideas?
Thanks in advance!!!

Wietse

Re: FTP-access doesn't work
« Reply #4 on: August 19, 2001, 11:38:42 PM »
FTP-access isn't a problem anymore. People can connect to the server from outside my LAN, see the files and even download them. But, for some reason they cannot upload them.

I've changed the ftp access level from "write=admin" to "write=group". Last thing to do then, is selecting the group for that i-bay. If I select "everyone", then it won't work. If I select new created group, then the group can only contain members who have a user account. But I cannot create a user account with the same name?!?!

So... my point of view at this time: a i-bay is just a folder, and you can create user accounts if someone wants to use that folder (if you put him in the correct group).

But, I see that I when I log in with one of the created user accounts (through an FTP-manager), that I can browse through almost the whole system. I can see all the i-bays (but I can only open those to which I have access), and up-/download things if I have access. Other files are protected.

Is this the way to use it? I think it is a little weird that people can browse the "system" (except the program files themselves). Is there someone who can assure me that NO damage can be done by people who "just belong to a group and for some reason can browse the system"?

Thanks in advance! I am learning more every day... :)

Wietse