Koozali.org formerly Contribs.org

Dantz Retrospect - auto backup fails on client

.nate

Dantz Retrospect - auto backup fails on client
« on: February 02, 2004, 09:30:23 PM »
I use 5.5 server and gateway with mostly Win2k clients.  On my win2k backup server box (which is also a client on the LAN) I use Retrospect 5.11 to run all my automated data backup routines.  When I set up the scripts and connect to the data sources, I have no problems.  Also, when I run the scripts manually everything works fine.  However, for some reason the scripts fail with “Can’t access volume:  error –1017 (insufficient permissions)” every time they run unattended and automated.  I have tried setting the file permissions wide open and it still fails.
 
I am using the Retrospect box to backup other win2k clients only; Not SME.  I use Flexbackup for the 5.5 box.

Is there some sort of Samba issue with share connections being lost relative to other windows boxes after a certain amount of time and/or inactivity?  Even so, why wouldn’t it re-authenticate when the scripts run?
 
Does anyone else have this problem?  
Is there a “duh” answer to this?
 
Thanks,
.nate

nsh

not an elegant solution but it works like a charm
« Reply #1 on: February 26, 2004, 07:42:58 PM »
Since I got no answer to this post I had to take matters into my own hands and find a hack, – this is what I did:
 
As I suspected Samba is “timing out” and the shares get a big red X in windows.  However, as soon as you “look” at them they come back to life.  So, I simply created a “keep-alive” script on the client machine(s) that is run every ten minutes from a Windows “scheduled task”.
 
------------------------------------------
@echo off
 
F:
dir
M:
dir
P:
dir
V:
dir

exit
-------------------------------------------
 
This is not an elegant solution but it works like a charm!  

I believe this “timing-out” of Samba shares is the cause of many automated task errors running from windows clients under samba.
 
Just thinking out loud…  
 
HTH
 
*** If anyone has a better way please let me know.

Offline Boris

  • *
  • 783
Dantz Retrospect - auto backup fails on client
« Reply #2 on: February 26, 2004, 11:19:31 PM »
Did you try to disable power management for the network adapter on the Windows box? Or reconnect (via Script) just before the backup starts?
...