Koozali.org formerly Contribs.org

'Admin member of all groups' problem

Luc Verstraeten

'Admin member of all groups' problem
« on: June 20, 2003, 02:18:14 PM »
Hi,


Is it possible to manually (console) add groups to the server. If so, you could make sure that 'admin' and 'www' aren't members and have a workaround on the 28-groups 'bug'.
Could this be made an option in the 'Lazy Administrator Toolkit'?

Luc

Michiel

Re: 'Admin member of all groups' problem
« Reply #1 on: June 20, 2003, 05:05:51 PM »
> Is it possible to manually (console) add groups to the
> server.

Sure. Use lat-groups from the Lazy Admin Toolkit (http://mirror.contribs.org/smeserver/contribs/mblotwijk/Contribs/lazy-admin-tools/).

Please note that the format of the arguments for lat-groups has changed slightly in 0.7.0.

> If so, you could make sure that 'admin' and 'www'
> aren't members

Funny. In the first release of the LAT there was a bug that prevented you from adding 'admin' to a group. I fixed that in 0.7.0 and now you are asking me to put that bug back in :-).

Seriously, why would you want that? As 'admin' you decide who becomes memeber of a group. If you don't add 'admin' or 'www' to the group, they won't be a member. Or am I missing something?

> and have a workaround on the 28-groups 'bug'.

I'm not aware of a 28-groups bug. What is the issue?

Michiel

Luc Verstraeten

Re: 'Admin member of all groups' problem
« Reply #2 on: June 20, 2003, 05:30:28 PM »
A user cannot be a member of more than 32 groups. This is a Linux thing. (can be changed but...)
In SME, 'admin' and 'www' are members of every group you make, probbably because of rights to access and change the groups made via the server-manager.

A problem arises when you create more than 28 groups in sme (sme creates 4 groups itself which you cannot change) because of the 32-limit. Admin cannot access the server-manager anymore because of admin being removed from the group which has access to server-manager.

It is possible however to create an almost unlimited number of groups within Linux.

What I am trying to accomplish is creating groups without admin in a simple way. This would be a workaround for this 'flaw' in SME. These groups cannot be changed through server-manager of course.

More info: http://forums.contribs.org/index.php?topic=7792.msg28760#msg28760

This 'bug' was first reported in 4.1.2 and solved in 5.0 by not being able to create more than 28 groups via server-manager.

Michiel

Re: 'Admin member of all groups' problem
« Reply #3 on: June 24, 2003, 02:33:04 AM »
I added two options to lat-groups that should solve this problem:

To create a group without 'admin' or 'www':

lat-groups --add --no-admin -c="mygroup | My group"

To remove 'admin' or 'www' from a group:

lat-groups --remove -c="mygroup | admin | www"  

You can download the latest version of the 'Lazy Admin Toolkit' from http://mirror.contribs.org/smeserver/contribs/mblotwijk/Contribs/lazy-admin-tools/

Let me know what you think.

Michiel

Luc Verstraeten

Re: 'Admin member of all groups' problem
« Reply #4 on: June 24, 2003, 02:02:31 PM »
Sorry to tell you but it doesn't seem to work. Admin and www still are memùbers of new groups I create with lat-groups (and the -n or --no-admin option (tried themboth)) .
I installed the rpm with --force option so the original packages should be overwritten. (Checked it to make shure and the version-date is 2003-06-23)

I am working with sme 5.5

Thnx for the effort you put into this BTW!!


Luc

Cyrus

'Admin member of all groups' problem
« Reply #5 on: July 13, 2005, 06:23:31 AM »
Yeah I found this out the hard way too, but it seems if you run the removal it woirks:

lat-groups -r -f -c " * | admin | www"

BUT every time the SME runs something it removes adminand www from the groups and groups- file, admin gets removed from root, www and shared and www gets removed from admin and shared.

So I have setup a script run through cron that runs the lat-groups removal part and a script that looks at the groups and groups- file and adds admin and www to the apropriate places.

But still this requires a reboot for the changes to take place.

Has anyone found a fix for this?