Koozali.org formerly Contribs.org

mail stuck in que

Tim Litwiller

mail stuck in que
« on: May 17, 2003, 09:45:17 PM »
This moning when I went to check my email it says no mail on server since I knew there should be some I started checking the server.  

smtpfront-qmail is recieving the mail but if I check the mailque report in the server manager it says something like

messages in queue: 93
messages in queue but not yet preprocessed: 81

where do I look next,  I have tried restarting  etc....

Nathan Fowler

Re: mail stuck in que
« Reply #1 on: May 18, 2003, 12:36:44 AM »
Look in /var/log/qmail.

Do a ls -la, and tail -f the last file.  Then try sending a message to an account on that box and see what qmail reports.  Chances are it's a permissions issue with your user directories, have you changed anything recently?

Logfiles are definately the first place to look.  Once you isolate an error message I'd try Googling that error and see if there are any fixes.  Keep in mind that SME/E-Smith is based of RH, and uses standard daemons like qmail, so many things applicable to other distributions are also applicable to E-Smith/SME.

Hope this helped,
Nathan

Tim Litwiller

Re: mail stuck in que
« Reply #2 on: May 18, 2003, 12:58:19 AM »
here was the command line I used

cd /var/log
tail qmail/current smtpfront-qmail/current messages maillog  -f

and here is the output - notice that it gets to smtpfront-qmail but it never gets to qmail

I check permissions of the users that might have been added or updated in the last week  and they seem to be ok

I assume you mean the .qmail file specifically

==> smtpfront-qmail/current <==
@400000003ec69428167d687c tcpserver: ok 10851 0:66.136.242.203:25 :12.149.180.171::1596
@400000003ec6942820b55c14 smtpfront-qmail[10851]: MAIL FROM:
@400000003ec6942824cbceb4 smtpfront-qmail[10851]: RCPT TO:
@400000003ec694282e33c04c smtpfront-qmail[10851]: Accepted message qp 11820 bytes 757
@400000003ec69428325e6e9c smtpfront-qmail[10851]: bytes in: 722 bytes out: 168
@400000003ec694283260dbb4 tcpserver: end 10851 status 0
@400000003ec694283260ef3c tcpserver: status: 0/40

==> messages <==
May 17 19:57:18 mailhost named[4966]: lame server resolving '171.180.149.12.in-addr.arpa' (in '180.149.12.in-addr.arpa'?): 208.129.230.27#53
May 17 19:57:18 mailhost named[4966]: lame server resolving '171.180.149.12.in-addr.arpa' (in '180.149.12.in-addr.arpa'?): 207.252.127.27#53

Tim Litwiller

Re: mail stuck in que
« Reply #3 on: May 19, 2003, 03:06:04 AM »
found problem, somehow the log file for qmail had a different user and group permissions so qmail-send could not log what it was doing and failed.

I suspect it was a spam report tool that I was trying that changed the permissions.