Koozali.org formerly Contribs.org

"Access denied" after editing passwd?? HELP!

maestroec

"Access denied" after editing passwd?? HELP!
« on: February 05, 2003, 01:06:24 PM »
Hi there,

I'm running SME 5.6.

After reading a few posts on this forum, I went about editing /etc/passwd directly to give a regular user of mine access to /bin/bash as their shell (trying to run eggdrop on the server, and obviously wouldn't run as root). All I did was change the text '/bin/sshell' to '/bin/bash' and as it didn't work I changed it back.

Now I cannot login on the server itself or via SSH/telnet. All I get with both root and admin with putty for windows are "Access denied". On the server itself, it goes to login, flashes some text, then goes back to the login prompt.

I've tried booting into single user mode to change the root and admin user's passwords (hold CTRL-X, type 'esmith single' and hit enter) but this doesn't work?

I've started prepairing to backup the server and do a format, but I'd really like to avoid this as I've got a pretty established setup with lots of extras at the moment.

Any idea what else I can try?

Thanks in advance.

Gav

Re: "Access denied" after editing passwd?? HELP!
« Reply #1 on: February 05, 2003, 05:47:49 PM »
Have you tried using the emergency boot disk if you havent got one install on another machine and create one!

I wouldnt have recommended editing the /etc/passwd, but Im sure I saw an addon to give you this access not sure where but I have it installed on my machine and can give different shell's.

If I find it il post it on here.

Hope this helps

Gav

Bill Talcott

Re: User Shell RPM
« Reply #2 on: February 05, 2003, 06:13:12 PM »