Koozali.org formerly Contribs.org

No manual entry found for...

Dan Brown

No manual entry found for...
« on: October 30, 2002, 11:50:45 PM »
I've been having some trouble lately with man on my SME 5.1.2 machine.  I've installed the man rpm from the CD-ROM, but it will not find manpages--just responds "no manual entry found".  Here's what happens:

[dan@e-smith dan]$ locate man.1
/usr/share/man/man1/pod2man.1.gz
/usr/share/man/man1/man.1.gz
[dan@e-smith dan]$ man 1 man
No entry for man in section 1 of the manual
[dan@e-smith dan]$ man man
No manual entry for man
[dan@e-smith dan]$ man -d man
Reading config file /etc/man.config
found man directory /usr/local/rav8/man:/usr/share/man:/usr/man:/usr/local/man

using /usr/bin/less -isr as pager

path directory /usr/local/sbin is not in the config file
but there is a man directory nearby
adding /usr/local/man to manpath

path directory /usr/sbin is not in the config file
but there is a man directory nearby
adding /usr/man to manpath

path directory /sbin is not in the config file
and we found no man directory nearby

path directory /usr/local/bin is not in the config file
but there is a man directory nearby

path directory /bin is not in the config file
and we found no man directory nearby

path directory /usr/bin is not in the config file
but there is a man directory nearby

path directory /usr/X11R6/bin is not in the config file
but there is a man directory nearby
adding /usr/X11R6/man to manpath

path directory /home/e-smith/files/users/dan/bin is not in the config file
and we found no man directory nearby

adding mandatory man directories

No manual entry for man

Darrell May

Re: No manual entry found for...
« Reply #1 on: October 31, 2002, 03:24:01 AM »
Check your /etc/man.config for valid entries.  Sounds like your missing variables in your config file.  Usually fixed with an rpm -e man, rpm -Uvh man*.rpm.  I'd also recommend a newer man rpm then what shipped with the 5.1.2 iso.

Darrell

Dan Brown

Re: No manual entry found for...
« Reply #2 on: October 31, 2002, 04:25:33 AM »
I'd looked at man.config, and it looks OK:

[root@e-smith dan]# cat /etc/man.config
MANPATH /usr/local/rav8/man:/usr/share/man:/usr/man:/usr/local/man
[root@e-smith dan]#

I'd also tried reinstalling man, but only with rpm -Uvh --force (I didn't remove it first).  After removing, and then reinstalling, it seems to work.  It's sometimes the simple things that get you...

Now that it's reinstalled, I see a lot of stuff that had been missing from man.config--wonder what caused that.  Thanks for the help!

Charlie Brady

Re: No manual entry found for...
« Reply #3 on: October 31, 2002, 06:27:58 AM »
Dan Brown wrote:

> I'd also tried reinstalling man, but only with rpm -Uvh
> --force (I didn't remove it first).  After removing, and then
> reinstalling, it seems to work.  It's sometimes the simple
> things that get you...

Doing a forced upgrade most likely won't replace the config file. Removing then re-installing will.

> Now that it's reinstalled, I see a lot of stuff that had been
> missing from man.config--wonder what caused that.

I'd check RAV. Do:

rpm -q --scripts rav

and see what it did at install time.

Charlie

Dan Brown

Re: No manual entry found for...
« Reply #4 on: November 01, 2002, 05:27:32 AM »
Charlie, that makes sense as to why removing and then reinstalling worked.  I took a look at the rav scripts, and everything seemed to be fine--I half expected to see a > instead of a >> somewhere, but I didn't.  Since it's an old version of rav, and it's working for me now, I guess I'll drop it (and have a better idea where to look next time).  Thanks for the input!