Koozali.org formerly Contribs.org

Multidrop Problems

Tim H

Multidrop Problems
« on: February 12, 2001, 01:45:07 AM »
I have configured e-smith to use multidrop as the e-mail retrieval mechanism.  Although e-mails sent to indivual users defined on e-smith arrive successfully, it appears that some other e-mails (including e-mails sent to multiple recipeints on the e-smith server) get left in the isp's mailbox.

The user manual seems to suggest providing a different sort header than the default one - problem is the isp does not give any info on this.  What sort header should I use to get down all e-mails?  What is the syntax for creating a sort header?

(I am using e-smith 4.0.1 in server & gateway - dialup mode)

Any assistance would be gratefully appreciated.

Thanks.

Tim.

Jochen Hoegerl

Re: Multidrop Problems
« Reply #1 on: February 12, 2001, 08:49:56 PM »
Try to switch your eMail-Client to show you the complete routing of the eMail.
e.g. If you use Eudora just click on the "blabla-Button". There should be at least
one line with the recipants address, beginning with "X-Delivered-To" or
"Envelope-To" thats what you need as a sorting field.

Tim H

Re: Multidrop Problems
« Reply #2 on: February 16, 2001, 03:36:45 AM »
I checked the header of an email as you adivised and found that I needed the sort header to be X-Envelope-To.  I changed the email retrieval settings to reflect this but the mails would still not come down. (outgoing is fine)

I have the server configured for "short connect" times (day,evening and weekend) and have the email retreival set to every hour during the day and every 2 hours at other times.

The strange thing I have now observed is that the emails will be retreived at very irregular intervals - about once every other day.  I know emails are waiting in the mailbox as I can see them through the web client provided by the isp.

I am wondering whether the short connect time does not give qmail/fetchmail? enough time to get to the pop server.  It dials up and connects at the correct times but only shows a connection of 0.6 - 0.9 minutes - is this long enough to retrieve email?

The only other piece of info I have is that the cron daemon posts the following message to the admin mailbox:
Subject: Cron /etc/startmail

fetchmail: couldn't find canonical DNS name of mail.globalnet.co.uk

Any ideas?